appleschloss

Server Running Crash Course

Recommended Posts

Hey everyone. I've been interested in making a server for my custom modpack, but I know next to nothing about what to do, in every aspect. I've been trying to reach out to people via social media for advice, but I haven't gotten much response, so I wanted to reach out here.

 

I *have* looked at the Technic Tutorial for running a server, but as someone who knows minimal about PCs (but can learn) and has an expensive PC that I don't want vulnerable for attacks, I would like some more information just about running servers in general. Like what is a speed for it to be at? Should I go thru a hosting site or not? If so which one? (I'm willing to pay). What do the numbers all even mean? Some of these expect me to know how to upkeep a server but I don't know any coding at all. I can do BBCode okay, but HTML is still a struggle for me. I do understand what RAM is and some basic things, but a lot of it I just want to be sure on and I'm not.

 

What advice/steps would you give to someone who's never run a sever before but is interested in learning?

Edited by appleschloss

Share this post


Link to post
Share on other sites
29 minutes ago, AetherPirate said:

In order to make a server for Modpack without a ServerPack, please read this tutorial from the Technic Help Site: https://technicpack.zendesk.com/hc/en-us/articles/203799459-How-to-create-a-server-for-your-Platform-modpack

See I was looking over/following that tutorial but this warning at the top

WARNING: Please note that running server software on your computer without a clear understanding of what you are doing may seriously harm your system and lead to vulnerabilities.

Left me very wary and I want to try and learn more about server software and what it does and good tips on RAM, websites to use for hosting, etc, so I don't leave my PC vulnerable, or just heck it up completely.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Butters915
      I know that a few others have reported the problem, but I have not found any solution with me and my friend's world. When we started the world, there were almost no problems with falling through the world or lag or anything. As we progressed, though, this problem got worse and worse, starting with when I died I would fall though the world for 10-20 seconds, and I would spawn back in with little to no problems. This has now gotten to the point where I cannot play on the server because I would be falling through the world and into the void. Once I let it sit for a while and it took almost 30 mins for me to load in, but I was immediately killed, leaving me to fall through the world. We use hamachi to play together and both have pretty mediocre internet, both staying around 6 Mbps on an average day. Also, we both have around 6 gb of ram allocated to technic, so that is not the problem, as we have both tried lowering and increasing ram. Any help would be great!
    • By PrussianSM
      Here is the error log:
      [B#402] 2019/03/17 17:12:57 [INFO]  A detailed walkthrough of the error, its code path and all known details is as follows:
      [B#402] 2019/03/17 17:12:57 [INFO]  ---------------------------------------------------------------------------------------
      [B#402] 2019/03/17 17:12:57 [INFO]  
      [B#402] 2019/03/17 17:12:57 [INFO]  -- Head --
      [B#402] 2019/03/17 17:12:57 [INFO]  Thread: Client thread
      [B#402] 2019/03/17 17:12:57 [INFO]  Stacktrace:
      [B#402] 2019/03/17 17:12:57 [INFO]      at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
      [B#402] 2019/03/17 17:12:57 [INFO]      at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
      [B#402] 2019/03/17 17:12:57 [INFO]      at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:247)
      [B#402] 2019/03/17 17:12:57 [INFO]      at org.lwjgl.opengl.Display.createWindow(Display.java:306)
      [B#402] 2019/03/17 17:12:57 [INFO]      at org.lwjgl.opengl.Display.create(Display.java:848)
      [B#402] 2019/03/17 17:12:57 [INFO]      at org.lwjgl.opengl.Display.create(Display.java:757)
      [B#402] 2019/03/17 17:12:57 [INFO]      at org.lwjgl.opengl.Display.create(Display.java:739)
      [B#402] 2019/03/17 17:12:57 [INFO]      at net.minecraft.client.Minecraft.func_175609_am(Minecraft.java:645)
      [B#402] 2019/03/17 17:12:57 [INFO]      at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:458)
      [B#402] 2019/03/17 17:12:57 [INFO]  
      [B#402] 2019/03/17 17:12:57 [INFO]  -- Initialization --
      [B#402] 2019/03/17 17:12:57 [INFO]  Details:
      [B#402] 2019/03/17 17:12:57 [INFO]  Stacktrace:
      [B#402] 2019/03/17 17:12:57 [INFO]      at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:378)
      [B#402] 2019/03/17 17:12:57 [INFO]      at net.minecraft.client.main.Main.main(SourceFile:123)
      [B#402] 2019/03/17 17:12:57 [INFO]      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [B#402] 2019/03/17 17:12:57 [INFO]      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      [B#402] 2019/03/17 17:12:57 [INFO]      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      [B#402] 2019/03/17 17:12:57 [INFO]      at java.lang.reflect.Method.invoke(Unknown Source)
      [B#402] 2019/03/17 17:12:57 [INFO]      at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
      [B#402] 2019/03/17 17:12:57 [INFO]      at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
      [B#402] 2019/03/17 17:12:57 [INFO]  
      [B#402] 2019/03/17 17:12:57 [INFO]  -- System Details --
      [B#402] 2019/03/17 17:12:57 [INFO]  Details:
      [B#402] 2019/03/17 17:12:57 [INFO]      Minecraft Version: 1.12.2
      [B#402] 2019/03/17 17:12:57 [INFO]      Operating System: Windows 10 (amd64) version 10.0
      [B#402] 2019/03/17 17:12:57 [INFO]      Java Version: 1.8.0_201, Oracle Corporation
      [B#402] 2019/03/17 17:12:57 [INFO]      Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
      [B#402] 2019/03/17 17:12:57 [INFO]      Memory: 2664855160 bytes (2541 MB) / 3087007744 bytes (2944 MB) up to 3087007744 bytes (2944 MB)
      [B#402] 2019/03/17 17:12:57 [INFO]      JVM Flags: 3 total; -Xms3072m -Xmx3072m -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump
      [B#402] 2019/03/17 17:12:57 [INFO]      IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
      [B#402] 2019/03/17 17:12:57 [INFO]      FML: 
      [B#402] 2019/03/17 17:12:57 [INFO]      Loaded coremods (and transformers): 
      [B#402] 2019/03/17 17:12:57 [INFO]      Launched Version: 1.12.2-forge1.12.2-14.23.5.2810
      [B#402] 2019/03/17 17:12:57 [INFO]      LWJGL: 2.9.4
      [B#402] 2019/03/17 17:12:57 [INFO]      OpenGL: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.
      [B#402] 2019/03/17 17:12:57 [INFO]      GL Caps: 
      [B#402] 2019/03/17 17:12:57 [INFO]      Using VBOs: Yes
      [B#402] 2019/03/17 17:12:57 [INFO]      Is Modded: Definitely; Client brand changed to 'fml,forge'
      [B#402] 2019/03/17 17:12:57 [INFO]      Type: Client (map_client.txt)
      [B#402] 2019/03/17 17:12:57 [INFO]      Resource Packs: 
      [B#402] 2019/03/17 17:12:57 [INFO]      Current Language: ~~ERROR~~ NullPointerException: null
      [B#402] 2019/03/17 17:12:57 [INFO]      Profiler Position: N/A (disabled)
      [B#402] 2019/03/17 17:12:57 [INFO]      CPU: <unknown>
      [B#402] 2019/03/17 17:12:57 [INFO]  [17:12:57] [Client thread/INFO] [STDOUT]: [net.minecraft.init.Bootstrap:func_179870_a:553]: #@[email protected]# Game crashed! Crash report saved to: #@[email protected]# C:\Users\Administrator\AppData\Roaming\.technic\modpacks\1121-millenaire\crash-reports\crash-2019-03-17_17.12.57-client.txt
      [B#402] 2019/03/17 17:13:13 [INFO] Attempting to open C:\Users\Administrator\AppData\Roaming\.technic\logs
      [B#402] 2019/03/17 17:13:13 [INFO] Using file:/C:/Users/Administrator/AppData/Roaming/.technic/logs/
      [B#402] 2019/03/17 17:13:13 [INFO] Intermediary path file:///C:/Users/Administrator/AppData/Roaming/.technic/logs/
      I also have the latest x64 Java
    • By StarZ563
      This makes me salty https://pastebin.com/dsARRYtN
    • By StarZ563
      Why won't this Badmobs config work? https://pastebin.com/WfTJTm4z
    • By RobloxIsDead
      Read the title.
       I think it may have something to do with this line:
      liblwjgl64.so: failed to map segment from shared object   2019-03-01-2.log