Jump to content

Recommended Posts

So I made a modpack, and it works, however, I also made a server package, that doesn't work.
I followed some tutorials on the internet and none of them fixed the issue.

Here's my log

Quote

 

C:\Users\Keith\Documents\KLS\New folder>java -Xmx2G -Xms1G -jar "forge-1.7.10-10.13.4.1614-1.7.10-universal.jar" nogui
A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.base/java.lang.reflect.Method.invoke(Unknown Source)
        at cpw.mods.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:43)
        at cpw.mods.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:12)
Caused by: java.lang.ClassCastException: java.base/jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to java.base/java.net.URLClassLoader
        at net.minecraft.launchwrapper.Launch.<init>(Launch.java:34)
        at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
        ... 6 more

C:\Users\Keith\Documents\KLS\New folder>java -version
java version "10.0.2" 2018-07-17
Java(TM) SE Runtime Environment 18.3 (build 10.0.2+13)
Java HotSpot(TM) 64-Bit Server VM 18.3 (build 10.0.2+13, mixed mode)

C:\Users\Keith\Documents\KLS\New folder>pause
Press any key to continue . . .


 


 

Link to post
Share on other sites
59 minutes ago, sliggybiggy said:

So I made a modpack, and it works, however, I also made a server package, that doesn't work.
I followed some tutorials on the internet and none of them fixed the issue.

Here's my log


 

Y'know, except that one reply where I told not to use Java 10, but java 8. Oh wait, multiple posts over the past few months.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By Vasiva
      Hi everyone, I'm searching for cheap hosting preferably up to 13$ for 1month where I can play with my friends. I want to set up 1.12.2 pack on this serwer and recommended RAM is 3,5GB and space disk slightly above 3GB. I'm from Europe and want hosting to be in Europe so my ping will be normal. Any recommendations? Thanks for help
    • By mojiwoji
      I'm pretty sure this will be an easy fix. FML starts working, then it finishes. Screen turns white, then red, then black. After that, it crashes. Here is the info...
       
       
      crash-2020-08-30_20.55.33-client.txt
    • By Justous
      Hi everyone,
      Despite my best efforts and reading several previous posts from this very form, my modpack keeps launching as if forge isn't installed. The mods and config folders and filled out and the modpack.jar is present in the bin folder upon install, but something just isn't happening. It seems like there must be something really obvious I'm missing...
      Here's a link to my modpack's zip: https://www.dropbox.com/s/m9pxkwagken6o02/muscraft.zip?dl=1
      Anyone have any idea what is wrong?
    • By DarkHyperion12
      I am making a pack for my friends and am wondering why my pack is not working. Can you please help me out?
       
      https://www.technicpack.net/modpack/froschreich-modpack.1725094
    • By aron9forever
      Hello, so i have been building on my tekkit classic map and while i was building, minecraft crashed with "Saving Chunks" screen. When i went to rejoin, it said "Simulating the world for a bit.." and after that "Saving chunks" and white screen.
      My techniclauncher log:
      https://privatebin.net/?e3752af48fe736a1#873mR1KLxx8hPqXt
      ______
      I FIXED IT! THE ISSUE WAS THAT I HAD SOME BROKEN ENERGY TELEPORTERS!
      if i remember correctly, i made this before the game crashed. https://prnt.sc/tk5lq4
×
×
  • Create New...