• 0
NebelC0meback

Linux: After install and creation of technic directory, the launcher wont start again.

Question

Posted (edited)

 

Hello people of the Technic community, I've had this problem for around 3 weeks now, and after countless hours of research i couldn't get it to work.

I've got the following problem:

I've been using Ubuntu (PoPOS) for around 2 months now, and i got really familiar with it. I got minecraft from the repositories no problem whatsoever. But as i wanted to play with mods, My old friend Technic Launcher came to my mind again, so i tried to install it and play some modpacks.

Problem:

I've installed the correct java version (OpenJDK 8 ) and put the techniclauncher.jar as an executable. Now when i run the launcher, the installation screen pops up, everything normal. Now when i install it as a portable or just normally, it creates the directory and the installer dissapears. Everything ok until now: When i try to launch Technic again, it just crashes. The java process is running, but starts dissapearing. So i tried again with oracle Java 11. Same problem. It just crashes. When i launch it over Terminal, it gives me this:

 

[email protected]:/home/muenzlpsaveyourinternet# java -jar '/home/directory/TechnicLauncher.jar' '/home/directory/TechnicLauncher.jar'
Settings for exe: /home/directory/TechnicLauncher.jar
Portable settings dir: /home/directory/technic
Setting up logging

And nothing else happens, the terminal doesnt continue launching, same with launching without terminal.Nothing opens , just the process i can see in my system manager

I tried and tried, i uninstalled the runtimes, 8 and 11, tried and tried but nothing worked. I found no answer, now after 2 weeks of trying, I decided to post this here to get some answers from nice people who like to help in the community.

If you like to help me, just post solutions or suggestions in the section down, please stay simple with ubuntu stuff since i am really new to linux and just getting started. Thanks for any response.

(replaced my install directory with directory because its pretty much useless for help and might confuse people)

 

Edited by NebelC0meback

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Omeruin
      I wasn't going to have this modpack on Technic, but, I want to play with all the chosen mods on there just in case my friends want to join me at anytime.
      ---
      I've uploaded a different modpack before, personal like this one, and it worked out just fine. This one does have wayyy more mods so something different is definitely going on. Downloading the modpack is fine, it is hosted on Dropbox. However, when I try to 'play' the modpack, it loads a few things before Minecraft assets, then waits a bit, the Launcher disappears, and then the launcher reappears; meaning something crashed/is not loading right.
      Here is the crash log from Technic: { https://pastebin.com/rz39VrR3 }
      Any help would be appreciated. I tried to skim through the log myself, but it is definitely confusing for me.
      Sorry if this is in the wrong topic, or that something isn't right, I'm typing as fast as I can before I go to work (I'll be able to respond within 8-9 hours from now).
    • By QuitStealingMyUserName
      Hey folks, I made a modpack, "Title Made To Not Plagiarize" and loaded it with a few different mods. When I install the pack from the Technic Launcher, it seems to download the zip I uploaded to Dropbox, but doesn't seem to actually install the mods. Some of the mods are older versions, but it shouldn't be a problem with most of them. (Here's the link for the file: https://dl.dropboxusercontent.com/s/iynms0xi9ifl1e2/TMTNPv2.0.1.zip). Any help would be appreciated, and my forge version is forge-1.12.2-14.23.5.2847-universal.jar. This is my first modpack so please be forgiving.
    • By Pollastre
      I am playing tekkit on a minecraft server. I use optifine and recently the game keeps crashing. I use the official launcher on Tekkit Legends version 1.1.1. Here is my latest crash report. https://pastebin.com/tzmHd8Jp
    • By TheNick
      I've been having an issue with technic launcher as it won't launch anything, it will simply load then the program refreshes and nothing happens, minecraft by itself can launch just fine with no problems but technic won't for some reason, I've done just about everything including:
      1. Reinstalling Technic
      2. Reinstalling java (64 bit)
      3. Reinstalling Minecraft
      4. snooping around the files
      Technic also doesn't leave me with any error messages, it just flashes and goes back to pretending it never did anything in the first place
      please help