Jump to content

Latest EnderIO crashes on start only with technic launcher - SOLVED


Recommended Posts

Hello!

I've recognized a strange behaviour of the technic launcher when I tried to update my other modpack with the latest EnderIO & Endercore.

It seems that something in the mod has changed, so the technic launcher has it's problem with it.

to prevent strange inter-mod behaviour, i created a modpack with only forge ( 14.23.5.2838 ) and the 2 mods: EnderIO (5.1.51) & EnderCore ( 1.12.2-0.5.69 ).

Before anyone declares this as an modpack issue: it isn't. it is working fine on other launchers:

Technic Launcher: crash (java.lang.NoSuchFieldError: ELYTRA)

Original Minecraft Lancher: runs

new Minecraft Launcher: runs

MultiMC: runs

The test pack i've created can be found here: https://www.technicpack.net/modpack/bkm-testpack.1544969

 

The log of the launcher (with the crash during startup of the modpack) can be found here: https://hastebin.com/tafuyezuyi.coffeescript

The crash report is here: https://hastebin.com/wimomegixo.pl

How to fix?

Thanks! BR, Michael

 

Bigger Edit: In the Meantime i contacted the Mod Authors. In their last update they included a check for a class which should load early:

static {
    if (com.mojang.authlib.minecraft.MinecraftProfileTexture.Type.ELYTRA.getClass().toString().equals("force a classload real hard")) {
      // this will crash some pirated clients.
      // better now than some weird and seemingly random crashes later in the game.
    }
  }

The technic launcher itself seems to handle the authlib different than all other launchers.

The problem is, that this class is not loaded when it should be, so the routine above fails and lets the boot-up crash.

is this a bug? I think the technic launcher devs are needed to look into this.

 

EDIT: After reinstalling technic launcher, it seemed to work again.

 

Edited by BlueKingMuch
Link to post
Share on other sites
  • 8 months later...
Guest
This topic is now closed to further replies.
×
×
  • Create New...