Sign in to follow this  
Graziservers

Extremely Low TPS - Need a solution.

Recommended Posts

I'm running on a dedicated server with a xeon core and 16 gigs of RAM, There is no reason my server should be getting ~8TPS with ~ 20 players on. Maybe some of you have experience with some of my plugins.

Also I am using 100% of a core, since minecraft only uses one.

Here is a FULL list of my plugins, even the givens.

AutoRank

ChatManager

ChestShop

EnjinMinecraftPlugin

Essentials

EssentialsSpawn

LagMeter

MobBountyReloaded

ModifyWorld

OpenInv

PermissionsEX

Residence

ScheduledAnnounce

SWatchDog

TekkitCustomizer

Vault

Votifier

WorldEdit

WorldGuard

Please post any suggestions.

**Update**

It's so terrible, that It took over a minute to stop the server.

Not sure if that helps to diagnose the problem

Share this post


Link to post
Share on other sites

A Xeon core what?

And chances are its just some bad builds in your world.

Check for EU, Item, Redpower loops etc...

Since you don't have LagClear check for the number of entities.

Share this post


Link to post
Share on other sites

There is an abnormally high amount of mobs spawning.

Are any of the 'lag prevention' plugins recommended?

Also I installed nolagg just a second ago to try to use the examine feature. Here is what is shows after a 25 second exam...

7f2c939aac514604a074d6877127576b.png?135

Share this post


Link to post
Share on other sites

I think you have a corrupt chunk... grab (tekkitrestrict?*) and do /tpic (nolagg might have something similar...) (it's that or a leaky pipe - hopefully its the latter)

*Having never needed it, I dont know which plugin gives the /tpic command. But it teleports you to any chunk with more than 200 entities in.

and LaggClear really helps keep entities down, you can even set it so it only clears when there are more than a given number of entities in the world.

Share this post


Link to post
Share on other sites

Kill your mobs... users dont like it but mob AI is badly coded and creates a lot of lag.

Grab nospawnchunks, nice little plugin to reduce chunk loading and its nice and light.

Upgrade your tekkit to cb++ or cb-- google tekkit spigot (I forget the url)

Turn off everything in nolagg bar the examiner, nolagg sucks.

Most of all dont even bother looking into java gc edits just yet. Most people see tps drop and try crazy command lines that make things worse.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this