Jump to content

Constant roadblocks while making a modpack


Recommended Posts

I've been working on a mod pack for a couple days now and every time it came to test it through Technic it has failed. After countless times of showing up as a generic 1.12.2 vanilla game, I finally managed to get it to read as modded (lack of .jar suffix and wrong forge version) and after getting all the duplicate mods out and getting the rest of them compatible, it finally starts to load longer than any time I've tried. But of course the pack crashes at the 2/7 loading mark. Spending a good deal of hours trying to get this to work just for it to stop abruptly as usual when I think it's going to work is kind of a let down. So I figured it was time to get some outside help. Sorry for the long read, first time posting in a forum. But I came here to ask some of you guys if you got any helpful advice that'll help me out of this standstill.

Here's the Dropbox link: https://www.dropbox.com/s/hm1higc4zwo4n1g/cosmicconquest14.jar?dl=1

and here's the pack link: http://api.technicpack.net/modpack/the-space-bound-conquest-pack

Any help whatsoever will be greatly appreciated. Thank you.

Link to comment
Share on other sites

Why is your modpack a .jar and not a zip? Why is it close to 1 GB in size? Oh, you seem to have a lot of duplicate Train content packs in your modpack. That seems to be the bulk of the size bloat. It would probably also cause it to abort at 2/7 due to "duplicate mod found" errors.

Link to comment
Share on other sites

For the .jar part, a lot of the tutorials were a bit confusing and I just thought that's what i was supposed to use (seeing it worked after making a few tweaks as well as the .jar suffix swap. So I'm guessing the pack being a .jar had no relation to the function.) I'll swap it back over to .zip and root around and delete the duplicates and try it again. (Edit>) I changed it over to .zip and looked around for the duplicate train stuff but I only found the one folder (IRLegacy) and most of the stuff in it didn't seem like duplicates. also I tried booting it up again and it was crashing as soon as it was reaching 3/7 (This might have also been the case for the version I Initially posted for, instead of at the 2/7 mark.)   

Edited by TheFancyShotgun
Link to comment
Share on other sites

There's an Immersive vehicles folder in your mods folder. It contains all kinds of large content packs that are also included in the mods folder itself.

[B#510]  java.lang.RuntimeException: Invalid id 4096 - maximum id range exceeded.
[B#510]      at net.minecraftforge.registries.ForgeRegistry.add(ForgeRegistry.java:295)
[B#510]      at net.minecraftforge.registries.ForgeRegistry.add(ForgeRegistry.java:281)
[B#510]      at net.minecraftforge.registries.ForgeRegistry.register(ForgeRegistry.java:113)
[B#510]      at net.minecraftforge.registries.ForgeRegistry.registerAll(ForgeRegistry.java:154)
[B#510]      at net.mcreator.wrd.wrd.registerBlocks(wrd.java:87)
[B#510]      at net.minecraftforge.fml.common.eventhandler.ASMEventHandler_2187_wrd_registerBlocks_Register.invoke(.dynamic)
[B#510]      at net.minecraftforge.fml.common.eventhandler.ASMEventHandler.invoke(ASMEventHandler.java:90)
[B#510]      at net.minecraftforge.fml.common.eventhandler.EventBus$1.invoke(EventBus.java:144)
[B#510]      at net.minecraftforge.fml.common.eventhandler.EventBus.post(EventBus.java:182)
[B#510]      at net.minecraftforge.registries.GameData.fireRegistryEvents(GameData.java:845)
[B#510]      at net.minecraftforge.fml.common.Loader.preinitializeMods(Loader.java:630)
[B#510]      at net.minecraftforge.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:252)
[B#510]      at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:467)
[B#510]      at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:378)
[B#510]      at net.minecraft.client.main.Main.main(SourceFile:123)
[B#510]      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[B#510]      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
[B#510]      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
[B#510]      at java.lang.reflect.Method.invoke(Unknown Source)
[B#510]      at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
[B#510]      at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

Add this mod: https://www.curseforge.com/minecraft/mc-mods/notenoughids/files

Edited by JaariAtmc
Link to comment
Share on other sites

11 hours ago, TheFancyShotgun said:

I completely removed (to my knowledge) all of the stuff for Immersive vehicles and it's still not wanting to work properly. Should I try getting rid of the railroading too?

Did you even read the second part of my comment?

Link to comment
Share on other sites

  • 3 months later...

I ended up getting it to work. After getting the Not Enough Ids mod and adding/removing other mods It wasn't reading as modded anymore a while later I realized I was putting the whole modpack file in the zip (modpack contents>modpack>modpack.zip) instead of the correct way (Modpack Contents> modpack.zip) and that's why it stopped reading it as modded. But anyway I ended up getting it to work, Thanks for your help. 

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Similar Content

    • By Omega_Volta
      I was planning on using some mods, but when I opened the modpack I intended to use, it just shut down and sent me back to the launcher screen. 
      I've tried removing the mods, uninstalling and reinstalling the modpack, updating my launcher, updating java, and restarting my computer, to no avail.
      Down below is the log in pastebin:
    • By BloodScythe
      https://pastebin.com/kRLp5Y2Y These are the error msgs, I have already tried re installing the pack, restarting the launcher, updating the pack, any more ideas?
    • By M3veronMast3r
      Hello, I didn't know where to put this Thread, sorry for that.
      My Problem is that i want to create more than only 5 Modpacks. I have different Packs in different Version and i need them all and i dont want to create constantly an new account just to create a new Modpack. I dont understand why this Action is limited to 5 Modpacks. It makes no sense to me. Is there any way to create more than only 5?
      Hope you can help me. ~M3veronMast3r
    • By 4net_E
      LAUNCHER VERSION: v4.664
      OPERATING SYSTEM: macOS 10.14.6
      JAVA VERSION: Oracle 1.8.0_261 64-Bit
      ANTIVIRUS: none
      recently I tried to play some modpacks, but i couldnt start any of them. Every time I wanted to launch them, icon of the modpack showed up in taskbar, window popped up, but after approximately a second, it had crashed.
      I tried to solve this problem by myself, but I didnt manage to success. The closest Ive got to solution was in this thread :
      However, there is a solution linked on another forum thread, but that link is probably corrupted or something, as it just redirected me to the same thread all over again. Thus Im stuck and seek help. This is a log after one of the unsuccessful launch attempts: https://pastebin.com/Md4yW3yw
      For any kind of suggestions or additional information request I'd be very thankful
      Okay, fortunately under this post's recommended threads I've found another new thread which stated a similar problem: 
      The solution right there seems to do the job (at least temporarily), but still, I'd like to know the core of the problem, for example - why 8u251 works and 8u51 doesn't?
      Hope this helps someone someday
    • By CStan96
      I'm at a loss. I've been playing my modpack for a month now and after updating to 1.16.5, it fails to launch as it loads Minecraft assets. I managed to get it to launch once, but it was vanilla Minecraft.

      RAM: 8gb
      MC Version: 1.16.5
      Forge: forge-1.16.5-36.1.0-installer
      Pastebin won't work (404 error) so here's the error log:
  • Create New...