Jump to content
yoinkazoinka

What does it mean by my edition of java is known to have issues with minecraft?

Recommended Posts

I'm on a Mac. I downloaded java a while ago, and I didn't know it had different versions and all. The exact message is  "You've selected Java 13.0.1, which is known to have issues with Minecraft. Are you sure you want to continue?" When I select yes, it doesn't actually load the mod. What do I do to fix this?

Share this post


Link to post
Share on other sites

That means you have to downgrade to Java 8. And remove java 13. What did you think would happen when it said that it is known to have issues with minecraft?

Share this post


Link to post
Share on other sites

New java versions changed a lot of what forge used for their "hacky" classloaders. Forge needs to be updated to match these, but with how fast releases have been coming out recently (5 releases in 3 years verses 1 release in 3 years for 7 -> 8). AFAIK Forge for 1.13+ was being re-written for Java 9, below that you need Java 8. For reference:

image.png.5a8f68f23d2f783bbbf1d56ec6047a49.png

Java 8 is listed as Long Term Support (LTS), and will continue receiving security updates through 2020, so you shouldn't have any reason not to install it.

Not to mention Java's new licensing, which is clear as mud -_-

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...