Jump to content

Tekkit Lite 0.5.2 log in errors, and Ticking world entities.


Recommended Posts

Between myself and several users on a private server, we have achieved several different errors that get us instantly removed from the server.

the three I have seen so far are: Ticking world entities, Could not render 'tanks', and of course 'Unexpected Error'. I only have the last two crash reports if anyone wants them.

Anyway, I would go back to 0.5.1, except after about 10 minutes of running, the server crashes do to ticking world entities. I have had the server running for... at least a week now, and we have experimented with Mystcraft, IC2, Red Power, computer craft, and most recently, buildcraft.

Can someone please tell me what a ticking world entity is?

(sorry if this question has already been asked and answered, I am just having a crap day, and I don't want to search a forum.)

Link to post
Share on other sites

I'm going to assume it refers to TPS, meaning ticks per second. Normally, it should be 20 TPS, the default MC ticks. When it's lower it means that either the CPU is having trouble keeping up or the I/O is bottlenecking. Of course it could be any other hardware or software cause, but these are the most common.

Link to post
Share on other sites

well you have part of it right. what it means by "ticking world entity" is that it is updating, or ticking, some object and that object is exploding in a most terrible fashion because of it. except for the exploding part, this is what happens every tick normally. every machine/object/thing has a function that is called when a tick happens that it uses to update itself. when that function is running, the entity is ticking.

I'm going to guess you had some railcraft stuff, didn't notice that the new tekkit lite doesn't include railcraft, upgraded, and now it has no idea what to do with railcraft tanks and other stuff (like the special carts, etc).

Link to post
Share on other sites

well you have part of it right. what it means by "ticking world entity" is that it is updating, or ticking, some object and that object is exploding in a most terrible fashion because of it. except for the exploding part, this is what happens every tick normally. every machine/object/thing has a function that is called when a tick happens that it uses to update itself. when that function is running, the entity is ticking.

I'm going to guess you had some railcraft stuff, didn't notice that the new tekkit lite doesn't include railcraft, upgraded, and now it has no idea what to do with railcraft tanks and other stuff (like the special carts, etc).

Nope. I pretty much forbade my users from using railcraft as I knew it was gonna be removed. However, I also got this problem in the 0.5.1 server, near the end of its life.

I'm going to assume it refers to TPS, meaning ticks per second. Normally, it should be 20 TPS, the default MC ticks. When it's lower it means that either the CPU is having trouble keeping up or the I/O is bottlenecking. Of course it could be any other hardware or software cause, but these are the most common.

And how do I go about solving this, when everything has been fine for the past week? None of hardware is acting up, and I have installed no new software... And I almost never have the 'server cannot keep up' dialogue. And when I do, it's because I have like, 50 internet tabs open doing research on how to do things in tekkit.

Link to post
Share on other sites

Nope. I pretty much forbade my users from using railcraft as I knew it was gonna be removed. However, I also got this problem in the 0.5.1 server, near the end of its life.

that's all well and good, but if you are getting errors about "tanks" being unable to render, I've got news for you: there's only 2 tanks in tekkit and we don't have any kind of modern war vehicle mods. it's unlikely that it is BC tanks that are dying, sooo RC is what's left.

if you want more detail than that, an actual error log will be required. if you post one though, please use pastebin or something.

And how do I go about solving this, when everything has been fine for the past week? None of hardware is acting up, and I have installed no new software... And I almost never have the 'server cannot keep up' dialogue. And when I do, it's because I have like, 50 internet tabs open doing research on how to do things in tekkit.

the dude was guessing (poorly, I might add). what he said has nothing to do with anything.

Link to post
Share on other sites

that's all well and good, but if you are getting errors about "tanks" being unable to render, I've got news for you: there's only 2 tanks in tekkit and we don't have any kind of modern war vehicle mods. it's unlikely that it is BC tanks that are dying, sooo RC is what's left.

if you want more detail than that, an actual error log will be required. if you post one though, please use pastebin or something.

Well, the first line of crash report two is "at buildcraft.factory.render.RenderTank.a(RenderTank.java:96)" So... I think it is buildcraft tanks. But I only got that error once.

And after looking at the other crash reports, it seems all three have that in common... To pastebin!

Note, these only apply for when I was using 0.5.2

http://pastebin.com/9v7VjT2f

Link to post
Share on other sites

This is a fantastic example of why providing incomplete information is a terrible idea. That is clearly bc tanks as you mentioned. I'm not at home right now, but I'll check your log out later when I get a chance

Admittedly, I didn't know that railcraft had tanks... So there is that, but yah, I probably should have provided the error logs from the get-go, eh?

Link to post
Share on other sites

a little looking around and some guesswork tells me that the most likely issue is a BC tank that is holding something that no longer exists, like creosote oil. were there any creosote oil filled BC tanks hanging around? if so, use worldedit to go in and remove them. hopefully that will fix the problem.

Link to post
Share on other sites

a little looking around and some guesswork tells me that the most likely issue is a BC tank that is holding something that no longer exists, like creosote oil. were there any creosote oil filled BC tanks hanging around? if so, use worldedit to go in and remove them. hopefully that will fix the problem.

Creosote no longer exists? Really? Wait... was that a part of railcraft?

Anyway, I'll get around to doing that tomorrow... Then I'll let you know what happens. Thanks for the tip.

Link to post
Share on other sites

a little looking around and some guesswork tells me that the most likely issue is a BC tank that is holding something that no longer exists, like creosote oil. were there any creosote oil filled BC tanks hanging around? if so, use worldedit to go in and remove them. hopefully that will fix the problem.

Next level of error reports:

http://pastebin.com/03eS6Zcf

Honestly, I think it might be easier to start a new bloody world... which I really don't want to do... Recommendations? (also, using MCedit turned most of our things into other things. But that's probably because of the 4096 error thing...)

Link to post
Share on other sites

Creosote no longer exists? Really? Wait... was that a part of railcraft?

yes, it was.

Next level of error reports:

http://pastebin.com/03eS6Zcf

Honestly, I think it might be easier to start a new bloody world... which I really don't want to do... Recommendations? (also, using MCedit turned most of our things into other things. But that's probably because of the 4096 error thing...)

uhh well, it sounds like MCedit did a number on stuff which is probably the cause of the new errors. I'll be honest, I don't know what to do about that =/

Link to post
Share on other sites

uhh well, it sounds like MCedit did a number on stuff which is probably the cause of the new errors. I'll be honest, I don't know what to do about that =/

Well, thank's for trying. I'm just gonna build a new world, and ignore everyone's complaints. Especially my own :)

Actually, one more thing you could do to help me.

http://pastebin.com/5ExhJUgM

That's the crash report for my 0.5.1 server. If you have any idea how to fix that... well, it'll make everyone involved a lot happier, me thinks.

Link to post
Share on other sites

Well, thank's for trying. I'm just gonna build a new world, and ignore everyone's complaints. Especially my own :)

Actually, one more thing you could do to help me.

http://pastebin.com/5ExhJUgM

That's the crash report for my 0.5.1 server. If you have any idea how to fix that... well, it'll make everyone involved a lot happier, me thinks.

that error is unfortunately very generic, and I can't find what yc.h does or handles via some quick googling. thanks mojang, for continuing to obfuscate your code so stack traces are goddamn unreadable and useless.

Link to post
Share on other sites

that error is unfortunately very generic, and I can't find what yc.h does or handles via some quick googling. thanks mojang, for continuing to obfuscate your code so stack traces are goddamn unreadable and useless.

Well, if you don't feel like keeping up the search, that's fine be me. You've helped me more than enough, and if you were some sort of service professional, I would give you a gold star :)

Link to post
Share on other sites

I was curious so I downloaded MCP for 1.4.6 and looked up the mappings. yc is the World class, and the "h" function isn't named anything fancy or informative. so yeah, got no clue. some array in the world class is out of bounds for one reason or another.

edit: I just realized that the file names are right there in the error log (world.java). still, MCP would have been where I needed to look for function or field info I guess.

Link to post
Share on other sites

I was curious so I downloaded MCP for 1.4.6 and looked up the mappings. yc is the World class, and the "h" function isn't named anything fancy or informative. so yeah, got no clue. some array in the world class is out of bounds for one reason or another.

edit: I just realized that the file names are right there in the error log (world.java). still, MCP would have been where I needed to look for function or field info I guess.

I have no idea what that means :)

Link to post
Share on other sites

I seriously ask my self...really, how can a mod team ,where you should expect technical knowledge, just remove a mod ( in this case reailcraft) that fu***** crashes everybody's server, without giving a BIG WARNING??????

Any hint here? haha... fuck no!

Tekkit Lite is here and it's awesome. You can read all about it in this post here http://www.technicpack.net/tekkit-lite-is-now-available/ and you can chat all about it in this here forum.

And here.....all the content is "bla bla great bla bla 1.4.6.....way more general bla bla bla"

The only hint is, the MystCraft thing..nothing else.

It’s finally here! A new version of Tekkit for Minecraft 1.4.6! One geared for smaller servers that takes advantage of the new way Minecraft handles multiplayer. Arising out of the chaos that is the forgebukkit fiasco, we present Tekkit Lite. The original Tekkit has also been renamed to Tekkit Classic.

Why is it called Tekkit Lite? It’s definitely not because of a shortage of mods. Tekkit Lite has no out-of-the-box Bukkit support like Tekkit Classic had. We include ForgeEssentials which is a forge mod that hopes to replace some of the most common Bukkit plugins all in one package. It’s made a lot of progress and I think everyone will be pleasantly surprised with the features it already has.

What’s new in Tekkit Lite? Well to start we have updated a lot of the core mods like RedPower, Buildcraft and IC2 to the latest versions. This alone brings a whole wide array of new items to Tekkit. You will also find new mods like Factorization, MystCraft, and Steve’s Carts.

Server owners please be aware that MystCraft can put a heavy strain on your server and should be disabled if you plan to make your server public.

You can find all the juicy details on what mods are included on Tekkit Lite’s page. We also have a new forum section open for discussing Tekkit Lite and a new server section.

Remember. We suggest larger servers stick with Tekkit Classic to take advantage of the wide range of bukkit plugins available for 1.2.5. Enjoy that smooth classic Tekkit taste. It is up to you which version to use on your server. We are happy to now provide options.

Seriously guys...if you do changes with such an immense impact, this HAS TO be pointed out.

Link to post
Share on other sites

And why the hell is this in a

Custom Zip – Build your own private modpacks!

Announcement, that has nothing (absolutely nothing) to do, with the regular - non-custom - build, that is being released by the tekkit team????? Yeah next time i have a question about tekkit lite i'll post it in the voltz section. If someone asks the same shit again i'll say "dude, there is already a thread *lol*".

C'mon....

Link to post
Share on other sites

And why the hell is this in a

Custom Zip – Build your own private modpacks!

Announcement, that has nothing (absolutely nothing) to do, with the regular - non-custom - build, that is being released by the tekkit team????? Yeah next time i have a question about tekkit lite i'll post it in the voltz section. If someone asks the same shit again i'll say "dude, there is already a thread *lol*".

C'mon....

Custom zips have everything to do with tekkit lite. They allow you to add in any mod you want (that is compatible) very easily. It also allows you to manually update mods on your server. And it lets you do all of this without making your server users do much work at all.

The fact that you didn't read the News in the News section isn't really a problem with the website, the announcement was there you just didn't read it.

There were also posts all over the forum about it being removed and why back when it was removed earlier in the month.

Link to post
Share on other sites

Custom zips have everything to do with tekkit lite. They allow you to add in any mod you want (that is compatible) very easily. It also allows you to manually update mods on your server. And it lets you do all of this without making your server users do much work at all.

The fact that you didn't read the News in the News section isn't really a problem with the website, the announcement was there you just didn't read it.

There were also posts all over the forum about it being removed and why back when it was removed earlier in the month.

Yeah, that explains all the people with "java render tank error" problems. Because of the super awesome announcement.

Link to post
Share on other sites

Yeah, that explains all the people with "java render tank error" problems. Because of the super awesome announcement.

There are 4 topics on this forum related to this issue. 4. The Dimensional Anchor crash in 0.5.2 alone causes 4 new posts A DAY. 4 posts does not "all the people" make.

You missed the news announcement. You missed the posts all over the forums around the release of 0.5.2 talking about railcraft being removed. It's that simple. You missed it. Stop blaming others.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...