Jump to content

Any way to improve performance on a laptop(not a server) I'm playing on


Recommended Posts

I'm playing Tekkit Lite on a public server and my laptop tends to have small freezes that make the gameplay annoying(to say the least), and occasionally FPS lag(like moving in slow motion).

I don't host the server, I'm just playing on it.

Any tips/tricks to improve the performance?

Laptop specs:

i5 [email protected] 2.3k GHz

8GB RAM DDR3

Video Card: http://www.notebookcheck.net/NVIDIA-GeForce-GT-540M.41715.0.html

nonSSD HDD - I/O shouldn't bottleneck, but who knows.

As a side note: What's a good setup to run Tekkit Lite with none of the issue mentioned above?

Was planning on getting a desktop anyway.

Link to post
Share on other sites

I've been having this exact set of symptoms (including the magic launcher issue). I just figured out what was causing it, and boy do I feel stupid!

I have a Dell XPS 15z laptop. It has two GPUs: a shitty Intel chipset for low power video applications and a GeForce GT 525M for 3D performance applications. It's supposed to automagically switch between the two depending on the application. Something about the technic and magic launchers breaks this automagic. It looks like Nvidia had to carve out a special exception in the driver for Minecraft, since it runs within a java host machine. I suspect that the core issue is that the Mojang launcher runs minecraft.jar by way of javaw.exe (no console environment), while the technic launcher and magic launcher run it via java.exe.

To get technic/tekkit/yogsbox/magic launcher running on the right GPU, open the Nvidia Control Panel. Go to the "Manage 3D settings" section. Pop over to the "Program Settings" tab. Click the "Add" button. Browse to java.exe. The location will vary depending on your OS and java version. On my 64-bit system with Java 7 it is:

C:\Program Files\Java\jre7\bin\java.exe

Where it says, "Select the preferred graphics processor for this program", select "High-performance NVIDIA processor" instead of the default "Use global setting (Auto-select: [...])" option.

Bear in mind, this will cause all java applications that run with java.exe to use the NVIDIA GPU, not just Minecraft. For most people, this probably isn't an issue, but if you run a lot of 2D java apps on such a laptop for whatever reason, this will negatively impact your battery time. I don't know of any way to target Minecraft specifically. It might be possible with a registry hack, but I haven't been able to locate where the driver stores its per-application settings.

I don't know how you'd do this on an ATI/AMD system, but I think it's almost certain that you can.

With vsync off, I'm back to getting 90+ FPS everywhere, as I do in Vanilla minecraft with optifine.

^This helped me, and I have the same graphics card as you. I manage to hit 100FPS regularly after doing this

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...