Jump to content

Tekkit Lite and Multiverse: Finding the real problem


Recommended Posts

Ok, I, as many others too (just google "tekkit lite multiverse" and you will find a lot of others) have problems getting Multiverse to work with Tekkit Lite.

I'm using BukkitForge and can load several plugins successfully using it, and I can see all the Multiverse commands when I type help.

But I can't import any of my maps from my private Tekkit Classic server! I have converted it using the method in this thread, but I can't import it to Multiverse using the mvimport command.

The minecraft server tells me "FAILED." and "That world folder does not exist. These look like worlds to me:" and then an empty line, even though I have copied the world folder into the Tekkit Lite directory.

That's about where most people with this problem are standing.

I have found out that it seams that Tekkit Lite stores worlds a bit different than Tekkit Classic (perhaps because the Minecraft version is different?). For Tekkit Classic, each world has a folder named world (overworld), one named world_nether (nether) and one named world_the_end (the end). Pretty clear. Basicly it seams the world folder contains a level.dat, a level.dat_old, a session.lock and a uid.dat file and a folder named "data" and one named "players". world_nether and world_the_end are similar, but they contain the folders DIM-1, DIMDIM-1 and DIM1, DIMDIM1, respectivly.

So it seams in Classic overworld, nether and the end are saved in seperate directories.

In Tekkit Lite, you have only one folder named world. It contains the level.dat and level.dat_old files (+ some others) AND a DIM-1 and a DIM1 folder. From what I have read, in minecraft 1.4.* you can reset the nether or the end by deleting the DIM-1 or DIM1 folder, so I guess in Tekkit Lite they are the corresponding folders for world_nether and world_the_end in Classic.

So problem number one seams to be getting the world, world_nether and world_the_end all into one folder.

Second question is, when I enter "mvcreate test normal" it seams to be generating some world. But, it starts getting strange when entering mvlist, because the worlds listed are not test/overworld/the_end/nether as you would suspect, but instead it is dim_bf6/overworld/the_end/nether?!?!??!??!?!

Looking into the world folder again, there now is a subfolder called DIM_BF6?!?!?!?!?

To pull everything together, it seams that worlds are saved in a completely different way in Tekkit Classic and Tekkit Lite, so the main question is now: Is it actually possible? I would want an answer from somebody who A. has done it personally and B. can give me (and others) a wink (or more) into the right direction.

And the normal stuff: Tekkit Lite 0.5.2, Multiverse 2.5 (latest build).

Oh, and just now I saw another thing: Looking into the server.log file, I can see these lines:

2013-01-28 20:32:06 [WARNING] [Multiverse-Core] WorldManager: Can't load this world because the folder was deleted/moved: overworld

2013-01-28 20:32:06 [WARNING] [Multiverse-Core] Use '/mv remove' to remove it from the config!

2013-01-28 20:32:06 [WARNING] [Multiverse-Core] WorldManager: Can't load this world because the folder was deleted/moved: Test

2013-01-28 20:32:06 [WARNING] [Multiverse-Core] Use '/mv remove' to remove it from the config!

2013-01-28 20:32:06 [WARNING] [Multiverse-Core] WorldManager: Can't load this world because the folder was deleted/moved: the_end

2013-01-28 20:32:06 [WARNING] [Multiverse-Core] Use '/mv remove' to remove it from the config!

2013-01-28 20:32:06 [WARNING] [Multiverse-Core] WorldManager: Can't load this world because the folder was deleted/moved: nether

2013-01-28 20:32:06 [WARNING] [Multiverse-Core] Use '/mv remove' to remove it from the config!

2013-01-28 20:32:06 [iNFO] [Multiverse-Core] 0 - World(s) loaded.

2013-01-28 20:32:06 [WARNING] [Multiverse-Core] The world specified as the spawn world (null) did not exist!!

I don't really know how to read this, but it seems like Multiverse doesn't even recognize the server created startup worlds????

Thanks for any help in advance,

Jan

Link to post
Share on other sites

Multiverse works on my server, the only command I cannot do is do /mv regen, cause it will crash the server.

This is how i get my server working with more bukkit plugins than the other options,

http://forums.technicpack.net/threads/howto-bukkit-fml-tekkitlite-bukkit-plugins.36732/

Please note that I am not the developer, and there is a dev post through that post (just read).

It is however working GREAT, and uses Spigot+Forge(FML).

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...