Sign in to follow this  
Vaygrim

Liquids not "flowing" in Tekkit Lite SSP?

Recommended Posts

I've got an SSP going to test out Tekkit Lite (I am seeing if I want to transition from Classic to Lite, long term). One thing I am noticing immediately (latest recommended build, which I believe is 0.57?) is that water and lava are basically static. They don't flow.

If I take a single bucket of water out of a massive ocean, I have a permanent 'empty square' left there in the water. Blocking off the source block of a water flow in a mine does NOT stop the water coming out of it. I have to individually block off every single square with a solid block like Dirt or Cobblestone.

Am I doing something wrong? Did I forget to turn something on?

Share this post


Link to post
Share on other sites

I'm having a similar problem. I have to right-click the spaces where the water/lava should be to "force" the game to update that square. Noticed this after falling into invisible lava.

Share this post


Link to post
Share on other sites

Sounds very similar to me, tho I didn't know about the right-click-trick. Does that update just the target square, or will it update that square and all others it effects?

EXAMPLE: If I empty a bucket of water against a wall 3 blocks up.. I get a "water fall" / "fountain" effect. I _SHOULD_ be able to remove that one top source block of water and stop the whole flow. In my SSP game tho.. it doesn't. I have to cancel out each and every square. So if I try your trick and right click on the source square I removed... will it update the whole waterfall or just that block?

Share this post


Link to post
Share on other sites

This is SSP. Spawn protection isn't an issue as I can decimate the landscape immediately around spawn just fine.

Anyone else have a suggestion? This is REALLY cramping game play heavily.

Share this post


Link to post
Share on other sites

this isnt an issue with tekkit but rather with forge conflicting with optifine

as soon as you block off a water source block forge doesnt update it because it clashes somehow with optifine

if you relog the problem should have gone away if that is the case update forge to #518 or above (forge is in the modpack.jar) and reinstall optifine after that

Share this post


Link to post
Share on other sites

tekkit classic does use forge only a earlier version the bug is only with forge #506-517 and since tekkit lite 0.5.7 uses forge 517 it conflicts with optifine

here is the post on optifine's thread

Preview OptiFine HD D3 Ultra for Minecraft 1.4.6 and 1.4.7 (added option Custom Sky based on MCPatcher's Better Skies, fixed CustomSky negative rotation axis, fixed TwilightForest maps, compatible with Forge #518, not compatible with Forge #506-516)

it really simple just update your forge to 518 and its fixed

Share this post


Link to post
Share on other sites

The modpack.jar file is forge and nothing else. Worst case just extract the file containing Forge to a new folder, copy the files from Optifine over top, overwriting existing files. Then select all the files and (assuming windows) right click and choose Send To->Compressed (zipped) folder. Rename this new zip "modpack.jar"

Share this post


Link to post
Share on other sites

I am having the same problem with my server, but there does not seem to be a modpack.jar. I did what you said with creating a new modpack.jar using Optifine and Forge but it didn't change anything liquid is still broken. Any suggestions?

Share this post


Link to post
Share on other sites

For the server, you will need to get a fresh copy of the minecraft server.

According to the Forge docs:

"Place the universal zip into the same folder where your minecraft_server.jar is, then change the extension of the forge zip to a .jar. "

Or you can do it the old fashioned way:

Rename the server to minecraft_server.zip, open it and copy the files for Forge into it, then rename it back to minecraft_server.jar

(Don't install Optifine on the server)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this