Jump to content
  • 0

Incorrect Java being used, Update Failed! [fix]


milktatious
 Share

Question

ok, well, I have no experience with programming at all, how would I make a batch file to run minecraft specifically with java 6?

Mod Note: The following information is offered AS IS and we can not officially support it since we haven't had to do it and can't test it. It's there for anyone who wants to try it.

Link to comment
Share on other sites

  • Answers 124
  • Created
  • Last Reply

Top Posters For This Question

Recommended Posts

  • 0

Re: Re: Update Failed!

you basically just have to tell it to use the right java.exe. in the case of java6, the default install path should be C:\Program Files\Java\jre6\bin\java.exe

I typed out a bunch of stuff explaining what you should put in the batch file, but in the end it will be way simpler if I just give you some lines to copy/paste

mkdir %APPDATA%\.techniclauncher\rtemp

"C:\program files\java\jre6\bin\java.exe" -Xmx1G -jar %APPDATA%\.techniclauncher\technic-launcher.jar

there you go. google batch files to find out how you make them, it's very very simple and needs no programing knowledge.

Link to comment
Share on other sites

  • 0

Re: Re: Update Failed!

thank you so much freakachu. I assume, If I wanted to run minecraft with java 6, I would change the paths that lead to technic launcher to the location of the minecraft launcher?

I put this in a bat file:

mkdir %APPDATA%\.minecraft\bin

"C:\program files\java\jre6\bin\java.exe" -Xmx1G -jar %APPDATA%\.minecraft\bin\minecraft.jar

pause

it tells me it fails to load the main-class manifest attribute from minecraft.jar.

what do I have to do to the bat?

EDIT

nevermind, I got it. Thanks so much again freakachu, now I can finally enjoy the technic pack to its fullest.

Link to comment
Share on other sites

  • 0

Re: Re: Update Failed!

just to clarify, the mkdir line is only needed for the technic launcher. if you're running vanilla minecraft (not through the launcher) then you can get rid of that entirely. also, you'd want to point it at the minecraft.exe file instead of technic-lancher.jar. that would allow you to run regular minecraft in the regular way. I know you already figured it out, but maybe there are other people with similar issues that aren't as swift so I thought I'd be as clear as possible.

Link to comment
Share on other sites

  • 0

This didnt work for me, all I got was the command promt box opening and closing and then a random file being put on my desktop, minecraft and Technic launcher didnt open or work. I made 2 different batch files for minecraft and the technic launcher. What did I do wrong?

Link to comment
Share on other sites

  • 0

if a new file appeared on your desktop ("rtemp", right?) then you did not create the batch file properly. it's most likely because you put the file on your desktop and didn't include the paths in the batch file.

just copy and paste

mkdir %APPDATA%\.techniclauncher\rtemp

"C:\program files\java\jre6\bin\java.exe" -Xmx1G -jar %APPDATA%\.techniclauncher\technic-launcher.jar

into notepad and save it as "instructions are hard.bat" then run it. you don't actually have to save it with that name, but make sure it ends in ".bat" and that you are not saving it as a .txt file.

to be 100% sure, you can put the batch file in your .techniclauncher folder and run it from there if you want.

Link to comment
Share on other sites

  • 0

No what appeared was pc then appdata then roaming then .techniclancher and finally rtemp. Thats with the file on the desktop, with all the info inside as you said. if i put it in the .techniclauncher it will open with an error and close with nothing. my .jar is in the .technic folder. I have Java 7 (x64) it says: Unable to open Jar file C:\Users\home (home pc is my user)

Am I being a Noob or is it my PC?

Link to comment
Share on other sites

  • 0

If you're using Windows, you can just go to Control Panel -> Java, click the "Java" tab, and double-click where it says "Path". Change it to "C:\Program Files\Java\jre7\bin\javaw.exe".

(That should work on 32 and 64 systems, because on 32 systems there's only one Program Files directory, and 64 systems that's the path to the 64-bit Program Files directory.)

Also helps to uninstall all versions of Java except the ones you actually need. (E.g., uninstall java 6 if you have 7 installed.)

Link to comment
Share on other sites

  • 0

i have tried everything when i did the .bat it ran but then stoped when almost finished i raped putting a dent in a metal file cabanet i need help

whoa there, big guy. raping file cabinets is wrong, no matter how they're dressed. that aside, it's all metal anyway and you clearly weren't doing it right if you put a dent in it.

Link to comment
Share on other sites

  • 0

Ok so I made the batch, pointed it to the correct java install and it got the other mod packs working but this new Voxel pack id like to check out is still giving me update failed. Did some searching but either im blind or no one has posted about voxel alone. I will do more searching but Seems it might be time to ask. any ideas?

*edit* manually selecting the other build in the options worked. found right after this post of course.

Link to comment
Share on other sites

  • 0

OK the whole thread wasn't stickied, so let me just sum it up.

you cannot currently use technic or minecraft with java 7. you need to downgrade to java 6 in order to make technic and minecraft work. BUT, you cannot run a tekkit server with java 6, you must upgrade to java 7.This is a java issue, not the fault of the technic crew. If you absolutely MUST have a tekkit server and run minecraft and technic on the same computer, then here is what you must do:

have both java 6 and java 7 installed to your computer.

Download the .jar version of minecraft from http://www.minecraft.net/download .

have it on your desktop, you will not click on it. open it with a batch file containing this:

"C:\program files\java\jre6\bin\java.exe" -Xmx1024M -Xms512M -cp

Minecraft.jar net.minecraft.LauncherFrame

To run technic pack in this scenario, (this is at least what I did):

have the technic launcher .exe on your desktop. you will not click on it.

open it with a batch file containing this:

mkdir %APPDATA%\.techniclauncher\rtemp

"C:\program files\java\jre6\bin\java.exe" -Xmx1G -jar %APPDATA%\.techniclauncher\technic-launcher.jar

this should solve your problem if you need java 7 on your computer for any reason. this only works if you have BOTH java 7 and java 6 on your computer.

If this still doesn't work or minecraft and technic don't load up and you don't have java 7, install the latest java 6 update. Then, delete any other versions of java on your computer. change path variable to java 6, which you can find out how to do on another post.

if it STILL isn't working, then an antivirus or firewall is blocking you from connecting to minecraft.net. you have to allow both minecraft(.exe or .jar) and techniclauncher(.exe or .jar) through your firewall. the steps to doing this are different depending on which antivirus or firewall software you are using.

I HOPE I HELPED!

Link to comment
Share on other sites

  • 0

What's this crap? Technic and Minecraft run under 7 fine.

indeed. however there seems to be a group of people who cannot run the client properly under 7 for whatever reason. chances are good that it's something they did to screw up their own PC, but it's far easier to tell them how to use 6 instead of 7 when needed than it is to figure out what kind of nubcakery they have perpetrated on their systems and fix that.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

Announcements




×
×
  • Create New...