Sign in to follow this  
Gee_Wisz

I just need a little help.

Recommended Posts

I created my modpack and it works nice and pretty, but when I try and use those mods on my server, it crashes. How do I fix that? What do I need to download and do? Do I need to make a new .jar for the server to run off of?

Share this post


Link to post
Share on other sites

I created my modpack and it works nice and pretty, but when I try and use those mods on my server, it crashes. How do I fix that? What do I need to download and do? Do I need to make a new .jar for the server to run off of?

First of all:

1. Some mods only work on client side and other mods on server side.

2. Some mods have differnet files for client and server.

3. You have to be sure that your mods config files are the same (client - server)

Share this post


Link to post
Share on other sites

First of all:

1. Some mods only work on client side and other mods on server side.

2. Some mods have differnet files for client and server.

3. You have to be sure that your mods config files are the same (client - server)

Alright, understandable enough. Now how do I create a server file (such as the TekkitLite.jar) that will cooperate with my modpack?

Share this post


Link to post
Share on other sites

Alright, understandable enough. Now how do I create a server file (such as the TekkitLite.jar) that will cooperate with my modpack?

lets see mmm:

1. Recomend you use the server.jar from tekkit lite or MCPC+.

Tekkit Server: http://mirror.technicpack.net/Technic/servers/tekkitlite/Tekkit_Lite_Server_0.5.7.zip

MCPC+: http://ci.md-5.net/job/MCPC-Plus/

-> Just download them and copy the jar file and rename it to whatever you want.

Then create a script to launch it:

Windows: server.bat

java -Xms2048M -Xmx2048M -jar server.jar -o true

PAUSE

Linux: server.sh

java -Xms2048M -Xmx2048M -jar server.jar -o true --nojline nogui

It will generate all teh files that you need, then jsut copy the mods to the mods folder and core mods to coremods folder and config files to config files folder.

Then start the server one more time with the script.

Remeber that with MCPC+ you can use plugins in a native way and witht he nromal server.jar you cant.

Share this post


Link to post
Share on other sites

I use MCPC+ so that I can use plugins, indeed, but when I run the server I get an error that says

---- Minecraft Crash Report ----

// Don't do that.

Time: 3/8/13 12:20 PM

Description: Exception in server tick loop

java.lang.NoClassDefFoundError: aud

at java.lang.Class.getDeclaredMethods0(Native Method)

at java.lang.Class.privateGetDeclaredMethods(Unknown Source)

at java.lang.Class.getDeclaredMethods(Unknown Source)

at cpw.mods.fml.common.FMLModContainer.gatherAnnotations(FMLModContainer.java:312)

at cpw.mods.fml.common.FMLModContainer.constructMod(FMLModContainer.java:457)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:69)

at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)

at com.google.common.eventbus.EventBus.dispatch(EventBus.java:317)

at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:300)

at com.google.common.eventbus.EventBus.post(EventBus.java:268)

at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:153)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:69)

at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)

at com.google.common.eventbus.EventBus.dispatch(EventBus.java:317)

at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:300)

at com.google.common.eventbus.EventBus.post(EventBus.java:268)

at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:86)

at cpw.mods.fml.common.Loader.loadMods(Loader.java:494)

at cpw.mods.fml.server.FMLServerHandler.beginServerLoading(FMLServerHandler.java:86)

at cpw.mods.fml.common.FMLCommonHandler.onServerStart(FMLCommonHandler.java:351)

at ho.c(DedicatedServer.java:86)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:724)

at fy.run(ThreadMinecraftServer.java:16)

Caused by: java.lang.ClassNotFoundException: aud

at cpw.mods.fml.relauncher.RelaunchClassLoader.findClass(RelaunchClassLoader.java:218)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

... 31 more

Caused by: java.lang.RuntimeException: Attempted to load class aud for invalid side SERVER

at cpw.mods.fml.common.asm.transformers.SideTransformer.transform(SideTransformer.java:38)

at cpw.mods.fml.relauncher.RelaunchClassLoader.runTransformers(RelaunchClassLoader.java:261)

at cpw.mods.fml.relauncher.RelaunchClassLoader.findClass(RelaunchClassLoader.java:206)

... 33 more

A detailed walkthrough of the error, its code path and all known details is as follows:

---------------------------------------------------------------------------------------

-- System Details --

Details:

Minecraft Version: 1.4.7

Operating System: Windows 7 (amd64) version 6.1

Java Version: 1.7.0_11, Oracle Corporation

Java VM Version: Java HotSpot 64-Bit Server VM (mixed mode), Oracle Corporation

Memory: 1585454944 bytes (1512 MB) / 2058027008 bytes (1962 MB) up to 2863333376 bytes (2730 MB)

JVM Flags: 2 total; -Xmx3G -Xms2G

AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used

Suspicious classes: FML and Forge are installed

IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0

CraftBukkit Information:

Running:

Failed to handle CraftCrashReport:

java.lang.NullPointerException

at org.bukkit.Bukkit.getName(Bukkit.java:68)

at org.bukkit.craftbukkit.v1_4_R1.CraftCrashReport.call(CraftCrashReport.java:19)

at l.a(CrashReportCategory.java:103)

at a.h(CrashReport.java:59)

at a.<init>(CrashReport.java:41)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:772)

at fy.run(ThreadMinecraftServer.java:16)

Is this caused by an outdated FML I downloaded or did I just dun goof?

Share this post


Link to post
Share on other sites

Everything from TekkitLite (0.5.7) with Mo'Creatures, Portal Guns and Gravity guns. I'm adding Optifine and the Zipline mod later, but they aren't in the pack yet. With Mo'Creatures I did add the GUI API to the coremods folder as the most recent build requests.

EDIT: Now it's just telling me that FML has identified a non-mod "NEI-RedPower Plugin" in the mods folder. Any idea what that's about? I'm 150% sure that NEI RedPower Plugin is a mod, considering I downloaded it alongside the other RedPower mods just to update them.

Share this post


Link to post
Share on other sites

Everything from TekkitLite (0.5.7) with Mo'Creatures, Portal Guns and Gravity guns. I'm adding Optifine and the Zipline mod later, but they aren't in the pack yet. With Mo'Creatures I did add the GUI API to the coremods folder as the most recent build requests.

EDIT: Now it's just telling me that FML has identified a non-mod "NEI-RedPower Plugin" in the mods folder. Any idea what that's about? I'm 150% sure that NEI RedPower Plugin is a mod, considering I downloaded it alongside the other RedPower mods just to update them.

Of use the following fixed mods for MCPC+

MoCreatures: http://www.mediafire.com/?d23774djb9d3ny2

IC: http://www.mediafire.com/?pij4uz34s4kflh5

more info can be found here: http://www.mcportcentral.co.za/index.php?topic=4657.0

Share this post


Link to post
Share on other sites

It's still just saying that NEI-Redpower Plugin isn't a mod, and when I tried removing that, it said the WR-CBE mods were a problem, then apparently weaponmod.... Eventually I'd just be stripping down every mod in the server at that rate. Any ideas as to the NEI-Redpower problem?

EDIT: I got it to work, it was whining at a duplicate of another mod that was present (though I don't know how it got there). Thanks for trying to help though, you did get me past the first error, I guess the NEI thing was a self inflicted problem. XD

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this