Jump to content
Sign in to follow this  

Forge Mod Loader could not connect to this server

Recommended Posts

Hey all,

I wonder if you could shed some light on the error I bumped into this

morning as I was about to harvest (some rubber tree's) before work

.... Yet was denied.

Basic info:

I've been playing MC / Tekkit Lite for a couple of weeks (Very new to MC).

I've managed to setup a home server and had a multiplayer world running and had a 2nd player join (via Hamachi ?) onto this server.

Using the TekkitLauncher, launching Tekkit Light, I've spend a good 20 hours on the current world, (Just piped to Sawmill and extractor ... tmi)

This morning I noticed the Tekkit launcher was not as quick at launching as normal, then there was a message about updating, I clicked "No" attempted to launch, and the client froze. Quite, re-tried, this time clicked "Update" .....

Files transfered, updated, Launched Tekkit lite ..... Still not happy.

I may have stopped and restarted the (multiplayer tekkit) server, then relaunched T.Launcher ....

Minecraft started, I selected "Multiplayer" (Normal server with green latency bar) appears, clicked .... then received the following messages:

Forge Mod Loader could not connect to this server

The mods and versions listed below could not be found

They are required to play on this server

ImmibisCore : 52.4.5

LogisticsPipes:Main :

DimensionalDoors : 1.4.6R1.2.1RC1

factorization : 0.7.10

AppliedEnergistics : rv.9.f

mod_bspkrsCore : v1.01(1.4.7)

DimensionalAnchors : 52.1.9

StevesCarts : 2.0.0.a61

Now as time was up and I had to log into RL and perform the usual Daily tasks to earn the gold coins ...... I closed down and left the problem.

However taking a snapshot of the last few lines on the server CMD window:

2013-04-23 08:40:00 [iNFO] [Minecraft] User Darkened connection failed:missing [], bad versions [immibisCore, LogisticsPipes:Main, DimensionalDoors, factorization, AppliedEnergistics, mod_bspkrsCore, DimensionalAnchors, StevesCarts]

2013-04-23 08:40:00 [iNFO] [ForgeModLoader] User Darkened connection failed :missing [], bad versions [immibisCore, LogisticsPipes:Main, DimensionalDoors, factorization, AppliedEnergistics, mod_bspkrsCore, DimensionalAnchors, StevesCarts]

2013-04-23 08:40:01 [iNFO] [Minecraft] Disconnecting Darkened [/25.xx.xx.xx:503xx]: Thhe server requires mods that are absent or out of date on your client

2013-04-23 08:40:29 [iNFO] [sTDOUT] saving

Any thoughts guy's 'n gals?

Again, I'm VERY new the the MC world, setting up servers etc.

Cheers in advance, Darkened.

Share this post

Link to post
Share on other sites

Heyy DarkenedDragon, I also had this exact problem this morning when trying to log in. I too am very new to MC and T.Lite, I also have setup a server on a home PC for my flat mates and I to play on.

I did pretty much exactly what you did and encountered the same problems. I have however managed to solve the problem.

I am not very tekky but I will do the best I can to describe how I solved this. Firstly, I had tried rolling back my version of the tekkit launcher after I updated. However this only caused more conflicts. I would not recommend this as the reset process meant I lost my way points (I didn't back anything up *facepalm*) and I now have to reinstall my texture packs, opti-fine and a bunch of other useful junk not in the pack as standard.

Anywayyy I digress... The solution was 'simply' to update the server to the latest version. I say 'simply' because not really knowing what I am doing, (I was only able to set up a server in the first place by following a step by step guide) updating with out a step by step guide to baby me through it was troublesome. I did try searching for a guide but could not find one (at least not specific enough for my noobdom).

So in the assumption that you maybe in a similar situation I will attempt to provide a step by step of what I did:

Before you start Back up your Tekkit-Lite folder in another location (or perhaps just your World folder) as I really don't know much about these things.

1 - Go to http://www.technicpack.net/tekkit-lite and on the right under 'get tekkit lite' click the download link for the 0.6.5 server.

2 - After the download is complete open the location where you keep your current T.Lite server folder (probably named something like 'Tekkit_Lite_Server_0.6.1'). Then copy the downloaded folder for 0.6.5 to this location, but not into the old version folder just next to it. You should now have a location with two folders that appears:

[] Tekkit_Lite_Server_0.6.1

[] Tekkit_Lite_Server_0.6.5

3 - The 'Tekkit_Lite_Server_0.6.5' folder will still be zipped, right click and extract to this location, then delete the zip folder upon completion.

4 - If you now open both folders side by side you will observe that your 0.6.1 folder has a few extra files and folders inside. I am not entirely sure what all of these are, but my understanding is that the folder entitled 'World' contains, well... the world you have been playing. Copy and paste this folder into the 0.6.5 folder.

5 - I also copied over 'banned-ips', 'banned-players', 'ops' and 'white-list' which are all files that appear in the 0.6.1 folder. I didn't really have a good reason for this other than I knew that I had edited these and so felt I should. For this reason you could perhaps skip this step?

6 - Finally run the windows batch file named launch.bat.

If all went well then once the server has finished setting up you should be able to log-in from your launcher without any problems.

Sorry about the rambly nature of this reply, I hope it helps.

[[it occurred to me whilst writing this, that I only tried rolling back to 0.6.4 as I assumed I must have been running that version,. However clearly I was running 0.6.1 so perhaps rolling back to 0.6.1 might have worked. Thought it might be worth mentioning this just in case.]]

Share this post

Link to post
Share on other sites

Hey Smithy,

Thank's for your thought's taking the time to respond. Sounds like we're in the same boat indeed ....

Whilst I'm just a little bit above the idiocy level for someone to shout out (about me) "Nurse, he's out of his bed again" ...

I'll take the precautions you've mentioned. To be honest, I spent a good 3 hours initially setting up tekkit and server software (MC and TL - Ever get the feeling you're at the head of a boat steering with one oar forgetting to paddle alternative sides .... yes sensing there's creeper behind you and you go like the clappers to escape .... Just me then?)

..... In the minecraft world, it's only because I've slapped stickies on ' Butt ' and ' Elbow ' that I can tell the difference between minecraft and Tekkit ..... (And we won't go into great detail on the fact that I've been following yogscast episodes, spending 10 hours looking for rubber to make wires for the condenser kit, only do discover to my joy .... that in EE3 ...... IT'S GONE?! - Even now I'm not sure what, if any machine has replaced it!!)

I still haven't looked / investigated in anger on exactly how to back up worlds, or worked out the association's between the "Game save folders" (Backing up worlds) as you've mentioned

(Such as correlating the difference between a single player world, multiplayer world, and any game worlds I may create in the future) .... Again I digress ....

Between now and end of the working day, I'll try to work out where I can find the version number of my tekkit server ....

Check your post, compare and contrast, and see what I can do at home.

My main concern is that I back up the saved file. yup I'll google it.

cheers again!

Share this post

Link to post
Share on other sites

OK update ....

Downloading Server 6.5, done, installed, and followed instructions as above .....

Yes, the Tekkit now works .... however I've lost my worlds / progress. Also the Server name (When connecting to a multiplayer game) was a different name to the one pre update.

Oddly enough, my waypoints are present, however ..... Not the same world I was in.

sods law spawned me in an oceanic world ...... Man it takes ages to swim to the nearest island .... and then some to the next one WITH TREES !!!!!

Its late, I'm heading off to bed, some sucess, but sadly lost a world I was in.

Now I completely backed up the whole folder before making any changes ... so "Recoverable" I hope....

Any Black Belt Tekkit's out there available to help?


Share this post

Link to post
Share on other sites

I was able to get it working but gathering the individual mods and replacing the updated ones in the mods folder.

So to break it down:

1. Gather the mods. [[ http://www.fileswap.com/dl/Z4UmpaWhe/ ]]

2. Go to your mods folder for tekkitlite. [[ C:\Users\YOUR_USER_NAME_HERE\AppData\Roaming\.technic\tekkitlite\mods ]]

3. For each of the mods it says is missing, find them in the zip file and drag them into your mods folder. (I only rolled back the ones in the list)

4. Remove the newer version of each.

Just a heads up, so far I haven't had any problems but be aware that you'll be using an untested combination of mods and it could be unstable.

Also, I highly recommend backing up the tekkitlite folder before you make any changes. If something goes wrong, restore the whole tekkitlite folder.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...