MachineMuse

Modular Powersuits Support

Recommended Posts

Couldent find anywhere else to post this...

I am using the latest jenkins build: ModularPowersuits-0.7.0-531

And im getting this error when i start my server with it

cpw.mods.fml.common.LoaderException: java.lang.NoSuchFieldError: powerTool

at cpw.mods.fml.common.LoadController.transition(LoadController.java:142)

at cpw.mods.fml.common.Loader.initializeMods(Loader.java:691)

at cpw.mods.fml.server.FMLServerHandler.finishServerLoading(FMLServerHandler.java:93)

at cpw.mods.fml.common.FMLCommonHandler.onServerStarted(FMLCommonHandler.java:355)

at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:141)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:430)

at net.minecraft.server.ThreadMinecraftServer.run(SourceFile:573)

Caused by: java.lang.NoSuchFieldError: powerTool

at andrew.powersuits.common.AddonConfig.loadPowerModules(AddonConfig.java:24)

at andrew.powersuits.common.ModularPowersuitsAddons.load(ModularPowersuitsAddons.java:38)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

at java.lang.reflect.Method.invoke(Method.java:601)

at cpw.mods.fml.common.FMLModContainer.handleModStateEvent(FMLModContainer.java:494)

at sun.reflect.GeneratedMethodAccessor1.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

at java.lang.reflect.Method.invoke(Method.java:601)

at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)

at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)

at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)

at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)

at com.google.common.eventbus.EventBus.post(EventBus.java:267)

at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:165)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

at java.lang.reflect.Method.invoke(Method.java:601)

at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)

at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)

at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)

at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)

at com.google.common.eventbus.EventBus.post(EventBus.java:267)

at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:98)

at cpw.mods.fml.common.Loader.initializeMods(Loader.java:690)

Is it ModularPowersuits addon that makes this becouse it dont know that the gauntlet have change name to fist?

Share this post


Link to post
Share on other sites

Thanks for this response. I salvaged the flight controls, but I'm still having the same trouble. It must be something to do with some of the other powersuit addons. I'll keep an eye out and report any solutions I find.

Take the battery out of your gauntlet.

And to the other guy: stop pasting crashlogs, they're shitting up the thread. Put them on hastebin or gist or something.

Share this post


Link to post
Share on other sites

Couldent find anywhere else to post this...

I am using the latest jenkins build: ModularPowersuits-0.7.0-531

And im getting this error when i start my server with it

Is it ModularPowersuits addon that makes this becouse it dont know that the gauntlet have change name to fist?

Make sure both your Modular Powersuits mod and the MPSA mod are updated. The addons to the armor/tool are part of a separate mod now (MPSA) and the name was changed in build 530. This means that the code in the addons had to change the names as well so that needs to be updated to build 142.

TL;DR Update MPSA to this version here.

Share this post


Link to post
Share on other sites

I've been stuck with playing Voltz offline, and, for some reason, when I open the tinker table with my power tool in hand, it only has the shovel, axe and pickaxe tools, plus the aqua affinity, diamond drill and the power mods. Having watched the Yogscast play Voltz, I would assume that the combat side is part of the main mod seeing as it's in all of the other mod packs booth on Technic and FTB, yet I can't seem to get it on my Voltz. It's also the latest recommended build of Voltz since about a week ago, but, again, I don't have proper Internet access. Any ideas as to the problem other than it being incomplete because of the loss of Internet?

Share this post


Link to post
Share on other sites

Yes, it's the loss of the Intertubes. MPS has been upgraded a fair bit since that version of Voltz. More specifically, Voltz currently runs under an older version of Minecraft.

Share this post


Link to post
Share on other sites

Yes, it's the loss of the Intertubes. MPS has been upgraded a fair bit since that version of Voltz. More specifically, Voltz currently runs under an older version of Minecraft.

I have never heard of the Intertubes, despite paying attention to every part of all these packs, from Technic to Voltz, Feed The Beast to New World. Including the small parts of mods like RedPower. And Voltz doesn't run on that old of a Minecraft version, since most mods actually haven't updated to 1.5 due to the massive changes coming in weeks of each other and the imminent arrival of 1.6. In fact, the latest version of any FTB or Technic packs, guaranteed, is 1.4.7 due to this updating and due to stabilization. So, bringing up that the version Voltz uses is mute when it is only outdated if you play Vanilla since it's still the version for most mods and all major mod packs.

Also, all I have seen in upgrades since this version, which is the same the Ypgscast use (I checked with Ridge about that), is the nice 3D change and in completed mods for Vanilla MPS.

Share this post


Link to post
Share on other sites

In fact, the latest version of any FTB or Technic packs, guaranteed, is 1.4.7 due to this updating and due to stabilization.
In fact, it's so guaranteed to be true that it is actually completely false! Big Dig (an official Technic modpack) is 1.5.2, and Tekkit as well is 1.5.1 (or if you use the beta build, 1.5.2). FTB also has a beta 1.5.x pack, somewhere.

As for mods, most of them either updated to 1.5.x (for an incomplete -- though quite extensive -- list, see here) or haven't had any updates at all (ie: Redpower, Xycraft) since before 1.5 even came out.

Regardless, Voltz doesn't have the MPSA (Modular Power Suit Addon) mod, which is probably why you don't have all the extra modules. The Yogscast don't use Voltz anymore either, they have their own personal "Yogcraft" FTB pack.

Finally, it's "moot", not "mute".

Share this post


Link to post
Share on other sites

In fact, it's so guaranteed to be true that it is actually completely false! Big Dig (an official Technic modpack) is 1.5.2, and Tekkit as well is 1.5.1 (or if you use the beta build, 1.5.2). FTB also has a beta 1.5.x pack, somewhere.

As for mods, most of them either updated to 1.5.x (for an incomplete -- though quite extensive -- list, see here) or haven't had any updates at all (ie: Redpower, Xycraft) since before 1.5 even came out.

Regardless, Voltz doesn't have the MPSA (Modular Power Suit Addon) mod, which is probably why you don't have all the extra modules. The Yogscast don't use Voltz anymore either, they have their own personal "Yogcraft" FTB pack.

Finally, it's "moot", not "mute".

Not according to when I checked the mod packs Saturday when Dad forgot to shut off my Internet. And, actually, they still have Voltz, they just haven't been doing episodes because of all the crap they need to do for any videos, especially the still heavily desired Shadow of Israphel series, which is likely being worked on extensively by the background people in the free time they have, taking them away from helping with any other organizing for other series for the main duo.

And, those mods are 1.4.7, the version before 1.5. Not a whole lot of more actually do 50 mod updates in a single version, whether for patches or actual updates.

And the Yogscast used basic Voltz 1.4.7, the one build it has for that version of Minecraft, and they have the mods. MPSA was once part of the MPS mod itself, according to what the mod creator has said on some other help page I looked up trying to figure out the problem. That being said, going back far enough, which isn't that long ago at all, MPSA would be utterly pointless because that came in a later MPS version, one that specifically calls upon a separate mod known as MPSA for it's mods.

Share this post


Link to post
Share on other sites

So this is an issue with the power gauntlet and not being able to see it from first person point of view. I have searched the web over and could not find anyone else having this issue. Before you start calling me newb and telling me to make sure it is selected tool. Keep in mind I can only not see it from 1st person. When I f5 it's there. All of my other items work in 1st person and I'v done everything I could including clean the java and uninstall then re-installed the big dig just in case my opitfine or visual settings was making it vanish. I have tried it on my FTB world and it works fine so it seems the big dig is the only one having an issue. Am I missing something?

Share this post


Link to post
Share on other sites

So this is an issue with the power gauntlet and not being able to see it from first person point of view. I have searched the web over and could not find anyone else having this issue. Before you start calling me newb and telling me to make sure it is selected tool. Keep in mind I can only not see it from 1st person. When I f5 it's there. All of my other items work in 1st person and I'v done everything I could including clean the java and uninstall then re-installed the big dig just in case my opitfine or visual settings was making it vanish. I have tried it on my FTB world and it works fine so it seems the big dig is the only one having an issue. Am I missing something?

I keep hearing from other forum users this was fixed in the most recent update of MPS.

Share this post


Link to post
Share on other sites

Uh, that looks like you're using compressed sawdust. Is that really the recipe? It's hardened glass + solenoid on my install, and I really doubt it was ever using sawdust...

Share this post


Link to post
Share on other sites

Uh, that looks like you're using compressed sawdust. Is that really the recipe? It's hardened glass + solenoid on my install, and I really doubt it was ever using sawdust...

Perhaps he's trying to go green and is attempting to make balsa wood wings? :D

Share this post


Link to post
Share on other sites

http://machinemuse.net/recipes.php

I am using the recipes from here.

Well, there's your problem. From the page you linked: "For more up-to-date information, I recommend the mod NotEnoughItems, by Chickenbones. All the recipes should show up." Note the first part. The screenshot must have been taken at a point when the recipe was bugged, and hasn't been fixed yet. You need to use hardened glass rather than sawdust.

In the future, you should probably just check the recipe in NEI (and if you don't have it for some insane reason, get it).

Share this post


Link to post
Share on other sites

I am using BigDig with NEI.. the recipes there show as vanilla ones even when TE is enabled. Does a client-side setting have to be changed?

Share this post


Link to post
Share on other sites

You might have to set MPS to use TE recipes in the client config, though it's weird that they wouldn't be synced. You should probably report it as a bug if you indeed have to make this change.

Share this post


Link to post
Share on other sites

Okay so the recipe change are client sided, meaning even if you set it in the server files, it won't work unless you change them on your client. I just tested

Share this post


Link to post
Share on other sites

It will work client-side without changing them on the client, just the server. The result of the recipe just won't show up until you click in the craft slot.

Share this post


Link to post
Share on other sites

I'm using this in the Tekkit v1.1.5 and I'm noticing that the PowerGlove Hud(shift+mousewheel scroll) has odd graphics that make it impossible to see what tool is selected. Also the tinkertable has the same broken icons in to represent the modules. It appears to have v 0.7.0-534 of your mod included...is there some way of fixing this easily? or is there an updated version i should be looking to try? I've tried removing the texture packs(and deleting the debug pngs in the tekkit main folder). It only wokrs fine if I don't have Optifine installed(I am using the newest Optifine for 1.5.2 as Tekkit v1.1.5 is minecraft 1.5.2, I've just downloaded OptiFine_1.5.2_HD_U_D5.zip today, twice, and its not fixing it.)

Here are links to screen shots so as to not "shit up the thread" ;)

Gloves:

Chest:

Legs:

Helmet:

Boots:

Share this post


Link to post
Share on other sites

So I'm trying to put together an up-to-date modpack, not dissimilar to Tekkit (in fact, it contains all existing tekkit mods, plus some).

With the latest version of modular power suits (and MSPA), I'm getting an error that suggests that "addComponent" is not a function of modular power suits:

Minecraft has crashed!

----------------------

cpw.mods.fml.common.LoaderException: java.lang.NoSuchMethodError: net.machinemuse.powersuits.item.ItemComponent.addComponent(Ljava/lang/String;Ljava/lang/String;Ljava/lang/String;)Lnet/minecraft/item/ItemStack;

Full log here

Any ideas?

Edit: Fault may lie with MSPA, error dissapears when it is removed.

Hmmm.

Edit2: Completely my fault, MSPA is for a higher version of MPS than I had installed.

Now, the question is, is it safe to use the latest version of MPS? Or should I use the version linked on machinemuse.net front page, and find a compataible version of MSPA?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.