Jump to content

Not Enough items not working, searching for items in creative crashes game.


Recommended Posts

I'm pretty sure this is an issue with the current 1.5.2 version of Thermal Expansion. I ran into this problem when I was screwing around with making a custom modpack; the bug only affects creative mode and there's nothing you can do, afaik, short of not searching or using the TE tab in creative mode. Use NEI if you need an item.

EDIT: Just noticed that you said NEI wasn't working, elaborate a bit more.

Link to post
Share on other sites

None of the items are shown with NEI, it has the area on the right to show all the items but there's 0 pages, and no items there.

A screenshot would be great. If you're playing in creative mode, the NEI interface really only shows up when you're looking at your personal inventory (the little chest in the bottom right). To be honest, I haven't updated my BigDig yet so it might be a bug I just don't know about.

Link to post
Share on other sites

Hi,

I have exactly same problem. I did fresh install of Big Dig and NEI shows absolutely no items. I tried downgrading to version 1.3.3 without success. NEI still is totally empty. I'm going to try downgrading to version 1.3.2 and even older. But that is not solution. I was waiting for 1.5.2 update to Big Dig.

Link to post
Share on other sites

Hi, not everyone seems to be having this issue, so if you could maybe get me a forge log or something that'd be really useful.

https://gist.github.com/georgyo/5659924

These logs come after deleting the entire big dig folder, so it includes the first run of everything and creating the world. I let it run for around for 20 minutes to finish the initial world gen, and then exit.

EDIT: Updated the gist with the IDMap Dump. I can only dump it if I include unused IDs, as if I select ignore unused IDs it won't dump claiming there is nothing to dump. Somehow NEI things every ID is unused although the dump clearly shows other wise.

Link to post
Share on other sites

I looked at all the logs, and nothing is that interesting. I turned on NEI debugging (mistaqur.enableDebug=true) expecting more verbose logs and was met with the same. Is there a way to get Forge or NEI to become super verbose?

I also install big dig on a windows 7/java1.7 to see if the logs had any glaring differences however I didn't find anything, but it does work correctly on Windows.

So, I know very little about java but it looks like NEI is hitting some platform specific code. Unfortunately I know fairly little about java so I am depended on others here.

Many thanks for your hard and noble work in solving these issues as they arise. Wrangling 92 mods can't be easy.

Link to post
Share on other sites

The only platform-specific issue I can think of is behavior around case-different file names, which bit me a few times while putting together this pack. Try deleting all your NEI-related config files and tell me if that makes a difference.

Link to post
Share on other sites

The only platform-specific issue I can think of is behavior around case-different file names, which bit me a few times while putting together this pack. Try deleting all your NEI-related config files and tell me if that makes a difference.

A good theory, but while HFS+ supports case sensitivity it is disabled by default in MacOS.

$ cd tmp/

$ echo hello > test

$ cat Test

hello

In any case, I deleted NEI.cfg, NEIServer.cfg, NEISubset.cfg. The files were regenerated with the same cases and the results were the same as before.

Link to post
Share on other sites
  • 8 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...