Jump to content
Sign in to follow this  
CanVox

Let's Test Big Dig 1.3.12!

Recommended Posts

Hey, everyone,

I've just promoted Big Dig 1.3.12 to Latest. There are a ton of key mod updates, along with the addition of a new mod: Simple Power Storage, by Technic's sct! SPS adds a "Makeshift Energy Cell" which can be used as an early-game alternative to the Redstone Energy Cell!

If you're interested in helping test, back up your worlds (SSP or server) and set your launcher up to use the "Latest" build, or manually select version 1.3.12. Play with us and report issues in this thread!

This is a clean slate, so even if you've already reported an issue elsewhere (including the 1.3.10/11 threads!), if it's present in 1.3.12, be sure to report it in this thread.

The 1.3.12 server can be downloaded here: http://mirror.technicpack.net/Technic/servers/bigdig/BigDigServer-v1.3.12.zip

Changelog for Big Dig 1.3.12- this is a list of all changes since 1.3.9:

- Updated to Minecraft Forge build 723

- Added Mekanism support to Treecapitator configuration.

- Corrected a rare crash bug in the Forge transparency fix

- Added Simple Power Storage version 1.0.10

- Equivalent Exchange 3 version pre1h has had a crash bug removed.

- Updated bspkrsCore to version 2.07

- Updated Immibis Core to version 55.1.2

- Updated Chococraft to version 2.8.5

- Updated ComputerCraft: Immibis' Peripherals to version 55.0.1

- Updated Forestry to version 2.2.6.3

- Updated Forestry: Extra Bees to version 1.6 pre 13

- Some image files have been renamed in Forestry: Extra Bees version 1.6 pre13 to prevent bad textures from appearing in menus.

- Modular Power Suits has been updated to version 0.7.0.534.

- MPS Addons has been updated to version 0.2.3.144.

- Updated MineChem to version 3.0.0.139

- Updated Pam's Wee! Flowers to version 1.5.2 1.01

- Updated MineFactory Reloaded to version 2.6.2.924

- Updated Secret Rooms to version 4.6.0.283

- Updated Soul Shards to version 1.34

- Updated Nether Ores to version 2.1.5.75

- Updated Galacticraft to version a0.1.35.297

- Updated MFFS to version 3.0.2.124

- Updated Magical Crops to version 2.1.0

- Updated Tinkers Construct to version 1.3.4.3

- Updated Natura to version 2.1 RC 2

- Updated Atomic Science to version 0.5.3.51

- Updated ICBM to version 1.2.0.114

- Updated Mekanism to version 5.5.6.76

- Updated Open Peripheral to version 0.1.5

- Updated Not Enough Items: Plugins to version 1.0.9.2

- Updated Buildcraft: Logistic Pipes to version 0.7.3.6

- Updated Mystcraft to version 0.10.4.00

Share this post


Link to post
Share on other sites

Hey crazybud420, try this:

Hey, I've been going over this and have had a hard time finding people with the same issues, tbh. Could you do me a favor? Your logs show that your server is on an old (dangerously old) version of java, 1.7.0_04- could you update to the latest version (1.7.0_21), see if that fixes it, and get me a fresh log if that does not fix it?

Share this post


Link to post
Share on other sites

Why is IC2 configs still in here?

Probably the same as Thaumcraft - it's easy if someone wants to try adding it themselves.

Share this post


Link to post
Share on other sites

When reporting errors please use one of the following:

http://pastebin.com or http://tny.cz/

I prefer tny myself. Doing this will make it easier for CanVox to look into the issues and hopefully have everything good for the next recommended release.

@CanVox - Will the next rec. release require a map reset?

It shouldn't, no.

Umm Mystcraft Symbols are the same ID and Arboriculture Stairs are the same id... o.O

Can you explain what this means? It's not impossible or even uncommon for several similar items from the same mod to share a single item ID.

Share this post


Link to post
Share on other sites

Crashed when placing a Bee in an apiary. Crash Log:

I agree with stubbypickle, please start posting these as links. However, this looks like the problem that crazybud420 was having. Let me ask you a couple questions:

1. Does this happen with a fresh world started in big dig .12?

2. What build of Big Dig did you start the world where this is occurring on?

Share this post


Link to post
Share on other sites

1.3.9

MCPC 516

bah, im not sure if these issues have been fixed in the new versions. in case they

havent placing em here anyway.

-95% of my crashes

at mods.tinker.tconstruct.util.player.TPlayerHandler.onPlayerLogout(TPlayerHandler.java:77)

http://pastebin.com/7G0zkRYp

-The other one

at buildcraft.additionalpipes.pipes.PipeLiquidsTeleport.fill(PipeLiquidsTeleport.java:47) <-- one of the others that popped up

http://pastebin.com/144iwYw8

let me know whether you want any more info or want this in a different thread.

Share this post


Link to post
Share on other sites

I agree with stubbypickle, please start posting these as links. However, this looks like the problem that crazybud420 was having. Let me ask you a couple questions:

1. Does this happen with a fresh world started in big dig .12?

2. What build of Big Dig did you start the world where this is occurring on?

I was unable to replicate the crash on a new world in .12 after 10mins testing, I will note I can still use my main world I just can't place bees in apiaries without it crashing.

Build .9 was the build I started the world on that now crashes on the Bees.

I do apologize for the big posts, I've not been using Pastebin because it refuses to let me use it unless I allow it access to facebook, which I will not do. But I will use google docs as the alternative from now on. :)

Share this post


Link to post
Share on other sites

I was unable to replicate the crash on a new world in .12 after 10mins testing, I will note I can still use my main world I just can't place bees in apiaries without it crashing.

Build .9 was the build I started the world on that now crashes on the Bees.

I do apologize for the big posts, I've not been using Pastebin because it refuses to let me use it unless I allow it access to facebook, which I will not do. But I will use google docs as the alternative from now on. :)

You don't need to register to use paste in.

Share this post


Link to post
Share on other sites

My textures for Modular Power Suit are freaking out (screenshots). This happens whether I am using custom texture pack (1st screenshot) or not (2nd screenshot).

With Sphax textures (they are incomplete, btw):

With default textures:

It is quite annoying, especially when I want to change my keybindings but all the modules' icons look like weird blurry white somethings.

Share this post


Link to post
Share on other sites

Hi, viesiu,

The .12 build includes a lot of major changes to MPS, including a new cosmetic suit system that allows you to do a ridiculous amount of customization. Most likely the texture packs you're using are for build 444, the previous rec build for MPS, and they're choking on the newer version.

Share this post


Link to post
Share on other sites

But, like I said, Im having this issue w/o any texture packs at all. The second screenshot shows the problem with vanilla textures only.

Doing a completely clean install didn't help either.

Share this post


Link to post
Share on other sites

I just can't place bees in apiaries without it crashing.

ive herd its mainly rocky and water bees causing this crash ive told people to stop using these 2 for now and had no other crashes so far...

theres quite a few reports from people crashing due to there power suits i havent experienced it myself but heres a report from some one on the server https://github.com/MachineMuse/MachineMusePowersuits/issues/315

Share this post


Link to post
Share on other sites

i cannot open big dig idk why when i open it i sit there for like a hour with the screen white it doesnt say anything and it doesnt change help!

Share this post


Link to post
Share on other sites

But, like I said, Im having this issue w/o any texture packs at all. The second screenshot shows the problem with vanilla textures only.

Doing a completely clean install didn't help either.

I can't repro this, and speaking with Machine Muse, she said that this was a problem that occurred for people without forge 712+. So, do me two things:

- What is your graphics card/adapter? Full name and model- you can find it in the display tab of dxdiag.exe if you have windows.

- Go to the main menu and read me off the forge and FML version from the bottom left.

Share this post


Link to post
Share on other sites

ive herd its mainly rocky and water bees causing this crash ive told people to stop using these 2 for now and had no other crashes so far...

theres quite a few reports from people crashing due to there power suits i havent experienced it myself but heres a report from some one on the server https://github.com/MachineMuse/MachineMusePowersuits/issues/315

Unfortunately I've had it happen from Imperials, Industrious and cultivated. Very frustrating. I don't really want to have too start a new fourth world, but if it is the only solution it may be my only choice.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...