Jump to content

[1.1.7] Tourney Tekkit[PvE][30 slots][No Whitelist][No DD] - Survival Server


Recommended Posts

Server is up and running again.

I suspect from reading the logs that ComputerCraft has been causing the crashes. So I've deleted all the ComputerCraft "programs" created during the last week. Let's see if that fixes the issue.

Link to post
Share on other sites
  • Replies 97
  • Created
  • Last Reply

Top Posters In This Topic

Nope, that didn't help - it crashed again. I saw it was up a little while ago, but by the time I sat down to get on, it's crashed.

I created one computercraft program using the peripheral API in the last few days to read the redstone energy cell levels via the peripheral API on the power station and graph the charge rate/total MJ stored and turn off the fusion reactor as needed when they were full, but it shouldn't have restarted for any server reboots since I never set it to run at startup yet since we're rebuilding the fusion reactor in the crater.

So unless it's just the presence of those computers sitting idle, it's probably not those (in my case, unaware of other CC usage by players)

Link to post
Share on other sites

Thanks for the heads up. It indeed crashed again just 15 minutes after I started it. No one have played during that time. Will have to do some more testing.

All of you can expect frequent crashes and a lot of downtime today / tomorrow.

Link to post
Share on other sites

After contacting MCPC team with crash log, they helped me find the issue. It is indeed related to ComputerCraft.

The reason for the crash can be found here: http://www.computercraft.info/forums2/index.php?/topic/13089-updating-a-wired-network-can-cause-a-peripheral-deadlock/

Please be careful when using CC modems, networks and gate readers etc. As they are bugged in the current version of CC.

Link to post
Share on other sites

Thanks Pewx - it was probably me then - I'll be sure to yank all the wired modems/cables I may have left - if you haven't done that yet - and stay off my CC coding for them until that gets updated... although I still don't see an update in 1.56 for it from the changelogs, so not sure if Cloudy is updating or waiting for more reproductions?

Link to post
Share on other sites

Thanks eph now i can't play on my favorite server..

What's wrong?

Thanks Pewx - it was probably me then - I'll be sure to yank all the wired modems/cables I may have left - if you haven't done that yet - and stay off my CC coding for them until that gets updated... although I still don't see an update in 1.56 for it from the changelogs, so not sure if Cloudy is updating or waiting for more reproductions?

I don't know either to be honest. Strange bug.

Link to post
Share on other sites

haven't really played minecraft at all in the last 6 months. Gonna try this server out. community looks decent from this forum and with a 1k size+ protection and extremely minimal banned mods, I'll be more than happy to lend a hand here.

Link to post
Share on other sites

Pewx,

Relative to the ComputerCraft issues - it looks like you can use a wireless modem still, correct?

Reason(s) I'm asking:

1) dan200 seems to think it's an MCPC+ caused issue and supports "pure Forge only", and the MCPC+ team thinks it's dan200's - i.e. this won't get resolved any time soon, and I've been trying to recreate it on a 'stock' 1.1.5 Forge-only server locally and can't

2) I've looked at all the similar tracebacks on this (including yours on the MCPC+ github), and basically it looks like the TileEntityCable.attach call is where the locks/thread blocking starts... so wired modems only is the presumption.

3) It -does- look like a basic computer placed next to each peripheral I'm monitoring can see them via the peripheral API (i.e. the redstone energy cube states/values)

So I was looking to overcome this by modifying my earlier code to replace wired modems with a remote wireless computer and have each establish a channel back to a 'head-end' advanced computer that can do the control of the various other elements (or send commands off to other remotes), and make pretty graphs, etc.

But obviously I'm not looking to be the cause of a crash :-) - thoughts?

It's just I'm hitting bugs in the PRC with client-side crashes tracing back to the PRC GUI trying to use it, and some variables in the PRC are getting stuffed with odd values.

Not to mention lua code is easier for me to read, lol. I never did well with logic-gate/machine-code logic. :-)

As an aside, it looks down again - but this time not even the Dynamicmap comes up, in case you're not aware.

*Edit:* It's back up now, so I guess you're aware!

Link to post
Share on other sites

haven't really played minecraft at all in the last 6 months. Gonna try this server out. community looks decent from this forum and with a 1k size+ protection and extremely minimal banned mods, I'll be more than happy to lend a hand here.

You're very welcome to join us.

Pewx,

Relative to the ComputerCraft issues - it looks like you can use a wireless modem still, correct?

Reason(s) I'm asking:

1) dan200 seems to think it's an MCPC+ caused issue and supports "pure Forge only", and the MCPC+ team thinks it's dan200's - i.e. this won't get resolved any time soon, and I've been trying to recreate it on a 'stock' 1.1.5 Forge-only server locally and can't

2) I've looked at all the similar tracebacks on this (including yours on the MCPC+ github), and basically it looks like the TileEntityCable.attach call is where the locks/thread blocking starts... so wired modems only is the presumption.

3) It -does- look like a basic computer placed next to each peripheral I'm monitoring can see them via the peripheral API (i.e. the redstone energy cube states/values)

So I was looking to overcome this by modifying my earlier code to replace wired modems with a remote wireless computer and have each establish a channel back to a 'head-end' advanced computer that can do the control of the various other elements (or send commands off to other remotes), and make pretty graphs, etc.

But obviously I'm not looking to be the cause of a crash :-) - thoughts?

It's just I'm hitting bugs in the PRC with client-side crashes tracing back to the PRC GUI trying to use it, and some variables in the PRC are getting stuffed with odd values.

Not to mention lua code is easier for me to read, lol. I never did well with logic-gate/machine-code logic. :-)

As an aside, it looks down again - but this time not even the Dynamicmap comes up, in case you're not aware.

*Edit:* It's back up now, so I guess you're aware!

It was down for a few minutes when you checked because we were changing some settings to prevent lava lag.

As for testing modem / cable. I don't think you can produce the crash like that in single player because the crashes seemed to appear randomly. For example out of nowhere when no one was online.

I appreciate you taking the time to find out what the "real" cause was. I think we should test your theory with only wireless modems and see how that works out. If we get the same error again we at least know what is causing it and can remove it.

Link to post
Share on other sites

Ok, will check it out, thanks.

I'm not testing on single player, BTW. It's a separate Debian linux VMware instance running tekkit 1.1.5 server on a server platform on my local network. I dropped a dimensional anchor and have multiple computers running instances of my code. I'm going to put MCPC+ on next to see if I can reproduce it there.

Link to post
Share on other sites

Ok, will check it out, thanks.

I'm not testing on single player, BTW. It's a separate Debian linux VMware instance running tekkit 1.1.5 server on a server platform on my local network. I dropped a dimensional anchor and have multiple computers running instances of my code. I'm going to put MCPC+ on next to see if I can reproduce it there.

Oh then it's interesting. Are you letting it run for a long period?

Link to post
Share on other sites

Oh then it's interesting. Are you letting it run for a long period?

A couple days so far... the host server is *mostly* 24/7 barring any major power outages, but it's only getting me logging in/out to check on the lua-script logs to make sure the timestamps kept increasing, occasionally check some tidbit of Atomic Science testing, and the lua scripts running on the CC computers.

Link to post
Share on other sites

A couple days so far... the host server is *mostly* 24/7 barring any major power outages, but it's only getting me logging in/out to check on the lua-script logs to make sure the timestamps kept increasing, occasionally check some tidbit of Atomic Science testing, and the lua scripts running on the CC computers.

Let's try it on the live server then. 1.1.7 has been running smoothly so far.

Link to post
Share on other sites
  • 2 weeks later...

He has never been reported on this server before, maybe on others. He is permanently banned now. I checked the logs and he did indeed try to grief.

I am the kid that was banned and i would like to try to appeal it and I do not think that this is fair i was griefed and trolled by a kid named SilentZoom who killed all my animals took some of my stuff and destroyed everything around my house that he could that could then quit the server all i did was mess around with him and place lux capacitors and in the end we became friends and i apologized to him I really would like to get unbanned I love this server its really fun to play on and i promise that you would never here from me again i would be peaceful and mind my own business i apologize for everything and anything i did and i hope u would be kind enough to unban me cause i love this server thank you

Link to post
Share on other sites

Announcements




×
×
  • Create New...