Jump to content

Server Issues while exploring


Recommended Posts

I run a small server for my wife and 2 friends. The server is hosted locally on the PC that i use to play the game and to give a bit of backround, i have played FTB Ultimate and Mindcrack and other things while hosting, including the new Tekkit with no issues..

However, with BigDig i have an issue with exploration just killing the server. Not fast exploration either, or even running exploration for that matter, just walking. My wife and i both walking straight west looking for a nice meadow to start a new base caused the server to choke up severly several times, i'm talking 20-30 second block lag with characters teleporting around.

I know that in the past exploring does cause a high strain on the PC and if you were moving at a high rate of speed, maybe... double a run? while flying, u could easilly cause the server to redline. However i have never seen it this bad with just walking. Maybe if we were in Twilight Forest or something... but not just standard biomes.

Has anyone else encountered this issue? or know of any solutions to the problem?

My PC uses 8 gigs of ram with a SSD for the System drive that i use for my MC server as well with a i7Intel <first gen>. My systems CPU does not seem effected by the server lag either, so i dont think its a hardware problem. I do run the server with the Java command to increase permsize and i run the server with the default string, which i believe is 2 or 3 gigs of ram dedicated to it.

Any help would be appreciated.. thanks.

Link to post
Share on other sites

I'm having the exact same problem with my 8 Slot server, apart from mines not hosted locally it's hosted by a dedicated host (Multiplay). I've had no issues with any other mod pack apart from this update of Big Dig.

I've got 2gb dedicated to server, and 4gb allocated to my MC and all of the players have pretty much the same set up as me.

No idea why, been surfing through trying to find how to fix and your the first post I've seen with the same issue!

Link to post
Share on other sites

Here is what startup batch looks like:

java -XX:MaxPermSize=1024M -Xmx8G -jar BigDig.jar nogui --log-limit 100000

:edit: <Curse you shortcut keys!>

Oddly enough, I'm finding that chunkloaders are not really needed any more and my machines work regardless if someone's on, or off the server. This may also be causing some of the problems. RAM flushing is far more efficient on the server versus client. It seems the more my denizens explore, the more RAM chewed by the server.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...