Sign in to follow this  
Draceb

Are worlds from 1.0.0 compatible with 1.0.1?

Recommended Posts

I just downloaded the new 1.0.1 server, copied files to my new hexxit server file folder then started her up and it was spewing all these chunk repairs saying [artifice] Regerated 612 chunks. 29 chunks left and so on down to 0. and i logged in it seemed ok but it kept spewing chunk repairs sorry nothing to paste, no crash reports showed up and after that i stopped server to start again hoping it was done.

When i started her up again the server will not even start. I also have the problem where when i try to copy and paste from the cmd window it just wont let me. I select all then using key commands try to paste it to notepad but nadda. Just wont take prolly more a vista problem then anything. Either way i am hoping this gets addressed been actively playing on a world wouldnt really want to start again will if i have to but its a shame when versions get updated they should account for people wanting to keep worlds.

Any input would be greatly appreciated. I did think of a screen shot but there is to much in the window to fit on screen so i nixed that idea.

Share this post


Link to post
Share on other sites

First time I loaded the new server files it kept crashing while it was loading. Thankfully I backed up my old server before I did this, so I was able to install the server files to a fresh folder then copied the world folder from my backup before I logged in. Updated the client files from the launcher, and when I got in, my old world was still there. Bonus feature, new blocks had generated in the parts of the world I'd already explored (thank you for basalt and marble!), so don't hesitate to go back to places you've already been.

Share this post


Link to post
Share on other sites

well here is exactly what i did this time. and so far so good ill keep my fingers crossed, after that last server wouldnt restart i just unzipped the 1.0.1 server into an empty folder again, set my launcher copy/pasted my old world and ran it. let it sit for a good while. thus far client has had no issue so i loaded it up and went int did its chunks thing and i left it sit for a while then i did the /save-all this time before the stop command and when i booted it back up no problems. Must have just gotten upset when i was floating around. dunno shrugs. either way thanks for the input seems as you say the new files just need to update the old ones.

when you say log do you mean the server.log.lck files? thats only one i see like that. also since space is limited how do you post long strings of code and have them in those small compressed windows people use im not forum code saavy and am wondering how to do that so i can post code without the forum getting upset its too long. thanks agian for everyone quick input.

Share this post


Link to post
Share on other sites

Everything worked fine for me. I basically installed 1.0.1 then copied my world over and started it up. It looks like it had to do something with every chunk that was created but the world still works fine...more flowers it seems :P

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this