Sign in to follow this  
77ab2

major lag worse than ftb which has almost double the mod packs

Recommended Posts

i have so much lag i can barely move i cant even pick anything up, please either fix the modpacks glitches or straighten out the modpacks or something to fix the lag, even optifine wont help it!!!

Share this post


Link to post
Share on other sites

yeah, there's major lag, probably because Hexxit contains a lot of complex terrain generation, even underground. For now I just turn off clouds, bobbing, tune down the render distance, and change to fast graphics. It's worth it for the awesome experience that Hexxit is.

Share this post


Link to post
Share on other sites

77ab2, you do realize the number of mods doesn't really matter. It is what the mods do. This set of mods has some very demanding requirements and the mod caters for updating chucks that have been already generated putting in new content. How about you get a better computer?

Share this post


Link to post
Share on other sites

You don't need 3Gb of RAM, this modpack was engineered to work with 1, but generating chunks can take a bit, depending on what your machine is like. If you're having really just shit-awful performance one thing I'd look into is your java version- make sure you have a 64 bit version and make sure it's the latest available for your OS (macs 1.6.0_45, everyone else 1.7.0_25). The best improvement you can give your computer to play hexxit more easily is a faster hard drive, if you're playing in SSP.

Share this post


Link to post
Share on other sites

If you're having really just shit-awful performance one thing I'd look into is your java version- make sure you have a 64 bit version and make sure it's the latest available for your OS (macs 1.6.0_45, everyone else 1.7.0_25).

Actually CanVox, Java was updated to 1.6.0_51 a week or so ago:

http://support.apple.com/kb/dl1572

And as of 10.8.4, if you don't have a java installation you'll be pushed to Oracle's download page for the latest Java 7 JRE.

Share this post


Link to post
Share on other sites

Ah, they must have incremented to _51 when 1.7 incremented to _25. Regardless, older versions tend to perform worse than newer versions, etc.

Share this post


Link to post
Share on other sites

My machine seams to handle hexxit just fine, but when I'm loading new chunks it comes to a crawl. Especially if I'm flying on my golden chocobo. I sometimes fly out and expand my map radius in a scouting run before I actually set out to explore an area. That way I can delag the area and not have to worry about new chunks coming into loading range while I'm exploring a dangerous new ruins or something.

Share this post


Link to post
Share on other sites

My machine seams to handle hexxit just fine, but when I'm loading new chunks it comes to a crawl. Especially if I'm flying on my golden chocobo. I sometimes fly out and expand my map radius in a scouting run before I actually set out to explore an area. That way I can delag the area and not have to worry about new chunks coming into loading range while I'm exploring a dangerous new ruins or something.

I suggest turning FOV to normal, Max FPS, and graphics to fast, I run @ like 120 fps with those settings. Oh and smooth lighting to minimum

Share this post


Link to post
Share on other sites

There's no real way to fix the gen lag short of pregenning your worlds scouting is probably the safest thing you can do, RBF, it's not about graphics most of those aren't handled by your CPU, which is what is processing a massive load of shit everytime you gen new chunks in hexxit, depending on what you get there are many massive objects to gen, this is gonna cause lag.

Share this post


Link to post
Share on other sites

So after installing the Java 7 on Mac, the crash report (for installing Optifine) it still shows that Hexxit is trying to run on an old Java, is there a way to tell it to use Java 7?

-- System Details --

Details:

    Minecraft Version: 1.5.2

    Operating System: Mac OS X (x86_64) version 10.8.4

    Java Version: 1.6.0_51, Apple Inc.

    Java VM Version: Java HotSpot 64-Bit Server VM (mixed mode), Apple Inc.

    Memory: 42893480 bytes (40 MB) / 130887680 bytes (124 MB) up to 6438125568 bytes (6139 MB)

    JVM Flags: 2 total; -Xmx6144m -XX:MaxPermSize=256m

    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used

    Suspicious classes: FML and Forge are installed

    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0

    FML:

    LWJGL: 2.4.2

    OpenGL: NVIDIA GeForce 320M OpenGL Engine GL version 2.1 NVIDIA-8.12.47 310.40.00.05f01, NVIDIA Corporation

    Is Modded: Definitely; Client brand changed to 'fml,forge'

    Type: Client (map_client.txt)

    Texture Pack: Default

    Profiler Position: N/A (disabled)

Share this post


Link to post
Share on other sites

So after installing the Java 7 on Mac, the crash report (for installing Optifine) it still shows that Hexxit is trying to run on an old Java, is there a way to tell it to use Java 7?

-- System Details --

Details:

    Minecraft Version: 1.5.2

    Operating System: Mac OS X (x86_64) version 10.8.4

    Java Version: 1.6.0_51, Apple Inc.

    Java VM Version: Java HotSpot 64-Bit Server VM (mixed mode), Apple Inc.

    Memory: 42893480 bytes (40 MB) / 130887680 bytes (124 MB) up to 6438125568 bytes (6139 MB)

    JVM Flags: 2 total; -Xmx6144m -XX:MaxPermSize=256m

    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used

    Suspicious classes: FML and Forge are installed

    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0

    FML:

    LWJGL: 2.4.2

    OpenGL: NVIDIA GeForce 320M OpenGL Engine GL version 2.1 NVIDIA-8.12.47 310.40.00.05f01, NVIDIA Corporation

    Is Modded: Definitely; Client brand changed to 'fml,forge'

    Type: Client (map_client.txt)

    Texture Pack: Default

    Profiler Position: N/A (disabled)

Did you install the Java 7 JRE or the JDK? OS X will need the JDK to run java 7 applications and java command line. If you open /Applications/Terminal.app then type "java -version" (without the quotes) what does it say?

Share this post


Link to post
Share on other sites

I feel we are getting closer to something!!

I think I installed the JRE, I didn't thought I needed the development kit, but will give it a try right now.

Result of Terminal reply:

java version "1.6.0_51"

Java SE Runtime Environment (build 1.6.0_51-b11-457-11M4509)

Java HotSpot 64-Bit Server VM (build 20.51-b01-457, mixed mode)

Share this post


Link to post
Share on other sites

Yep, that's telling me that you have Java 6 installed as far as command line and launching JAR applications is concerned. It's possible to use the JRE as the system default for all things java, but it's usually easier to just install the JDK. Once installed, you'll have /Library/Java/JavaVirtualMachines/jdk1.7.0_25.jdk, which should take over as the default java install for all java command-line and JAR apps. You can confirm by running that same Terminal command. If for some reason it is still reporting Java 6, your JAVA_HOME environment variable might need to be fixed, in which case try this in Terminal:

export JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.7.0_25.jdk/Contents/Home

We can also try monkeying with the symlink for java in /usr/bin, but hopefully it doesn't come to that.

Share this post


Link to post
Share on other sites

Yep, that's telling me that you have Java 6 installed as far as command line and launching JAR applications is concerned. It's possible to use the JRE as the system default for all things java, but it's usually easier to just install the JDK. Once installed, you'll have /Library/Java/JavaVirtualMachines/jdk1.7.0_25.jdk, which should take over as the default java install for all java command-line and JAR apps. You can confirm by running that same Terminal command. If for some reason it is still reporting Java 6, your JAVA_HOME environment variable might need to be fixed, in which case try this in Terminal:

I am having the same issue as AngelMalus. I downloaded the JDK 1.7 and ran the installer, then executed java -version terminal command and still show java 1.6. Tried running the terminal command you listed and still am showing java 1.6. i don't know where to go from here.

Share this post


Link to post
Share on other sites

I'll try to cover the bases, but there's a lot that could be wrong so I can't be sure everything will apply. Some of the commands are just to gather information from your computer, so I know how to try to fix it.

1)

which java

This will tell us which java your system is using to launch JAR files. I expect it to return "/usr/bin/java/". If so, proceed to the next step, otherwise let me know what it returns.

2)

ls -la /usr/bin/java

This will tell us where that java symlink is pointing to. I expect it to return "/usr/bin/java/ -> /System/Library/Frameworks/JavaVM.framework/Home/bin/java", but it might say something else. This would explain why installing the JDK didn't do anything.

3)

ls -la /Library/Java/JavaVirtualMachines/

This will confirm that the Java 7 JDK was installed properly. I expect one of the lines to read "jdk1.7.0_25.jdk". If so, proceed to the next step, otherwise let me know what it returns.

4)

sudo mv /usr/bin/java /usr/bin/java.old

This will set aside the current symlink that (I suspect) the system is using. Your administrator password will be required, just type it in and press return (you won't get any feedback that it is being entered, no dots or stars).

5)

sudo ln -s /Library/Java/JavaVirtualMachines/jdk1.7.0_25.jdk/Contents/Home/bin/java /usr/bin/java

Provided that all the previous steps returned the information I expected to find, this command will create a new symlink from the Java 7 JDK to /usr/bin/java, which is what TechnicLauncher will use to open and what command returns the version number when you run "java -version".

6) Confirm the symlink is working by typing

java -version
once again.

Let me know if there are any problems with those steps and provide the information that is returned in Terminal and I can try to help.

Share this post


Link to post
Share on other sites

I'll try to cover the bases, but there's a lot that could be wrong so I can't be sure everything will apply. Some of the commands are just to gather information from your computer, so I know how to try to fix it.

Let me know if there are any problems with those steps and provide the information that is returned in Terminal and I can try to help.

Steps 1 and 2 returned the information as expected.

Step 3 however returned the following information:

/usr/bin/java -> /System/Library/Frameworks/JavaVM.framework/Versions/Current/Commands/java

I haven't tried steps 4 - 6 since the information in step 3 came back different…so I would expect that any of the next steps would not work properly anyway.

Share this post


Link to post
Share on other sites

Steps 1 and 2 returned the information as expected.

Step 3 however returned the following information:

/usr/bin/java -> /System/Library/Frameworks/JavaVM.framework/Versions/Current/Commands/java

I haven't tried steps 4 - 6 since the information in step 3 came back different…so I would expect that any of the next steps would not work properly anyway.

Actually, you know what? I'm looking at another system and see my symlink in /usr/bin is pointing to the same place yours is. I must have been messing with java on the computer I was looking at before, sorry for the erroneous info. The information might also be different depending on WHEN you installed java. If you have 10.8, the java VM that is downloaded changed from 10.8-10.8.3 to 10.8.4; in 10.8.4 Java 7 is pushed, and Java 6 was pushed in 10.8-10.8.3.

In the end, it doesn't matter too much. We are setting aside the old symlink, regardless of where it is leading, and making a new one that points to Java 7. The rest of the steps should be OK, provided that step 3 confirms that you have a Java 7 JDK in /Library/Java/JavaVirtualMachines/

Share this post


Link to post
Share on other sites

Actually, you know what? I'm looking at another system and see my symlink in /usr/bin is pointing to the same place yours is. I must have been messing with java on the computer I was looking at before, sorry for the erroneous info. The information might also be different depending on WHEN you installed java. If you have 10.8, the java VM that is downloaded changed from 10.8-10.8.3 to 10.8.4; in 10.8.4 Java 7 is pushed, and Java 6 was pushed in 10.8-10.8.3.

In the end, it doesn't matter too much. We are setting aside the old symlink, regardless of where it is leading, and making a new one that points to Java 7. The rest of the steps should be OK, provided that step 3 confirms that you have a Java 7 JDK in /Library/Java/JavaVirtualMachines/

Well as I posted earlier, step 1 worked as expected, step 2 came back with the different result…might be right or might be wrong. Step 3 however isn't showing any results. I get the following when I enter the step 3 command:

ls -la /Library/Java/JavaVirtualMachines/

total 0

Along with some *nix user/group/other settings and no named directories

Since that is coming back empty, it would seem that some investigation will need to be undertaken to determine the location of the JDK install.

Share this post


Link to post
Share on other sites

If /Library/Java/JavaVirtualMachines is empty, then the JDK didn't install properly. Are you sure you got "jdk-7u25-macosx-x64.dmg" from http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html?

Ok, downloaded from the link you provided. Now I am showing Java 1.7.xx. I don't know what it was before, but apparently the main download page from Oracle, doesn't link to correct, functional downloads.

Edit update: Curious, all the steps worked (no errors were thrown) after using the download link provided. But now the java -version command throws an error stating that that command cannot be found. That would seem to indicate that the symlink wasn't created correctly. I'll try and create the symlink again and see if the result changes.

2nd Edit Update: Ok, apparently I must have typed something wrong the first time I tried to create the new symlink. I went back in and entered the command again to create the symlink. I double checked to make sure that everything was entered correctly, and then after creating the new symlink, I again tried java -version and this time it worked, and it also shows as java 1.7.0_25. So apparently everything should be good going forward.

Thanks, Dash16 for your time and assistance.

Share this post


Link to post
Share on other sites

Glad you got it sorted. You may want to manually update LWJGL as well, I've had some issues on some Macs with only Java 7 updated.

Share this post


Link to post
Share on other sites

Hi you guys sound a bit more computer smart for me.. Im not sure if I am having the same problem but hopefully one of you will know what to do.. I open the hexxit mod, and play for maybe 5 min and then it crashed stating that the game has run out of system memory. I have no idea what I am supposed to do sorry not at all computer smart... Please help thanks

Share this post


Link to post
Share on other sites

Hi you guys sound a bit more computer smart for me.. Im not sure if I am having the same problem but hopefully one of you will know what to do.. I open the hexxit mod, and play for maybe 5 min and then it crashed stating that the game has run out of system memory. I have no idea what I am supposed to do sorry not at all computer smart... Please help thanks

What OS are you using? Also post your crash log if you have one, that will make it easier to determine if there is a mod issue. Also in the Technic launcher main page, click the gear icon in the upper right corner. In the window that pops up, check the perm gen option, and maybe increase your memory allocation to 1 or 1.5 in the same window.

Share this post


Link to post
Share on other sites

What OS are you using? Also post your crash log if you have one, that will make it easier to determine if there is a mod issue. Also in the Technic launcher main page, click the gear icon in the upper right corner. In the window that pops up, check the perm gen option, and maybe increase your memory allocation to 1 or 1.5 in the same window.'-==

Windows 7

I updated my java to and it kept saying that I needed to make sure that it was whitelisted on all antivirus apps I couldnt figure that out so

I spoke to one of my sons friends... probably should have waited they told me to go into appdata and delete the whole file then reload... I did.. but now there are no mods on it at all and I dont know how to get them back :( my son wont talk to me because I cant make this work.. And I just cant seem to get it...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this