Sign in to follow this  
MrTwinkeh

How to install OptiFine into Hexxit [Mac]

Recommended Posts

Oh I though he accidently posted a reply for a camera forum here.

Well I don't use my PC for photography but I do use it for Image editing and 3D rendering on C4D/Photoshop, that's when you'll experience the true power of an 8 threaded Xeon.

When it comes to video editing it's ridiculously fast as After Effects can take advantage of my GTx 780. I'm fairly certain mac has an advantage in photography like you mentioned but it's not something I've ever considered using a PC for but it's an interest I may pursue in the future.

Share this post


Link to post
Share on other sites

Not like I don't believe you, but would you have a proof that it actually works. The screenshoots only show CurrentOptifine -_- so it wont even show the version. And I can't see the Hexxit name in none of the folders.

If you have a screenshot of running hexxit with optifine on your mac would be nice.

Also what version of Optifine exactly you installed?

Oops, I was under the influence that it wouldn't really matter for that. The reason is wrote 'Current Optifine' was so that everyone understood that the Optifine to be installed was in fact the current Optifine. The Optifine version I used was the Ultra version... OptiFine 1.4.6_HD_U_D5 to be exact. I installed it exactly like this beforehand, and it started just fine. If you really want some proof, I can make it, but otherwise I'm sure you can trust me :).

Share this post


Link to post
Share on other sites

Optifine 1.4.6? Interesting, as Hexxit minecraft version is 1.5.2. Will have to give it a go with that version, wouldn't surprise me if that worked when later versions don't.

Sometimes modpatching stuff like this feels like voodoo. It shouldn't work, but it does. Or you expect it to work, and it doesn't.

[Edit: I'm disinclined to believe the original instructions myself now. I've used the same Optifine version mentioned, and not only do I not get the extra Optifine video settings I also lose the 'Mods' button on the main menu. I didn't even bother trying to connect to my server to test, I didn't want to risk screwing up my local client data even further or causing weird stuff with the server.

I'm with AngelMalus: Pics or it didn't happen.]

Share this post


Link to post
Share on other sites

Windows, Mac doesn't matter really.

Here is the ForgeModLoader-client-0.log after the crash:

2013-07-17 05:42:01 [iNFO] [ForgeModLoader] Forge Mod Loader version 5.2.23.737 for Minecraft 1.5.2 loading

2013-07-17 05:42:01 [iNFO] [ForgeModLoader] Java is Java HotSpot 64-Bit Server VM, version 1.6.0_51, running on Mac OS X:x86_64:10.8.4, installed at /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home

2013-07-17 05:42:01 [FINE] [ForgeModLoader] Java classpath at launch is /Users/apple/Library/Application Support/techniclauncher/TechnicLauncher.jar

2013-07-17 05:42:01 [FINE] [ForgeModLoader] Java library path at launch is .:/Library/Java/Extensions:/System/Library/Java/Extensions:/usr/lib/java

2013-07-17 05:42:01 [FINE] [ForgeModLoader] Enabling runtime deobfuscation

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] All core mods are successfully located

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Discovering coremods

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Found a candidate coremod CoFHCore-1.5.2.4.jar

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Loading coremod CoFHCore-1.5.2.4.jar

2013-07-17 05:42:01 [WARNING] [ForgeModLoader] The coremod cofh.asm.CoFHPlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Loaded coremod CoFHCore-1.5.2.4.jar

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Found a candidate coremod CodeChickenCore 0.8.7.jar

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Loading coremod CodeChickenCore 0.8.7.jar

2013-07-17 05:42:01 [WARNING] [ForgeModLoader] The coremod codechicken.core.asm.CodeChickenCorePlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Loaded coremod CodeChickenCore 0.8.7.jar

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Found a candidate coremod CustomPortForge.jar

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Loading coremod CustomPortForge.jar

2013-07-17 05:42:01 [WARNING] [ForgeModLoader] The coremod CustomLAN.CoreMod.CustomLANLoadingPlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Loaded coremod CustomPortForge.jar

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Found a candidate coremod NotEnoughItems 1.5.2.28.jar

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Loading coremod NotEnoughItems 1.5.2.28.jar

2013-07-17 05:42:01 [WARNING] [ForgeModLoader] The coremod codechicken.nei.asm.NEICorePlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Loaded coremod NotEnoughItems 1.5.2.28.jar

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Found a candidate coremod [1.5.2]TreeCapitator.Forge.1.5.2.r01.Uni.CoreMod.jar

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Loading coremod [1.5.2]TreeCapitator.Forge.1.5.2.r01.Uni.CoreMod.jar

2013-07-17 05:42:01 [WARNING] [ForgeModLoader] The coremod bspkrs.treecapitator.fml.asm.TreeCapitatorCorePlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Loaded coremod [1.5.2]TreeCapitator.Forge.1.5.2.r01.Uni.CoreMod.jar

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Found a candidate coremod immibis-microblocks-55.0.1.jar

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Loading coremod immibis-microblocks-55.0.1.jar

2013-07-17 05:42:01 [WARNING] [ForgeModLoader] The coremod mods.immibis.microblocks.coremod.MicroblocksCoreMod does not have a MCVersion annotation, it may cause issues with this version of Minecraft

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Loaded coremod immibis-microblocks-55.0.1.jar

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Found library file argo-small-3.2.jar present and correct in lib dir

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Found library file guava-14.0-rc3.jar present and correct in lib dir

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Found library file asm-all-4.1.jar present and correct in lib dir

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Found library file bcprov-jdk15on-148.jar present and correct in lib dir

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Found library file deobfuscation_data_1.5.2.zip present and correct in lib dir

2013-07-17 05:42:01 [FINEST] [ForgeModLoader] Found library file scala-library.jar present and correct in lib dir

2013-07-17 05:42:02 [iNFO] [sTDOUT] [CustomLAN]: Adding transformer map: customlan_at.cfg

2013-07-17 05:42:02 [FINEST] [ForgeModLoader] Running coremod plugins

2013-07-17 05:42:02 [FINEST] [ForgeModLoader] Running coremod plugin FMLCorePlugin

2013-07-17 05:42:04 [iNFO] [ForgeModLoader] Found valid fingerprint for Minecraft Forge. Certificate fingerprint de4cf8a3f3bc15635810044c39240bf96804ea7d

2013-07-17 05:42:04 [FINEST] [ForgeModLoader] Coremod plugin FMLCorePlugin run successfully

2013-07-17 05:42:04 [FINEST] [ForgeModLoader] Running coremod plugin FMLForgePlugin

2013-07-17 05:42:04 [FINEST] [ForgeModLoader] Coremod plugin FMLForgePlugin run successfully

2013-07-17 05:42:04 [FINEST] [ForgeModLoader] Running coremod plugin CoFHPlugin

2013-07-17 05:42:04 [FINEST] [ForgeModLoader] Coremod plugin CoFHPlugin run successfully

2013-07-17 05:42:04 [FINEST] [ForgeModLoader] Running coremod plugin CodeChickenCorePlugin

2013-07-17 05:42:04 [iNFO] [sTDOUT] Adding Accesstransformer map: codechickencore_at.cfg

2013-07-17 05:42:04 [FINEST] [ForgeModLoader] Coremod plugin CodeChickenCorePlugin run successfully

2013-07-17 05:42:04 [FINEST] [ForgeModLoader] Running coremod plugin CustomLANLoadingPlugin

2013-07-17 05:42:04 [FINEST] [ForgeModLoader] Coremod plugin CustomLANLoadingPlugin run successfully

2013-07-17 05:42:04 [FINEST] [ForgeModLoader] Running coremod plugin NEICorePlugin

2013-07-17 05:42:04 [iNFO] [sTDOUT] Adding Accesstransformer map: nei_at.cfg

2013-07-17 05:42:04 [FINEST] [ForgeModLoader] Coremod plugin NEICorePlugin run successfully

2013-07-17 05:42:04 [FINEST] [ForgeModLoader] Running coremod plugin TreeCapitatorCorePlugin

2013-07-17 05:42:04 [FINEST] [ForgeModLoader] Coremod plugin TreeCapitatorCorePlugin run successfully

2013-07-17 05:42:04 [FINEST] [ForgeModLoader] Running coremod plugin MicroblocksCoreMod

2013-07-17 05:42:04 [FINEST] [ForgeModLoader] Coremod plugin MicroblocksCoreMod run successfully

2013-07-17 05:42:04 [FINEST] [ForgeModLoader] Validating minecraft

2013-07-17 05:42:05 [FINEST] [ForgeModLoader] Minecraft validated, launching...

2013-07-17 05:42:07 [iNFO] [sTDOUT] Inserted super call into azg.c

2013-07-17 05:42:08 [iNFO] [sTDOUT] ayl was overriden from NotEnoughItems 1.5.2.28.jar

2013-07-17 05:42:10 [iNFO] [sTDOUT] Generated BlockMobSpawner helper method.

2013-07-17 05:42:11 [iNFO] [sTDOUT] 229 recipes

2013-07-17 05:42:11 [iNFO] [sTDOUT] 27 achievements

2013-07-17 05:42:12 [iNFO] [Minecraft-Client] Setting user: AngelMalus

2013-07-17 05:42:12 [iNFO] [sTDOUT] (Session ID is 7646434576511561582)

2013-07-17 05:42:12 [iNFO] [sTDERR] Initial mode: 1920 x 1080 x 32 @60Hz

2013-07-17 05:42:12 [iNFO] [Minecraft-Client] LWJGL Version: 2.4.2

2013-07-17 05:42:13 [iNFO] [sTDERR] GL_EXT_direct_state_access was reported as available but an entry point is missing

2013-07-17 05:42:13 [iNFO] [sTDERR] GL_NV_primitive_restart was reported as available but an entry point is missing

2013-07-17 05:42:13 [iNFO] [sTDERR] org.lwjgl.opengl.OpenGLException: Invalid value (1281)

2013-07-17 05:42:13 [iNFO] [sTDERR]    at org.lwjgl.opengl.Util.checkGLError(Util.java:56)

2013-07-17 05:42:13 [iNFO] [sTDERR]    at org.lwjgl.opengl.Display.swapBuffers(Display.java:645)

2013-07-17 05:42:13 [iNFO] [sTDERR]    at net.minecraft.client.Minecraft.func_71357_I(Minecraft.java:518)

2013-07-17 05:42:13 [iNFO] [sTDERR]    at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:407)

2013-07-17 05:42:13 [iNFO] [sTDERR]    at net.minecraft.client.MinecraftAppletImpl.func_71384_a(SourceFile:56)

2013-07-17 05:42:13 [iNFO] [sTDERR]    at net.minecraft.client.Minecraft.run(Minecraft.java:733)

2013-07-17 05:42:13 [iNFO] [sTDERR]    at java.lang.Thread.run(Thread.java:680)




And here is the crash-report:




---- Minecraft Crash Report ----

// Ooh. Shiny.

 

Time: 7/17/13 5:42 AM

Description: Failed to start game

 

org.lwjgl.opengl.OpenGLException: Invalid value (1281)

    at org.lwjgl.opengl.Util.checkGLError(Util.java:56)

    at org.lwjgl.opengl.Display.swapBuffers(Display.java:645)

    at net.minecraft.client.Minecraft.func_71357_I(Minecraft.java:518)

    at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:407)

    at net.minecraft.client.MinecraftAppletImpl.func_71384_a(SourceFile:56)

    at net.minecraft.client.Minecraft.run(Minecraft.java:733)

    at java.lang.Thread.run(Thread.java:680)

 

 

A detailed walkthrough of the error, its code path and all known details is as follows:

---------------------------------------------------------------------------------------

 

-- System Details --

Details:

    Minecraft Version: 1.5.2

    Operating System: Mac OS X (x86_64) version 10.8.4

    Java Version: 1.6.0_51, Apple Inc.

    Java VM Version: Java HotSpot 64-Bit Server VM (mixed mode), Apple Inc.

    Memory: 42893480 bytes (40 MB) / 130887680 bytes (124 MB) up to 6438125568 bytes (6139 MB)

    JVM Flags: 2 total; -Xmx6144m -XX:MaxPermSize=256m

    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used

    Suspicious classes: FML and Forge are installed

    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0

    FML:

    LWJGL: 2.4.2

    OpenGL: NVIDIA GeForce 320M OpenGL Engine GL version 2.1 NVIDIA-8.12.47 310.40.00.05f01, NVIDIA Corporation

    Is Modded: Definitely; Client brand changed to 'fml,forge'

    Type: Client (map_client.txt)

    Texture Pack: Default

    Profiler Position: N/A (disabled)

    Vec3 Pool Size: ~~ERROR~~ NullPointerException: null

Share this post


Link to post
Share on other sites

Just an update. I was able to install OptiFine_1.5.2_L_D2.zip but of course it comes with no settings and I can't tell if there is any improvement on FPS at all. After running it, I've tried to load the modified Sphax PureBDcraft 128x MC15 texturepack that I use in Linux on the same computer. And of course it sicks it down like there is no tomorrow.

Share this post


Link to post
Share on other sites

Just an update. I was able to install OptiFine_1.5.2_L_D2.zip but of course it comes with no settings and I can't tell if there is any improvement on FPS at all. After running it, I've tried to load the modified Sphax PureBDcraft 128x MC15 texturepack that I use in Linux on the same computer. And of course it sicks it down like there is no tomorrow.

Yeah, most likely it either didn't install or it installed incorrectly. That experience seems pretty similar to what I described in a previous post on this thread. It later turned out that it (Optifine) apparently wasn't installed, since my frames basically went straight back to where they previously had been (single-digits and mid-teens to low twenties).

From a simple web search, I and others have found that the error code on the first line of the crash log after the description, apparently has something to do with an incompatible texture or a texture that is too large. This would seem to me to indicate that there is a development issue at work here that needs to be addressed in a future update to the modpack.

We can only hope that the modpack developers see these crash logs and analyze them to determine the issue, and then correct it (hopefully sooner rather than later!).

Share this post


Link to post
Share on other sites

Most funny thing is that its only on Mac. Linux and Windows seem to run any version without trouble. Even on this same computer, I have a Linux partition and it works sooooo much faster. Problem is that recording on linux is not that easy.

Share this post


Link to post
Share on other sites

Most funny thing is that its only on Mac. Linux and Windows seem to run any version without trouble. Even on this same computer, I have a Linux partition and it works sooooo much faster. Problem is that recording on linux is not that easy.

Yeah, it would seem that the modpack and possibly the launcher have some "issue" with Mac OS X, especially when it comes to using Optifine. It would be really nice if Optifine could be just dropped into the mods folder and then have a simple little config that could be editied to define load order, since Optifine generally is supposed to be loaded after all other mods, unless specified otherwise.

In the meantime barring that, it would be great if the modpack developers would be able to analyze the error logs related to the mac/optifine install issues, and try to determine what that issue is so it can be sorted out and corrected.

Share this post


Link to post
Share on other sites

hexxit.pngoptifine is not working on my hexxit it just shows a black screen and then says minecraft has crashed is there a way to fix this

Are you using Mac OS X?

Also post your crash log. You'll find it in your Hexxit folder.

Share this post


Link to post
Share on other sites

I've tried the Optifine Lite, not really same boost as the Standard one would give to Tekkit Lite or Hexxit on the same computer but different OS. Its been quite long, and I even went ahead and FORMAT my HD and installed Mountain Lion all the way from zero.

After few updates and all. Super clean Technic Launcher and all. Still no work at all. Same error over and over.

It is a fact, Optifine DOES NOT WORK for HEXXIT ON A MAC.

At least not in my MacBook Pro 8.2 (Yes the one from 2010, don't like it? buy me a new one -_-)

I do have 500 GB HDD, 8 GB in Ram and 256 NVidia card on it.

And interesting thing. I had a partition with Linux (Ubuntu) and Optifine for Hexxit worked perfectly fine. Not even that, but I was able to run the 128 Sphax texturepack on Fancy, Smooth Lighting and Far render with 40-60 FPS and I only allocate 1GB of RAM to the Launcher.

Share this post


Link to post
Share on other sites

I figured it out! Will be posting a tutorial soon. I have Hexxit running with Optifine D5 with SPhax texturepack again. So perfect!!

This is on the Mac correct? And you have confirmed that Optifine is indeed installed, and functioning correctly? If so, I eagerly await your tutorial, so that I can give it a try!

Oh! Don't leave us hangin'! We'll look forward to your tutorial, but what was the gist of the solution?

I agree, I have been trying to get Optifine into Hexxit since late June…because of the issues with Hexxit/MC, Optifine & Mac (lag is the killer) I have essentially given up trying to play Hexxit. So anything new that can be tried would be really good!

Share this post


Link to post
Share on other sites

I figured it out! Will be posting a tutorial soon. I have Hexxit running with Optifine D5 with SPhax texturepack again. So perfect!!

This is sort of a late reply but.. I really need that tutorial, could you please share it.

Thanks in advance.

 

- Edward

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this