Jump to content

Technic Launcher Can't Connect to Minecraft.net


Recommended Posts

I logged off of Tekkit Classic, quit the game, and took a short break. When I tried launching Tekkit Classic again, it tells me that it can't connect to Minecraft.net

I have already tried deleting the .technic folders in roaming and having the launcher redownload everything. Speaking of redownloading, I already tried that with the launcher as well. I tried restarting my computer, running as administrator, and I even tried logging in with a friend's account. I restarted my router and modem, everything. Nothing seems to be working.

The Minecraft Servers are all up and running, it's only Technic that won't connect me to Minecraft.net and I'm not sure what the problem is. I'm almost positive that this question has multiple answers from browsing around on other places, but none of those "solutions" have worked.

Any help would be MUCH MUCH appreciated. Thanks [=

Edit: I also checked my Java, and I'm using the latest update, Java 7 (64x)

Link to post
Share on other sites
  • 2 weeks later...

Guys i have had a problem where im unable to connect to any server i dont know why even when people are on it

i got a feeling its got somthing to do with the new minecraft launcher I got for the horse update because it started after i got it and in the main menu "In the tekkit one" Its advertising the new launcher.

Please i have been asking for weeks but nobody will help me

Link to post
Share on other sites

@Vivacity - thanks, but as it turns out I'm not currently using an anti-virus software (I'm currently downloading one as we speak). I'm thinking I need some kind of internet connection for the Technic launcher to work as it errors out with "cannot authenticate account with Minecraft.net". This would appear, to me, that it needs to connect to Minecraft.net in order to check my credentials, though I'm not entirely certain why (I have a legit account)...

Link to post
Share on other sites
  • 2 weeks later...
  • 4 months later...
  • 3 weeks later...
  • 1 month later...

I had the same problem as most of you, this is what i did:

1. Migrate your account by signing in here https://account.mojang.com/login?redirect=https://mojang.com/

2. Log out of both minecraft and technic on their launchers

3. Relog on minecraft first then on technic

It should work now, this worked for me

I just tried that and it didnt work. what should I do?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...