Jump to content

Can't Load Worlds


WombatKing
 Share

Recommended Posts

Same problem I tried remove quantum link on moon, computer crashed and now i can't load my world.

Last things on console are like this

2013-09-23 16:19:32 [iNFO] [Galacticraft] Unregistered Dimension: -28

2013-09-23 16:19:32 [iNFO] [ForgeModLoader] The state engine was in incorrect state ERRORED and forced into state SERVER_STOPPED. Errors may have been discarded.

2013-09-23 16:19:32 [iNFO] [ForgeModLoader] The state engine was in incorrect state ERRORED and forced into state AVAILABLE. Errors may have been discarded.

I thing something is wrong with Moon, how to reset it?

Link to comment
Share on other sites

I have the same problem: This is the console log from when I attempted to start the world.

2013-09-23 18:13:40 [iNFO] [Minecraft-Server] Stopping server

2013-09-23 18:13:40 [iNFO] [Minecraft-Server] Saving players

2013-09-23 18:13:40 [iNFO] [Minecraft-Server] Saving worlds

2013-09-23 18:13:40 [iNFO] [Minecraft-Server] Saving chunks for level 'Techsiting Adventures'/Overworld

2013-09-23 18:13:40 [iNFO] [sTDERR] java.lang.NullPointerException

2013-09-23 18:13:40 [iNFO] [sTDERR]at atomicscience.ZhuYao.worldSave(ZhuYao.java:731)

2013-09-23 18:13:40 [iNFO] [sTDERR]at net.minecraftforge.event.ASMEventHandler_21_ZhuYao_worldSave_Save.invoke(.dynamic)

2013-09-23 18:13:40 [iNFO] [sTDERR]at net.minecraftforge.event.ASMEventHandler.invoke(ASMEventHandler.java:39)

2013-09-23 18:13:40 [iNFO] [sTDERR]at net.minecraftforge.event.EventBus.post(EventBus.java:108)

2013-09-23 18:13:40 [iNFO] [sTDERR]at net.minecraft.world.WorldServer.func_73044_a(WorldServer.java:907)

2013-09-23 18:13:40 [iNFO] [sTDERR]at net.minecraft.server.MinecraftServer.func_71267_a(MinecraftServer.java:346)

2013-09-23 18:13:40 [iNFO] [sTDERR]at net.minecraft.server.MinecraftServer.func_71260_j(MinecraftServer.java:379)

2013-09-23 18:13:40 [iNFO] [sTDERR]at net.minecraft.server.integrated.IntegratedServer.func_71260_j(IntegratedServer.java:240)

2013-09-23 18:13:40 [iNFO] [sTDERR]at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:523)

2013-09-23 18:13:40 [iNFO] [sTDERR]at net.minecraft.server.ThreadMinecraftServer.run(SourceFile:573)

2013-09-23 18:13:40 [iNFO] [Galacticraft] Unregistered Dimension: -28

2013-09-23 18:13:40 [iNFO] [ForgeModLoader] The state engine was in incorrect state ERRORED and forced into state SERVER_STOPPED. Errors may have been discarded.

2013-09-23 18:13:40 [iNFO] [ForgeModLoader] The state engine was in incorrect state ERRORED and forced into state AVAILABLE. Errors may have been discarded.

Link to comment
Share on other sites

I actually just finished fixing the same problem. The statement about Galacticraft isn't relevant as I was having the same problem with and without Galacticraft installed, plus that statement occurs normally when I review logs from when the server was working.

I ended up having a multitude of issues.

1/ The overworld save was corrupted

2/ My latest backup of the overworld was corrupted (1 week old at this point and made by ForgeEssentialsServer)

Re-installing Java didn't work. Deleting all traces of tekkit and downloading a fresh, unmodified server also wouldn't start.

I ended up having to re-install the entire server, OS and everything. No big deal for me as the machine was dedicated to just Tekkit.

Not sure how much this helps you as I was recovering from a power issue while the server was running that I suspect was the culprit.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...