Jump to content

Help Test Tekkit 1.2.5c (1.6.4, FINALLY!)


Skuli
 Share

Recommended Posts

  • Replies 423
  • Created
  • Last Reply

Top Posters In This Topic

Sounds nice... I think we should now work on compatibility with Tekkit 1.1.10 maps =)

There are just some item IDs to fix... and some things to rebuild on 1.1.10 maps in my oppinion.

your old would would mostly work. problem is stuff like aluminium would be spawned in chunks that have been created. and some items have had their id changed. i think time would be better spent getting this release stable on a new map over more time unstable on 1.1.10 maps

Link to comment
Share on other sites

Duplication bug. Putting coal in a stirling engines, and beaking it seems to give twice the amount u put it. Have tried with full stacks, not sure if it works with all numbers.

So turns out u can dupe any items, any dmg, any number, any mob, anthing basicly, by doing this.

after 1.2.1 update, i can no longer breed animals manually, but the MFR breeder still works.

This is SMP. ssp works.

Link to comment
Share on other sites

your old would would mostly work. problem is stuff like aluminium would be spawned in chunks that have been created. and some items have had their id changed. i think time would be better spent getting this release stable on a new map over more time unstable on 1.1.10 maps

No problem... just fixing the Modular Powersuits IDs (cause the mod generated a new config file) and rebuild the rest (mostly Redstone Power Conduits and the Energy Cells)... and a 1.2.2 world would almost work as a a 1.1.10 world... just with all the nice new stuff =)

Will try my best tonight:

Better rebuild some items then starting a new world :D (in my oppinion - cause rebuilding is MINECRAFT STYLE :D yiiiha - new projects: fixing old projects :D)

Link to comment
Share on other sites

Upgraded to 1.2.1 and server didn’t start. Found out that if I in the World folder deleted DimensionalDoors catalog and 2 DimensionalDoors files in the rot folder and Loaded the world as standalone in tekkit launcher and answered yes to mods that wehre missing. Then copied the world folder to the server and it loaded and I could connect. But 2 big chunks where many off my buildings where, didn’t load it was replaced by dirt and stone. Open my world in old server 1.1 and noticed that the chunks missing in 1.2.1 all contained galacticraft stuff. So I deleted all parachest, nasa workbench and fuel loaders. Then all off my world loaded in 1.2.1, even my moon base containing same galacticraft items loaded correctly J

Only problem now is power my old magmatic engine setup doesn’t work because magmatic engines not exist anymore. And kinesis pipe doesn’t connect to my redstone energy cells anymore.

Link to comment
Share on other sites

Not sure if anyone else has had an issue with MPS recipes not being in the game. But i wanted to share a fix we found for this. The items show in NEI no problem but have no recipes attached to them. Doing some further digging i found there was no recipe file in the tekkitmain\config\machinemuse\recipes directory. We were able to download the Thermal expansions .recipes file from http://build.technicpack.net/job/ModularPowersuits/ and place it in this folder on both the client and the server and everything for MPS now has a recipe and is craftable.

Also has anyone noticed EE3 does not seem to have any recipes? Im dying without my chiseled stone bricks =D

Link to comment
Share on other sites

Hi!

Thanks for all the work on updating Tekkit.

Id like to make a replacement suggestion, can you replace the trade booth with this: http://www.minecraftforum.net/topic/1747810-164smpforge-vending-block/

It such an elegant solution IMO.

Also, I'm sure you know NEI has all micro blocks listed, I think we would all prefer is they were hidden like before.

A Few other thoughts. We have so much technology and so many weapons, as you have even added more. But really, nothing to go fight. Also, an elevator mod would be welcome, as well for me, I would love to see this boat mod added: http://www.minecraftforum.net/topic/1857899-164-152forge-archimedes-ships-v14-passenger-seats/

Thanks for reading.

Link to comment
Share on other sites

Had a few crashed on SMP, gave this crashreport.

---- Minecraft Crash Report ----

// I'm sorry, Dave.

Time: 14/01/14 20:48

Description: Exception in server tick loop

java.lang.NoSuchMethodError: powercrystals.minefactoryreloaded.api.IDeepStorageUnit.setStoredItemType(III)V

at appeng.proxy.helpers.MFRDSU.addItems(MFRDSU.java:108)

at appeng.me.MEInventoryHandler.addItems(MEInventoryHandler.java:193)

at appeng.me.MEInventoryHandlerWrapper.addItems(MEInventoryHandlerWrapper.java:80)

at appeng.me.tile.TileStorageBus$AvailableItemsBuffer.addItems(TileStorageBus.java:126)

at appeng.me.MEInventoryArray.addItems(MEInventoryArray.java:347)

at appeng.me.MEInventoryNetwork.addItems(MEInventoryNetwork.java:79)

at appeng.slot.SlotME.addToInv(SlotME.java:129)

at appeng.gui.AppEngContainer.func_75144_a(AppEngContainer.java:438)

at appeng.gui.AppEngContainer.handleSlotMEPacket(AppEngContainer.java:259)

at appeng.common.network.packets.PacketClickSlotME.serverPacketData(PacketClickSlotME.java:42)

at appeng.common.network.AppEngServerPacketHandler.onPacketData(AppEngServerPacketHandler.java:83)

at cpw.mods.fml.common.network.NetworkRegistry.handlePacket(NetworkRegistry.java:270)

at cpw.mods.fml.common.network.NetworkRegistry.handleCustomPacket(NetworkRegistry.java:259)

at cpw.mods.fml.common.network.FMLNetworkHandler.handlePacket250Packet(FMLNetworkHandler.java:85)

at net.minecraft.network.NetServerHandler.func_72501_a(NetServerHandler.java:2463)

at net.minecraft.network.packet.Packet250CustomPayload.func_73279_a(Packet250CustomPayload.java:70)

at net.minecraft.network.TcpConnection.func_74428_b(TcpConnection.java:470)

at net.minecraft.network.NetServerHandler.func_72570_d(NetServerHandler.java:233)

at net.minecraft.network.NetworkListenThread.func_71747_b(NetworkListenThread.java:54)

at net.minecraft.server.dedicated.DedicatedServerListenThread.func_71747_b(DedicatedServerListenThread.java:34)

at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:914)

at net.minecraft.server.dedicated.DedicatedServer.func_71190_q(DedicatedServer.java:330)

at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:781)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:663)

at net.minecraft.server.ThreadMinecraftServer.run(ThreadMinecraftServer.java:16)

A detailed walkthrough of the error, its code path and all known details is as follows:

---------------------------------------------------------------------------------------

Not sure what caused it, but it happed 3 times in a short period, and now seems to have vanished again.

Link to comment
Share on other sites

Uranium generation is not quite working right yet. A look through the config files shows that the cofh core world gen config has the wrong block id for the uranium ore. Atomic science uranium might not have a forge ore dictionary entry so this would cause no uranium to be generated. Either the uranium block id should match in both the cofh world gen config and the atomic science config or just enable the ore in the atomic science config and use that for generating uranium.

This has been a problem in the last 6 releases of tekkit(space) so it makes me believe that atomic science does not use the forge ore dictionary, thus the cofh custom ore generator can not find the correct ore consistantly...

Link to comment
Share on other sites

Bug in SMP. Having DSUs on a network that is empti cause random bugouts, removing all items from the ME accesterminal. Having to breake and place the controller, before u can see the items again.

When using a IO port to get items into a network, and having empty DSUs on that network will remove the IO port, any disk in it. Found that a random import bus got deleted to, at the same time.

Link to comment
Share on other sites

Version 1.2.2 will be going live shortly.

Fixed case issue with Tradebooth config file

Added:

Big Reactors v2.14alpha

Carpenter's Blocks 1.9.9

Updated:

Buildcraft 4.2.2

Logistics Pipes v0.7.4 build 98

One could copy the files from the client into your server's mods and config directories, removing the outdated buildcraft and logi pipes. Then if you're on linux rename TradeBoothMod.cfg to tradeboothmod.cfg and you've got a 1.2.2 server.

Link to comment
Share on other sites

Uranium generation is not quite working right yet. A look through the config files shows that the cofh core world gen config has the wrong block id for the uranium ore. Atomic science uranium might not have a forge ore dictionary entry so this would cause no uranium to be generated. Either the uranium block id should match in both the cofh world gen config and the atomic science config or just enable the ore in the atomic science config and use that for generating uranium.

This has been a problem in the last 6 releases of tekkit(space) so it makes me believe that atomic science does not use the forge ore dictionary, thus the cofh custom ore generator can not find the correct ore consistantly...

you need to go to the Atomic Science config and enable it

Link to comment
Share on other sites

Uranium generation is not quite working right yet. A look through the config files shows that the cofh core world gen config has the wrong block id for the uranium ore. Atomic science uranium might not have a forge ore dictionary entry so this would cause no uranium to be generated. Either the uranium block id should match in both the cofh world gen config and the atomic science config or just enable the ore in the atomic science config and use that for generating uranium.

This has been a problem in the last 6 releases of tekkit(space) so it makes me believe that atomic science does not use the forge ore dictionary, thus the cofh custom ore generator can not find the correct ore consistantly...

For Tekkit 1.1.10 the uranium ore generation just worked (for me) when enabling it in the Atomic Science config file AND changing the ID in the cofh core to 1402... and I had to do the same thing in Tekkit 1.2.1

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

Announcements




×
×
  • Create New...