• ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By Stonemaster5
      I don't know what happened to trigger it, but I was playing the B-team as a bat and my flight speed (displayed on the top-left of my screen) went down to 25% when it was previously at 100% for no reason. I flew very slow and it got annoying. I didn't know what to do so I just re-downloaded the modpack. It worked at first, but about 3 minutes in it started going down again and it was back to 25%. If anyone knows how to fix this, please help.
    • By BAG
      Yes, before anyone asks, java -version gives me this:
      So I'm using java 8. Technic launcher is still stuck on the loading screen. Please help!
    • By TheProBajao
      Hello, i have something wrong... I open up the inventory and i saw many mod glitches... Can someone to prove answer so that will fix the problem?
    • By ThatsSoAmber
      When I logged in my dino was full grown and i could fly it
      I clicked on it and when on it. Then I crashed to the lobby
      I tryed to go back on but it keep making me go to the lobby ;-;

      I've tryed: 
      Reistalling the modpack
      Deleting the pack and reinstalling it
      Having my friends try to kill the dino

      Please if there is any other way let me know! 
      I really wanna go back on to play with my friends
       
    • By LordFlowerpot
      Upon opening my technic launcher a couple of minutes ago, i noticed Tekkit Classic had deleted itself?! So I redownloaded it, my worlds still seemed to exist. But when I opened one I noticed half of my house ( which is built inside a hill) was dirt and stone again. So half of my house glitched away. Can anyone help me out please?