Jump to content

Unable to choose how much memory to allocate


Recommended Posts

Hi,

I have recently installed the attack of the b-team modpack on my laptop running windows 8 64 bits.

Noticing that I have crashes and difficulty running the modpack, I installed Java 64 bit, so I had more RAM allocation options in the launcher.

Now the problem is that even if I allocated 4G to AoTBT, every 10 seconds I have a lag spike, and I know it's because of the RAM because when I press F3, I see the 99% of the allocated RAM is being used, which is normal, because the RAM allocated is only around 400mb. Now this is very weird, since I have allocated 4G to the game... I cannot find a way to change the amount allocate, it won't let me change it :(

I have also messed with the Java Runtime Parameters, trying "-Xmx4G", to allocate 4G, but nothing works. I am absolutely certain I have installed the 64 bit version of Java...

 

What can I do? Why won't it let me change the allocated memory? I can also mention that I have Optifine installed, the Ultra C6 version.

 

Thank you for your help!

 

Link to post
Share on other sites
  • 2 weeks later...

It took me 6 hours but I found the fix! 

 

What you need to do is go to control panel, then system and security, then system. 

 

On the left hand side is a list of stuff; click advanced system settings in the new window, click "Environment Variables" on the bottom right.

 

In the new window, find the variable "_JAVA_OPTIONS", select it and click edit then change the value to whatever amount of RAM you like. For example -Xmx4096M for 4GB, or -Xmx2048 for 2GB

 

Done.

Link to post
Share on other sites
  • 3 weeks later...

If you don't have the issue with Java_options being set to override your java max memory allocation, then you don't have the issue with Java_options being set to override your java max memory allocation.

 

If that's not clear enough yet, then simply understand that you do not have the same issue.

 

Please post your logs up on the tracker following the guidelines - links that will help with that can be found in my sig.

Link to post
Share on other sites

You know how there's two sides of that window, a list at the top and a list at the bottom?  The one at the bottom is what they were calling "System" (it's the bit based in HKEY_CURRENT_MACHINE), the bit at the top is what they were calling "Local" (based on HKEY_CURRENT_USER instead).  If it's not on the page at all then that's actually good.

 

If you'd post logs on the tracker after following the tracker guidelines rather than pushing the point here which is at the >very least frowned upon then I'd actually be able to tell you for sure.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By FokinLaserSights
      Ok so i got 16gb of ram. I set the launchers ram limit to 8gb. When i start the game the ram usage (as the task manager shows) is 2-3gb. After time it just gets higher and higher that the ram usage gets to like 12gb. And that causes discord to stop itself just to get more memory for the game
      And so i dont get why this happens
    • By deathplayer43
      so my modpack has 5mb of memory allocated but it only uses like 700mb is there a way to fix this
    • By CyberNinja98
      So I have the launcher options set so it can use 6GB-s of ram but whenever I try to play it caps out at 455MBs. I need some technical help with this
    • By Lazerhack
      When trying to play any modpack on the technic launcher, i have the options to choose anywhere from 1gb ram to 15gb ram, being that i have 16gb ram installed on my pc. The problem i run into is that if i choose any more than 6gb allocated, the modpacks wont load at all. the technic launcher will close as if it is starting the modpack then will immediately open back up without attempting to load the modpack, giving the error "Not enough memory installed to support this modpack" in the console. When i open my system properties it shows that i do indeed have 16gb ram installed. I've already tried uninstalling and reinstalling technic, each of the modpacks, java RTE, and even attempted replacing my RAM twice with 16gb Corsair Vengeance Pro with no luck. Any help would be much appreciated.
    • By NanoByte
      I can't allocate more than 1 GB of RAM to my technic launcer, and before you comment you need to know that I have a 64bit Win10 and 64 bit Java 8 latest version. I also have plenty of memory available (16 more precise) and a pretty nice pc, my only problem is that I can't load any pack because of the Ram restriction 
×
×
  • Create New...