Jump to content

Technic only allocating 469MB


Recommended Posts

So here's the problem.
 
When I open the technic launcher I set the RAM allocation to 2GB and the pack loads (good so far)
 
When I am in a world however, it appears that the allocated memory is only 469MB and as it quickly fills up I get a big fps drop which then increases and drops again repeatedly even though it is set to 2GB and my laptop has 8GB which isnt used by anything else. I have included a screenshot of the allocated memory on the right and a screenshort showing the selection of 2GB allocated. My system specs are below. Thanks!
 
Processor: Intel Core i5 4200M (2.5Ghz)
Graphics: Geforce GT 740M (2GB dedicated graphics)
OS: Windows 8.1 64bit with 64bit Java

 

Screenshot1

Screenshot2

Edited by thekian
Link to post
Share on other sites

It took me 6 hours but I found the fix! 

 

What you need to do is go to control panel, then system and security, then system. 

 

On the left hand side is a list of stuff; click advanced system settings in the new window, click "Environment Variables" on the bottom right.

 

In the new window, find the variable "_JAVA_OPTIONS", select it and click edit then change the value to whatever amount of RAM you like. For example -Xmx4096M for 4GB, or -Xmx2048 for 2GB

 

Done.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By Conex_0
      I'm tired and frustrated with this launcher. First it wouldn't even launch properly and I had to fix that, then it won't even detect 64 bit. I litteraly reinstalled the launcher and java multiple times, I even installed java online and offline, offline first, then when the launcher was open java online, and selected java online, and it still said it already had that in the launcher settings, still 32-bit. I just want to play a modpack with my friends on their server.
    • By deathplayer43
      so my modpack has 5mb of memory allocated but it only uses like 700mb is there a way to fix this
    • By Lazerhack
      When trying to play any modpack on the technic launcher, i have the options to choose anywhere from 1gb ram to 15gb ram, being that i have 16gb ram installed on my pc. The problem i run into is that if i choose any more than 6gb allocated, the modpacks wont load at all. the technic launcher will close as if it is starting the modpack then will immediately open back up without attempting to load the modpack, giving the error "Not enough memory installed to support this modpack" in the console. When i open my system properties it shows that i do indeed have 16gb ram installed. I've already tried uninstalling and reinstalling technic, each of the modpacks, java RTE, and even attempted replacing my RAM twice with 16gb Corsair Vengeance Pro with no luck. Any help would be much appreciated.
    • By Danny84
      Hello,
      I'm having trouble getting Tekkit Legends to launch. When I click "play" in the launcher, it validates all the files, but then just goes back to the launcher as if nothing had happened. Here is the log. I have tried resetting the modpack multiple times, to no avail. I am able to launch vanilla through the technic launcher, but not tekkit legends.
      Any help is much appreciated!
    • By Kehlani
      The bug:
      Type of bug: Launcher bug. Reproduction rate: 10/10. Technic launcher keeps crashing on me when I'm in-game due to low memory. It also does lag a decent amount.
      Shader/Resource pack:
      I use shaders and an x32 pixel resource pack. I have the same setup in vanilla Minecraft and it works fine there. Technic will still crash even without a resource pack and shader.
      The issue in detail:
      I can't allocate more than 1gb of memory in the java settings in the technic launcher. I have tried to go to advanced system settings in system and checking out the environment variables. I cannot find "_JAVA_OPTIONS" in there. I can find "C:\Program Files (x86)\Common Files\Oracle\Java\javapath" in the system variables but that's it when it comes to java. I just downloaded technic launcher again after a long time (around 2 years). It used to work fine and I used to be able to allocate way more ram (I believe I used 4GB back then). Technic launcher is updated. My draw distance within minecraft is set to 8. 
      OS and Java version:
      I have an x64 bit operating system. I also have java downloaded for an x64 bit operating system. I have confirmed this by running vanilla Minecraft (not technic) and putting my view distance to far. According to this post  https://goo.gl/bpK4qw , if I had x34 bit java installed it would just give me an error message but that does not happen with me. I have also made sure to download the x64 bit version of java and I have updated it.
      ALL INFORMATION ABOUT COMPUTER SPECS + OS + LOGS + MC 
      System specs:  https://imgur.com/a/ryE71LV
      250gb SSD (60gb free space) + 2TB HDD (650gb free space) (I run technic from my HDD). 750W PSU. Windows and my graphics card driver is updated.
      LOG: I tried pasting the log into paste.ubuntu and pastebin but the log is too large and my browser can't handle it (the file size is 25MB). I pasted quite a bit of the end of the log. Sorry but that's the best I can do here and hopefully, it will provide some information of importance: https://paste.ubuntu.com/p/ZFGmBvcqh2/
×
×
  • Create New...