GenPage

Spigot/MCPC Server Bug

Recommended Posts


 
Credit to Kobata for noticing and informing me of the tweet.
 
This is an issue that affects Spigot which is built into MCPC-Plus
 
This has been fixed in Spigot: http://www.spigotmc.org/threads/arrayindexoutofboundsexception.14826/
 
Just waiting on MCPC now.

 

The error that crashes your server will be a 

java.lang.ArrayIndexOutOfBoundsException

 
I will be following this closely as many seem to be having issues with players joining your servers.

 

UPDATE:

 

Build #251 of MCPC-Plus is now recommended. 

 

http://ci.md-5.net/job/MCPC-Plus-164/251/

 

Download this new jar, replace, restart

Edited by GenPage
Update - Fixed

Share this post


Link to post
Share on other sites

Im using the version you recommended, but then it fixed it only giving me a "failed to bind port error", but after a few times of turning on and off my server, the java.lang.ArrayIndexOutOfBoundsException: 4100 

 

This all started when two mods i was running on my server had an id confilct, i changed one of the id's to 4188888, and it gave me the java.lang.ArrayIndexOutOfBoundsException: 4188888 error. So i changed it to 4100 thinking that it was too much or something, and it still didnt work, i tried your recommendation, but it came back, and now it wont stop occuring no matter how many times i restart my server. Anyway i can solve this? And is there a way i would be able to fix the "Failed to bind port error?" here is the java.lang.ArrayIndexOutOfBoundsException: 4100 error: http://pastebin.com/9yhaPcDt

 

Please help.

Share this post


Link to post
Share on other sites

Oh, my. This belongs in Server Op Swap Shop. The bind port error is because you have an orphaned Java process still running. Bring up your task manager and kill it. The Index Out Of Bounds is because the highest worldgen block ID you can use is 4095.

Share this post


Link to post
Share on other sites

Nevermind, i fixed it. But i need the mcpc+ 1.6.2 version (the 1.6.4 version is incompatible with turninator's95 moonquest modpack) but the webpage gives me a http 404 error when i go to it. Was the webpage moved? Or removed?

Share this post


Link to post
Share on other sites

The link is broken.

 

Too true. The MCPC+ project has been renamed to Cauldron and has a new dedicated website for both 1.6.4 and 1.7.2 versions:

 

Website: http://cauldron.minecraftforge.net/

 

Cauldron 1.6.4/1.7.21.7.10: http://files.minecraftforge.net/Cauldron/

 

MCPC+ 1.5.2: http://ci.md-5.net/job/MCPC-Plus-Legacy/

 

Please note that most versions now require the use of the installer in order to get the libraries and minecraft_server.jar as they no longer automatically get those on first startup.

Edited by plowmanplow

Share this post


Link to post
Share on other sites

Too true. The MCPC+ project has been renamed to Cauldron and has a new dedicated website for both 1.6.4 and 1.7.2 versions:

 

Website: http://cauldron.minecraftforge.net/

 

Cauldron 1.7.2: http://files.minecraftforge.net/Cauldron/

 

Cauldron 1.6.4: http://ci.md-5.net/job/CauldronLegacy/

 

Please note that both versions now require the use of the installer in order to get the libraries and minecraft_server.jar as they no longer automatically get those on first startup.

 dammit those links are 404s as well D: why does the minecraft community take away everything we need?

Share this post


Link to post
Share on other sites

 

Credit to Kobata for noticing and informing me of the tweet.

 

This is an issue that affects Spigot which is built into MCPC-Plus

 

This has been fixed in Spigot: http://www.spigotmc.org/threads/arrayindexoutofboundsexception.14826/

 

Just waiting on MCPC now.

 

The error that crashes your server will be a 

java.lang.ArrayIndexOutOfBoundsException

 

I will be following this closely as many seem to be having issues with players joining your servers.

 

UPDATE:

 

Build #251 of MCPC-Plus is now recommended. 

 

http://ci.md-5.net/job/MCPC-Plus-164/251/

 

Download this new jar, replace, restart

 

You might want to update to remove that link. Due to the DMCA that link is no longer valid and I think anyone using MCPC, or any other "bukkit" based server is in limbo for now. Hopefully the mod dev's will see our pain and spigot 1.8 will rock.

 

 Apparently they disabled access to the second link as well.

Edited by CharZinta

Share this post


Link to post
Share on other sites

You might want to update to remove that link. Due to the DMCA that link is no longer valid and I think anyone using MCPC, or any other "bukkit" based server is in limbo for now. Hopefully the mod dev's will see our pain and spigot 1.8 will rock.

 

 Apparently they disabled access to the second link as well.

 

The ONLY problem I have with spigot is no forge based Mods. So you get Plugin's or Mods. Cauldron was the perfect solution till the DMCA. Now we all wait in purgatory hoping something comes along.  I like some of the talk on Sponge but some comments are good and some concern me. I won't cross link in here but you can google it :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By stringybean
      I have recently updated to macOs Catalina, and i wanted to reinstall technic launcher to play with my friends. I already have java installed, but when i open the .jar file, it pops up on my dock and disappears twice. When i check the logs there is usually one log for each time i open it, along with nothing in the surrounding folders. I have tried to 'reinstall' technic multiple times.
      techniclauncher_2020-02-06.log
    • By Lord_Ahegao
      So, I'm trying to download Technic Launcher, everything went smoothly up until the point I actually downloaded it.. I went to the "Discover" tab only to see it completely blank, all of it was white except the top and bottom boarders of the launcher, my profile picture also won't load if that gives any more insight into my problem.

      Mind helping, anyone?
      https://justpaste.it/2awey
       
    • By KUHMM_DUMPSTER
      when i launch hexxit everything is just fine but when i enter a world after a few minutes the game crashes can someone help me out please?
    • By Archaon888
      I loaded up the game for the first time and I have no game sound. None in the menu or in the singleplayer world I created. The settings are set to 100% for sound and music, but I have neither. I have already tried restarting the game, to no effect.
    • By [email protected]
      Hello well my Technic launcher is infinitely in offline mode like this was out of the blue bugged and just don't think modpack anymore and not even low would be able to take it out? can't solve it