Sign in to follow this  
SirIkaros

Java Problems - Maximum Heap size

Recommended Posts

So I just wanted to set up a server to play with my friend some Attack of the B-Team but then this showed up in the launch.batch window:
 

 
C:UsersFabiDesktopNeuer Ordner (2)>java -Xmx3G -Xms2G -jar BTeam.jar nogui
Picked up _JAVA_OPTIONS: -Xincgc -Xms2048m -Xmx4096m
Invalid maximum heap size: -Xmx4096m
The specified size exceeds the maximum representable size.
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.
 
C:UsersFabiDesktopNeuer Ordner (2)>pause


ignore the german words in the path

Does someone know what is going on here ?
I already tried to add the PATH and CLASSPATH way to my enviromental system but that also hadn't worked.

Share this post


Link to post
Share on other sites

Post your issue on the tracker after reading the guidelines, check signature for these links.

 

Edit: Btw, quick note about this issue is that _JAVA_OPTIONS is a environment variable like PATH and CLASSPATH but is used to add default options to java being ran. this can be edited where you first went to look at adding PATH and CLASSPATH

Edited by Kalbintion

Share this post


Link to post
Share on other sites

It's most likely one of two things, you either have less than 4GB of RAM, or your default Java virtual machine isn't the 64-bit version.  If you have 64-bit windows, you can fix this easily by uninstalling all JAVA instances, then reinstalling 32-bit Java, and then 64-bit Java.  Doing this will allow IE11 to work properly with sites that use Java, and will make the last one you installed the system VM (64-bit.)

 

Alternatively, if you have 64-bit java, you can run it directly from "C:Program FilesJavajre#binjava.exe" replacing the # symbol with either 7 or 8 depending on which version you have installed, so you'd just replace the "java" part in the batch file with that entire string, including the quotes.

 

If you have less than 4GB of RAM, you need to edit the environment or check the Java control panel iin order to change the values you have entered.  The environment can be edited through the System control panel icon, then (With Windows 7) Advanced System Settings..., and there's a button called environment variables.  The VM options in the Java applet are under the "Java" tab, and then click on View...  The column is labeled Runtime Parameters (At least with Java 8.)

Share this post


Link to post
Share on other sites

This however isn't an issue with the mod pack, nor a bug, it's completely a client side configuration problem, and any information regarding the set up or installation of the mod pack should be in this forum, easy for people to access.  With as many problems with people not using the right Java version, or not having 64-bit Java installed, I'm surprised there isn't already a sticky tutorial to help that.

Share this post


Link to post
Share on other sites

Refer to the pinned topic at '?do=embed' frameborder='0' data-embedContent>> in regards to what I mean about that.

 

It specifically states to report any issues and bugs to the tracker, this includes an incorrect java version.

 

Also the reason this issue is reported so often is that most people do not know how to read the logs or know what version of java they have. It is often difficult to expect everyone to know this type of information.

Edited by Kalbintion

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Superskillz69
      I've played tekkit for a couple thousand hours now and never once encountered the battle I'm going through now. I haven't played in about 6 months or so.
      Some things to note:
      - I have both java 32 bit and 64 bit  runtime environments and I have experimented with a variety of different versions (many recommended on this forum)
      -I have 16Gb of RAM, a dedicated GPU and my nVidia driver is up to date. I have also rolled back to previous versions and encountered the same issues.
      -With any 64 bit java installed on the PC, Technic Launcher will not launch.
      -When I uninstall 64 bit java, launcher starts (in 32 bit) but obviously ram cannot be changed etc... However whilst running, I can install 64 bit java and then change ram settings.
      -Packs will download in this case however will not launch even when RAM is set below 6GB. I get a little java pop-up window saying "Hello".
      -https://paste.ubuntu.com/p/5MGrYNsP44/
       
      Please please please provide any assistance as I'm not ready to give up just yet!
    • By NanoByte
      I can't allocate more than 1 GB of RAM to my technic launcer, and before you comment you need to know that I have a 64bit Win10 and 64 bit Java 8 latest version. I also have plenty of memory available (16 more precise) and a pretty nice pc, my only problem is that I can't load any pack because of the Ram restriction 
    • By JokeInABox
      Hi All,
      when i install a modpack and click play, all it dose is close launcher then minecraft appears in the taskbar takes a few seconds then switches to the name of the mod im trying to play (Legands) then dose nothing, wont let me click on it and when i hover over its just a blank white box. 
      I have tried a Couple of different things to get it to work but to no avail.
      Reinstalled minecraft and launcher
      restart PC 
      Changed to 64bit java and set to 4GB ram 
      checked to see if my NVIDA was up to date 
       
      all help would be greatly appreciated.
      link to my logs https://pastebin.com/rNEDnvKb 
    • By xSypho
      Hello, I have recently found a glitch where technic launcher will not open. I run it, but it does not create a .technic folder or open. Minecraft works perfectly fine and I found out it was something to do with java. I have tried reinstalling java and restarting my computer, virus scans, reinstalling technic, but nothing works. I'm running Windows 7 64 bit if it helps. Thanks. (Ill attach the java errors) Here's the text information. The program mmc.exe version 6.1.7601.23892 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Action Center control panel.
       Process ID: 1e50
       Start Time: 01d47e0a62f4ddd3
       Termination Time: 22
       Application Path: C:\windows\system32\mmc.exe
       Report Id: b8dfe13d-e9fd-11e8-a761-4c72b9081cf7
      The picture of it is attached.

    • By bootleg_engineer
      Hi! Im trying to run the modpack craft & slash rpg, but it won't even get to the loading screen. it stops at:
      [B#395]  [19:14:45] [main/WARN] [FML]: The coremod codechicken.core.launch.CodeChickenCorePlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft
      I dont even get a crash log or anything. Ive tried all versions of java 8 and java 7, testing my ram and removing the only faulty stick in the system, reinstalling java, reinstalling the modpack, reinstalling the launcher, and even wiping the modpacks folder in appdata.
      I doubt this will help, but here's the log for the technic launcher console: https://pastebin.com/ex6qY5JA