Sign in to follow this  
maeries

[Ubuntu Linux] Morph Selector does not open

Recommended Posts

Hi there

 

I'm playing attack of the b-team on ubuntu, but I'm not able to open the morph selector. I think it's because I have a German keyboard where the key to open the selector would be the ß-key (two left of the backspace), but minecraft does not recognize this key. Also in vanilla minecraft I'm not able to bind a function to this key, because it just says NONE when I press it. I also can not bind the selector to any other key. For example when I play aotb-t in windows and I go to options -> controls -> morph and set it to any other key, it still opens when I press "ß".

 

Has someone an idea of how to fix this?

Share this post


Link to post
Share on other sites

You could try remapping the keys using xmodmap and xev, both should come preinstalled in ubuntu.

 

xev is used to display info about pressed keys, xmodmap is used to remap them.

 

So for example the key information for [ and ] (the keys used to scroll through the morph menu)

On my keyboard is:

KeyRelease event, serial 37, synthetic NO, window 0x3600001,
    root 0x80, subw 0x0, time 143727145, (-201,75), root:(393,391),
    state 0x0, keycode 34 (keysym 0x5b, bracketleft), same_screen YES,
    XLookupString gives 1 bytes: (5b) "["
    XFilterEvent returns: False

KeyPress event, serial 37, synthetic NO, window 0x3600001,
    root 0x80, subw 0x0, time 143727261, (-201,75), root:(393,391),
    state 0x0, keycode 35 (keysym 0x5d, bracketright), same_screen YES,
    XLookupString gives 1 bytes: (5d) "]"
    XmbLookupString gives 1 bytes: (5d) "]"
    XFilterEvent returns: False

What you would need to do is run xev from the terminal then press your 'ß' key, take note of the keycode.

Then you can remap it using xmodmap (substitute 20 for the keycode of your 'ß' key)

xmodmap -e "keycode 20 = bracketleft"

This will only work for the current session, so if you reboot you will lose these changes.

To make it work across reboots you need to export the changes to a file using:

xmodmap -pke >~/.xmodmap

Then to load your remaps at boot add the following line to the end of ~/.bashrc

xmodmap .xmodmap
Edited by Kr0nZ

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By NebelC0meback
      Hello people of the Technic community, I've had this problem for around 3 weeks now, and after countless hours of research i couldn't get it to work.
      I've got the following problem:
      I've been using Ubuntu (PoPOS) for around 2 months now, and i got really familiar with it. I got minecraft from the repositories no problem whatsoever. But as i wanted to play with mods, My old friend Technic Launcher came to my mind again, so i tried to install it and play some modpacks.
      Problem:
      I've installed the correct java version (OpenJDK 8 ) and put the techniclauncher.jar as an executable. Now when i run the launcher, the installation screen pops up, everything normal. Now when i install it as a portable or just normally, it creates the directory and the installer dissapears. Everything ok until now: When i try to launch Technic again, it just crashes. The java process is running, but starts dissapearing. So i tried again with oracle Java 11. Same problem. It just crashes. When i launch it over Terminal, it gives me this:
       
      [email protected]:/home/muenzlpsaveyourinternet# java -jar '/home/directory/TechnicLauncher.jar' '/home/directory/TechnicLauncher.jar'
      Settings for exe: /home/directory/TechnicLauncher.jar
      Portable settings dir: /home/directory/technic
      Setting up logging
      And nothing else happens, the terminal doesnt continue launching, same with launching without terminal.Nothing opens , just the process i can see in my system manager
      I tried and tried, i uninstalled the runtimes, 8 and 11, tried and tried but nothing worked. I found no answer, now after 2 weeks of trying, I decided to post this here to get some answers from nice people who like to help in the community.
      If you like to help me, just post solutions or suggestions in the section down, please stay simple with ubuntu stuff since i am really new to linux and just getting started. Thanks for any response.
      (replaced my install directory with directory because its pretty much useless for help and might confuse people)
       
    • By MajorHeartAttack
      Just made a new Modpack called Heartattack, and wanted to advertise it, because it has mods like Galacticaft, Morph, SpeedsterHeroes, Nukes, Everything! Also the main reason would be if this Modpack gets support, I would open up a Public server, so I would really be looking forward to that with your support! Line: https://www.technicpack.net/profile/4864249/modpacks
    • By Caminon
      Whenever I try to run the sh in the server folder in the terminal, this happens:
      A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException
              at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
              at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
              at java.base/java.lang.reflect.Method.invoke(Method.java:564)
              at cpw.mods.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:48)
              at cpw.mods.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:17)
      Caused by: java.lang.ClassCastException: java.base/jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to java.base/java.net.URLClassLoader
              at net.minecraft.launchwrapper.Launch.<init>(Launch.java:33)
              at net.minecraft.launchwrapper.Launch.main(Launch.java:27)
              ... 6 more

      I'm running on Debian, just installed java fresh on this computer. I can't seem to figure out why it won't work.
    • By elvis8900
      I'm trying to run the Technic Launcher on mint linux 18.2. I can see the launcher. I just can't adjust the launcher window to access any mod packs.