Sign in to follow this  
cormor

Server crash need help

Recommended Posts

can someone please help me to find what is causing the server to crash

 

 

report log

---- Minecraft Crash Report ----
// Quite honestly, I wouldn't worry myself about that.

Time: 5/23/14 9:02 PM
Description: Ticking entity

java.lang.ClassCastException: tconstruct.blocks.logic.CastingTableLogic cannot be cast to tconstruct.blocks.logic.FaucetLogic
 at tconstruct.blocks.SearedBlock.func_71872_e(SearedBlock.java:301)
 at net.minecraft.block.Block.func_71871_a(Block.java:574)
 at net.minecraft.world.World.func_72945_a(World.java:2168)
 at net.minecraft.entity.Entity.func_70091_d(Entity.java:886)
 at net.minecraft.entity.item.EntityItem.func_70071_h_(EntityItem.java:134)
 at net.minecraft.world.World.func_72866_a(World.java:2944)
 at net.minecraft.world.WorldServer.func_72866_a(WorldServer.java:1006)
 at net.minecraft.world.World.func_72870_g(World.java:2890)
 at net.minecraft.world.World.func_72939_s(World.java:2704)
 at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:883)
 at net.minecraft.server.dedicated.DedicatedServer.func_71190_q(DedicatedServer.java:330)
 at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:777)
 at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:659)
 at net.minecraft.server.ThreadMinecraftServer.run(ThreadMinecraftServer.java:16)


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- Head --
Stacktrace:
 at tconstruct.blocks.SearedBlock.func_71872_e(SearedBlock.java:301)
 at net.minecraft.block.Block.func_71871_a(Block.java:574)
 at net.minecraft.world.World.func_72945_a(World.java:2168)
 at net.minecraft.entity.Entity.func_70091_d(Entity.java:886)
 at net.minecraft.entity.item.EntityItem.func_70071_h_(EntityItem.java:134)
 at net.minecraft.world.World.func_72866_a(World.java:2944)
 at net.minecraft.world.WorldServer.func_72866_a(WorldServer.java:1006)
 at net.minecraft.world.World.func_72870_g(World.java:2890)

-- Entity being ticked --
Details:
 Entity Type: Item (net.minecraft.entity.item.EntityItem)
 Entity ID: 7800
 Entity Name: item.SearedBlock.Faucet
 Entity's Exact location: -2403.85, 78.56, -1268.77
 Entity's Block location: World: (-2404,78,-1269), Chunk: (at 12,4,11 in -151,-80; contains blocks -2416,0,-1280 to -2401,255,-1265), Region: (-5,-3; contains chunks -160,-96 to -129,-65, blocks -2560,0,-1536 to -2049,255,-1025)
 Entity's Momentum: -0.07, -0.28, -0.01
Stacktrace:
 at net.minecraft.world.World.func_72939_s(World.java:2704)

-- Affected level --
Details:edblo
 Level name: world
 All players: 2 total; [GCCorePlayerMP['HELLMAN81'/167, l='world', x=1553.78, y=78.00, z=-836.65](HELLMAN81 at 1553.7810087147896,78.0,-836.6515110706749), GCCorePlayerMP['sckeetmore'/7799, l='world', x=-2402.78, y=77.00, z=-1269.60](sckeetmore at -2402.7837229533347,77.0,-1269.604032098894)]
 Chunk stats: ServerChunkCache: 613 Drop: 0
 Level seed: -2586697669944867809
 Level generator: ID 00 - default, ver 1. Features enabled: true
 Level generator options:
 Level spawn location: World: (156,64,256), Chunk: (at 12,4,0 in 9,16; contains blocks 144,0,256 to 159,255,271), Region: (0,0; contains chunks 0,0 to 31,31, blocks 0,0,0 to 511,255,511)
 Level time: 7642806 game time, 7768392 day time
 Level dimension: 0
 Level storage version: 0x04ABD - Anvil
 Level weather: Rain time: 88220 (now: false), thunder time: 4909 (now: true)
 Level game mode: Game mode: survival (ID 0). Hardcore: false. Cheats: false
Stacktrace:
 at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:883)
 at net.minecraft.server.dedicated.DedicatedServer.func_71190_q(DedicatedServer.java:330)
 at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:777)
 at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:659)
 at net.minecraft.server.ThreadMinecraftServer.run(ThreadMinecraftServer.java:16)

-- System Details --
Details:
 Minecraft Version: 1.6.4
 Operating System: Linux (amd64) version 2.6.32-431.11.2.el6.x86_64
 Java Version: 1.7.0_55, Oracle Corporation
 Java VM Version: OpenJDK 64-Bit Server VM (mixed mode), Oracle Corporation
 Memory: 147001928 bytes (140 MB) / 634613760 bytes (605 MB) up to 2075918336 bytes (1979 MB)
 JVM Flags: 6 total; -Xms32M -Xmx2048M -XX:+UseParNewGC -XX:MinHeapFreeRatio=5 -XX:MaxHeapFreeRatio=10 -XX:MaxPermSize=256M
 AABB Pool Size: 1518 (85008 bytes; 0 MB) allocated, 1296 (72576 bytes; 0 MB) used
 Suspicious classes: FML and Forge are installed
 IntCache: cache: 0, tcache: 0, allocated: 1, tallocated: 63
 CraftBukkit Information:
   Running: MCPC+ version git-MCPC-Plus-jenkins-MCPC-Plus-164-251 (MC: 1.6.4) (Implementing API version 1.6.4-R2.1-SNAPSHOT) true
   Plugins: { WorldEdit v5.6.2 com.sk89q.worldedit.bukkit.WorldEditPlugin [],}
   Warnings: DEFAULT
   Threads: { RUNNABLE Thread-20: [java.net.PlainSocketImpl.socketAccept(Native Method), java.net.AbstractPlainSocketImpl.accept(AbstractPlainSocketImpl.java:398), java.net.ServerSocket.implAccept(ServerSocket.java:530), java.net.ServerSocket.accept(ServerSocket.java:498), net.minecraft.network.rcon.RConThreadMain.run(RConThreadMain.java:97), java.lang.Thread.run(Thread.java:744)], RUNNABLE DestroyJavaVM: [], RUNNABLE Connection #375 read thread: [java.net.SocketInputStream.socketRead0(Native Method), java.net.SocketInputStream.read(SocketInputStream.java:152), java.net.SocketInputStream.read(SocketInputStream.java:122), java.io.FilterInputStream.read(FilterInputStream.java:133), org.bouncycastle.crypto.io.CipherInputStream.nextChunk(Unknown Source), org.bouncycastle.crypto.io.CipherInputStream.read(Unknown Source), java.io.DataInputStream.readUnsignedByte(DataInputStream.java:288), net.minecraft.network.packet.Packet.func_73272_a(Packet.java:159), net.minecraft.network.TcpConnection.func_74447_i(TcpConnection.java:327), net.minecraft.network.TcpConnection.func_74450_c(TcpConnection.java:556), net.minecraft.network.TcpReaderThread.run(TcpReaderThread.java:23)], TIMED_WAITING Connection #7 write thread: [java.lang.Thread.sleep(Native Method), net.minecraft.network.TcpWriterThread.run(TcpWriterThread.java:49)], WAITING Thread-1: [sun.misc.Unsafe.park(Native Method), java.util.concurrent.locks.LockSupport.park(LockSupport.java:186), java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.await(AbstractQueuedSynchronizer.java:2043), java.util.concurrent.LinkedBlockingQueue.take(LinkedBlockingQueue.java:442), cpw.mods.fml.relauncher.FMLRelaunchLog$ConsoleLogThread.run(FMLRelaunchLog.java:83), java.lang.Thread.run(Thread.java:744)], RUNNABLE Listen thread: [java.net.PlainSocketImpl.socketAccept(Native Method), java.net.AbstractPlainSocketImpl.accept(AbstractPlainSocketImpl.java:398), java.net.ServerSocket.implAccept(ServerSocket.java:530), java.net.ServerSocket.accept(ServerSocket.java:498), net.minecraft.server.ServerListenThread.run(ServerListenThread.java:82)], TIMED_WAITING Keep-Alive-Timer: [java.lang.Thread.sleep(Native Method), sun.net.www.http.KeepAliveCache.run(KeepAliveCache.java:172), java.lang.Thread.run(Thread.java:744)], RUNNABLE Server thread: [java.lang.Thread.dumpThreads(Native Method), java.lang.Thread.getAllStackTraces(Thread.java:1639), org.bukkit.craftbukkit.v1_6_R3.CraftCrashReport.call(CraftCrashReport.java:27), net.minecraft.crash.CrashReportCategory.func_71500_a(CrashReportCategory.java:106), net.minecraft.crash.CrashReport.func_71504_g(CrashReport.java:58), net.minecraft.crash.CrashReport.<init>(CrashReport.java:40), net.minecraft.crash.CrashReport.func_85055_a(CrashReport.java:312), net.minecraft.world.World.func_72939_s(World.java:2709), net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:883), net.minecraft.server.dedicated.DedicatedServer.func_71190_q(DedicatedServer.java:330), net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:777), net.minecraft.server.MinecraftServer.run..

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Emberss
      I ran a small server for me and my friends on an old laptop so I can keep it running all the time. My laptop started acting funny so I flashed it with DBAN and reinstalled windows. And now I get this Log.txt every time I attempt to launch it. Anybody know how to fix?
      I've tried downloading another server for Tekkit classic, but I get the same Log.txt. 
      Log:
      D:\Server>java -Xms512M -Xmx1024M -jar Tekkit.jar nogui pause
      182 recipes
      27 achievements
      18:22:55 [INFO] Starting minecraft server version 1.2.5
      18:22:55 [INFO] Attempting early MinecraftForge initialization
      18:22:55 [INFO] Completed early MinecraftForge initialization
      18:22:55 [INFO] Forge Mod Loader version 2.2.91.173 for Minecraft 1.2.5 loading
      18:22:55 [SEVERE] Unable to process our input to locate the minecraft code
      18:22:55 [SEVERE] cpw.mods.fml.common.LoaderException
      18:22:55 [SEVERE]       at cpw.mods.fml.common.ModClassLoader.getParentSources(ModClassLoader.java:77)
      18:22:55 [SEVERE]       at cpw.mods.fml.common.Loader.load(Loader.java:374)
      18:22:55 [SEVERE]       at cpw.mods.fml.common.Loader.loadMods(Loader.java:606)
      18:22:55 [SEVERE]       at cpw.mods.fml.server.FMLBukkitHandler.onPreLoad(FMLBukkitHandler.java:134)
      18:22:55 [SEVERE]       at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:135)
      18:22:55 [SEVERE]       at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:438)
      18:22:55 [SEVERE]       at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
      18:22:55 [SEVERE] Unexpected exception
      cpw.mods.fml.common.LoaderException
              at cpw.mods.fml.common.ModClassLoader.getParentSources(ModClassLoader.java:77)
              at cpw.mods.fml.common.Loader.load(Loader.java:374)
              at cpw.mods.fml.common.Loader.loadMods(Loader.java:606)
              at cpw.mods.fml.server.FMLBukkitHandler.onPreLoad(FMLBukkitHandler.java:134)
              at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:135)
              at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:438)
              at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
      >
       
    • By jonohorry
      My tekkit classic server keeps crashing i attached the crash reports any help would be greatly appriciated! sorry if this isnt in the right category
      crash-2018-02-20_20.25.56-server.txt
      crash-2018-02-20_20.27.28-server.txt
    • By TheOrangeGamingFTW
      Api Link: http://api.technicpack.net/modpack/theoranges-modpack
    • By jack dye
      I had java 8 thought it might have caused it so uninstalled it and installed 7 didnt make a difference.
      This is what it comes up with in the server cmd. 
      [SEVERE] Exception in thread "Thread-9"
      22:15:24 [SEVERE] com.google.gson.JsonSyntaxException: java.lang.IllegalStateException: Expected BEGIN_OBJECT but was STRING at line 1 column 7
      22:15:24 [SEVERE]       at com.google.gson.internal.bind.ReflectiveTypeAdapterFactory$Adapter.read(ReflectiveTypeAdapterFactory.java:180)
      22:15:24 [SEVERE]       at com.google.gson.Gson.fromJson(Gson.java:755)
      22:15:24 [SEVERE]       at com.google.gson.Gson.fromJson(Gson.java:694)
      22:15:24 [SEVERE]       at org.bukkit.craftbukkit.updater.BukkitDLUpdaterService.fetchArtifact(BukkitDLUpdaterService.java:44)
      22:15:24 [SEVERE]       at org.bukkit.craftbukkit.updater.BukkitDLUpdaterService.getArtifact(BukkitDLUpdaterService.java:27)
      22:15:24 [SEVERE]       at org.bukkit.craftbukkit.updater.AutoUpdater$1.run(AutoUpdater.java:77)
      22:15:24 [SEVERE] Caused by: java.lang.IllegalStateException: Expected BEGIN_OBJECT but was STRING at line 1 column 7
      22:15:24 [SEVERE]       at com.google.gson.stream.JsonReader.expect(JsonReader.java:339)
      22:15:24 [SEVERE]       at com.google.gson.stream.JsonReader.beginObject(JsonReader.java:322)
      22:15:24 [SEVERE]       at com.google.gson.internal.bind.ReflectiveTypeAdapterFactory$Adapter.read(ReflectiveTypeAdapterFactory.java:168)
      22:15:24 [SEVERE]       ... 5 more
      please help thank you
    • By supreamcallum45
      hey, im an server dev of a tekkit legends server and since the update we have been having crashes and i would like some help, i have attached the crash reports and the console errors, and the plug ins and i hope you guys can help me fix it.
      crash-2015-12-08_01.21.57-server.txt