Jump to content

Tekkit memory Increase problem on mac


Recommended Posts

Hi, I tried increasing the memory of my server (hosted on home mac) but when I do it keeps giving the "Reached end of stream for /XXx.XXX.XXx.XxX etc" and wont appear online when on multiplayer menu but If i run it normally (loading the tekkit.jar)  it works fine the way I'm trying to do it is below.

#!/bin/bash
cd "$( dirname "$0" )"
java -Xmx1024M -Xms1024M -jar Tekkit.jar

I also did the chmod a+x  to give it permission, Any idea why it works with the default amount but not when I try to give it more?

 

Thanks.

Link to post
Share on other sites
  • Discord Moderator

Are you saying that it works when you just "run" the Tekkit.jar file or that the above script works as long as you don't have the starting/max memory arguments on the command line in the script?

 

If you just type "java -version" in a shell terminal what do you get as the result? How much memory is in your system?

Link to post
Share on other sites

Yeah if I just run Tekkit.jar it loads and works fine If I try to use a script no matter the memory size it wont allow me or anyone else to connect to the server it just says its down.

java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

I have 8GB of ram

Link to post
Share on other sites
  • Discord Moderator
  • Assuming you are running Technic's Tekkit (main) pack I would recommend setting the memory to no less than 1536M and preferably 2G.
  • You may have better luck using the latest Java 7 64bit JRE for your OS.
  • I don't run anything on a Mac, but this "may" be something firewall related as it is possible that it is treating the script-started service differently than if you just "run" the Tekkit.jar file. This is just educated speculation.
Link to post
Share on other sites

I was just helped with a similar problem, mine turned out to be an error with Mr. crayfish's furniture mod. Removing that mod from the server fixed the problem. If that's not it posting a crash report will help.

Alternative: I also have 8GB of RAM and I've found that allocating 4-6GB to the server makes it work best and you can still have other programs running in the background.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...