Jump to content
Sign in to follow this  
Cobalta

Trouble with my modpack

Recommended Posts

Hey!

I already posted on this forum to ask help for a custom modpack,but,since there were too much problems,I decided to 

go and make a new one,but,guess what?I'm having trouble with this one too x(!

I don't think the problems are the same so, can you please help me?

 

My modpack : http://www.technicpack.net/api/modpack/feed-the-steed

 

For now,the main problem is that once I click play on the tecnhnic pack launcher,the launcher disapears and reapears after a few seconds.

 

Help me please!

Share this post


Link to post
Share on other sites
  • You have included the entire client contents of the bin folder. The ONLY file that should be in there is modpack.jar.
  • You have files in the coremods folder. Forge/MC 1.6+ does not use the coremods folder in any way. All mods belong in or below the mods folder.
  • You have the Forge installer jar in the coremods folder. This file should be remove completely.
  • As I mentioned in the post the last time I tried to help you, you do not have Better Dungeons installed correctly. You need to follow the author's instructions. (open that zip and look inside).
  • Your CraftableSpawners mod looks like it is for Forge/MC 1.6.2. This might be a problem.
  • You have an ancient version of IndustrialCraft 2. If you intend to include IC2 you will want to look at this post: (check the versions and compatibility of ALL the other IC2 mods you have included as well)
  • As I mentioned in your previous thread. You MUST include a full set of configs with your modpack. These are generated in the config folder where you are testing the pack as you assemble it. You are testing it locally, right? Always, always include this entire folder with your pack.

Fix all of those and come back when you hit another snag.

Share this post


Link to post
Share on other sites

 

  • As I mentioned in your previous thread. You MUST include a full set of configs with your modpack. These are generated in the config folder where you are testing the pack as you assemble it. You are testing it locally, right? Always, always include this entire folder with your pack.

 

 

No,I don't test It,I don't know how to x(.I fixed every thing you said besides this so,how can I "test" my modpack?

Share this post


Link to post
Share on other sites

so,how can I "test" my modpack?

 

I would recommend using my BareBonesPack modpack. This will allow you to have a "clean" Forge install which can be started in the launcher on which you can build your modpack. Additional information on the BareBonespack is on the description page of the pack.

Share this post


Link to post
Share on other sites

 

Fix all of those and come back when you hit another snag.

 

Well,I think I've added everything,fixed everything but it keeps making the same error. (launcher disapears then reapears after a few seconds)

I bothered you three times already,would you care for a forth?

You know what they say : never three without four! (Wait,what?)

Share this post


Link to post
Share on other sites
  • You are including a version of Thaumic Tinkerer for Forge/MC 1.7.2. The last build of TT which works with 1.6.4 is this one: http://jenkins.nekokittygames.com:8080/job/Thaumic%20Tinkerer/207/
  • Something is jacked up with your version of Galacticraft and supporting mods. Get the latest version here and try again: http://ci.micdoodle8.com/job/Galacticraft/
  • You got the wrong version of Advanced Solar Panels from the IC2 forum post I referenced. You got 3.3.8 and you need 3.4.7.
  • You have a messed up or incorrect mod version for Falling Meteors Mod. Get the 2.11.2 version here: http://www.curse.com/mc-mods/minecraft/falling-meteors-mod#t1:other-downloads
  • There is something up with the Barrels mod in recent builds. Possibly related to Thaumcraft and the author's efforts to update to 1.7.2. My recommendation would be to switch to something like JABBA until this gets resolved (or permanently since JABBA seems like a more feature rich mod).
  • Your Immibis' mods don't match. Since Immibis Core and Microblocks are oddly named I will assume that this is due to you not getting them all directly from the author's download site. Don't do this. Always get them directly from the author, and always sync up versions of mods from the same author which use a common core.
  • The default generated configs have a number of block ID conflicts which will need to be resolved.
  • You have item id conflicts between: BetterFurnaces & BetterDungeons
  • After some (way too much) time I isolated that you have a very old version of DragonAPI which was including a version of the Thaumcraft API that was out of date with the version of Thaumcraft you included. Always always get matching/updated versions of your mods directly from the authors to prevent this.
  • You don't have a full set of config files in your modpack archive. This is "bad".

I think that is everything I had to do to get things working. My mind is a little melted after a couple hours of debugging. :) Give these a shot and see where it gets you. Keep in mind that the whole reason for using the BareBonesPack is so that you can find these things out yourself by examining the FML client logs.

Share this post


Link to post
Share on other sites

Hey,again and again me,I tried to fix a lot of problems on my modpack but there is one I tried to fix but it failed,I saw on the crash logs that it is linked to thaumcraft 4 but I can't find the answer..

Can you tell me what is wrong with it?

I know I have Id conflicts but I will fix that later,for now I'm focusing on thaumcraft 4.

 

Sorry for bothering you again ^^

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Verhunqert
      hi see i recently made a modpack and everytime i start is is says installing assets, does that, then just doesnt start, no minecraft nothing, please help, i already made the 0 of the dropbox into a 1 and stuff like that
       
      dropbox: https://www.dropbox.com/s/oulmzhezhfw976b/Minecolonies.zip?dl=0
      modpack: https://www.technicpack.net/modpack/modpack12-341.1703589
    • By IcarusUK
      Hey, so I've made a modpack for my gaming group and have followed all the steps closely that were provided on the guide. However, whenever I open the modpack on Technic it does not load forge, only vanilla minecraft. The forge version is: 14.23.5.2847 and works perfectly fine in the normal minecraft launcher (yes I used the universal version for the modpack and renamed it correctly). Furthermore all of the mods work and I'm able to connect to the server I host which also has the same version of forge which works there (and of course all of the mods). When I check the .technic folder and go to the pack folder everything appears to have installed correctly however forge does not load even though it's in the bin folder with minecraft.jar (this is automatically put there by technic). The modpack link is below, please can someone help me to get this to work...
      http://api.technicpack.net/modpack/resist-gaming
      The bin folder:

      This is the full contents of the modpack

      This is the config folder (it has 1 required customised file under CustomMainMenu - this works in the standard minecraft launcher):

      If you can help me with this I would really appreciate it.
       
      Mark
       
      (edit) here's the direct download of the pack... https://www.dropbox.com/s/kkfbn4gfahx8ul3/rg1.zip?dl=0
    • By AlexKoyomi
      When I click in install, it does something for a second and then just appear the options to "Delete modpack" and "install".
       
      https://pastebin.com/KpRY4efn
    • By PyroSweets
      My friends and I made a custom modpack with all our favorite mods in 1.12.2. I was having some issues with the modpack.jar that made it run vanilla and I fixed it, but now the modpack doesn't even show a java client or loading screen before crashing. I posted a day or two ago on reddit and was told to delete some iffy modpacks, but that only makes it run vanilla again. Any ideas why this is happening?
      Crash Log: http://dl.dropboxusercontent.com/s/wkv06mn3wna9hbv/techniclauncher_2020-05-31.log
      Modpack: http://dl.dropboxusercontent.com/s/ndyuw1g8t38xkde/POGWORK.zip
      Technic Page: https://www.technicpack.net/modpack/dillons-cult-pack.1697994
    • By NotXSco
      I've made my own modpack with the latest version of forge universal for 1.12.2. My process for making it was to put the 1.12.2 universal forge.jar in the bin folder, renamed it modpack. Next, I copied all of my 1.12.2 mods and my config files from .minecraft into their respective folders. Lastly, I archived the bin, config, and mods folder with winrar into a .zip file, put it on dropbox, and made the link shareable having dl=1 at the end. Everything works fine when I use the minecraft launcher using the client version of forge. 
×
×
  • Create New...