forntonio

Server crashes, but not client and can't identify problem.

Recommended Posts

I have made a modpack and am porting it to server but I get this crash. It says something about a mod missing, but I've compared the clients mod folder and the servers mod folder and I can't find any mod missing.

 

Help to identify (and fix it) is greatly appreciated!

 

Thanks in advance!

 

-The modpack is 1.6.4 as stated on the pastebin-

Share this post


Link to post
Share on other sites
  • Your Galacticraft version is absolutely ancient. I would highly recommend updating: http://ci.micdoodle8.com/job/Galacticraft/
  • Your IC2 version is out of date and has known problems. I recommend starting here if you plan to include IC2:
  • Actually, many of your mods are somewhat to extremely out of date. Might want to address that.

Disabling the following mods allowed me to start a server with your pack:

  • ArmorStatusHUD
  • CustomLANPort
  • DynamicLights

Share this post


Link to post
Share on other sites

 

  • Your Galacticraft version is absolutely ancient. I would highly recommend updating: http://ci.micdoodle8.com/job/Galacticraft/
  • Your IC2 version is out of date and has known problems. I recommend starting here if you plan to include IC2:
  • Actually, many of your mods are somewhat to extremely out of date. Might want to address that.

Disabling the following mods allowed me to start a server with your pack:

  • ArmorStatusHUD
  • CustomLANPort
  • DynamicLights

 

Thing is, no of those 3 mods are on the server :C, I will try updating mods.

Share this post


Link to post
Share on other sites

I didn't update any of them, I was just making a (strong) recommendation.

 

All I did was create the server and copy over your folders, then remove those three mods. Started just fine.

Oh cool, I will try that.

Share this post


Link to post
Share on other sites

I didn't update any of them, I was just making a (strong) recommendation.

 

All I did was create the server and copy over your folders, then remove those three mods. Started just fine.

Can you upload the server on dropbox or something, I can't get it to work, even by doin exactly what you said, I get the same error.

Share this post


Link to post
Share on other sites

I'm not going to go through all that. It's totally unnecessary. I re-downloaded your client pack and set the server up again. Since you have removed DynamicLights all you have to do is remove CustomLANPorts and ArmorStatusHUD and you are good to go.

 

What server are you using? What's failing? What does your crash report or FMLServer log look like?

Share this post


Link to post
Share on other sites

  minecraftforge-universal-1.6.4-9.11.1.953 and I made another with minecraftforge-universal-1.6.4-9.11.1.965-v164-pregradle , same problem.

Share this post


Link to post
Share on other sites

we'll need more recent logs to figure out what the issue is.  I can tell you that galacticraft will not run without micdoodlecore, as they are basically 2 parts of the same mod.  "it crashes" doesn't help me, or anyone else much in terms of figuring out what's wrong.

Share this post


Link to post
Share on other sites

Okey, it works without MrCrayfish Construction Mod and Micdoodle+Galacti, I will test when I get home, could it be that MicdoodleCore needs to be installed at the same time as GalactiCraft?

Also I updated Forge and a few mods.

Edited by forntonio

Share this post


Link to post
Share on other sites

galacticraft needs micdoodlecore to function.  micdoodlecore is a library that the galacticraft author made to help with his mod.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Underscore
      It was as simple as that. The game closed immediately after the world generated in the Shivaxi RLCraft modpack. The console says, "java.lang.OutOfMemoryError." I have no idea what is happening, I just want to play this modpack but nothing at all is working right anywhere. Your basic answers will probably not solve the issue.

    • By jasunthesungod
      Looking for new players to add to my server to build a community. The goal is to get YouTubers to bring life back to Tekkit Lite, and see impressive builds.
      comment or dm me, also jasunthesungod on Instagram
      jasonisaroach.com:25565
      157.230.211.143:25565
       
    • By ZakDank
      PLEASE NOTE:
      This pack is designed for one specific server which is why we provide no server files. Please do not attempt to replicate our server. Thank you.
       

      MODPACK LINK - http://www.technicpack.net/modpack/wild-west-frontier.185231
      API (copy and paste this into technic launcher);
      http://api.technicpack.net/modpack/wild-west-frontier
       
       
      Having Issues? Please look here: http://wildwest.retg.net/common-fixes/

      Our Official Discord
      Climb aboard the modpack that throws you back to the days of the ol' west. We aim to provide an authentic yet fun experience to satisfy the desires of any western loving person.






      Old Screenshots



       
      Here you will find custom content, including new guns and artwork, a item based economy with a separate land deed system for towns. This server is full PvP so gang together to survive bandits or become bandits yourselves.
      ~~~~~~~~~~~~~~~~~~~~~~~~~~

      Our Community
      We take a very relaxed stance with players and generally allow most things as long as they are not derogatory to any player or the server (i.e. Racism, Abuse, Hacks, Exploits) so feel free to make yourself at home without fear. Our community has been around for over 3 years now and we have accomplished a lot in that time and we hope to continue with our accomplishments.
      We really do hope you enjoy your stay with us, no matter what the length.
      For more info about us, please check our site wildwest.retg.net
       
      Standard community rules:
      1. No Hacking.
      2. No exploitation of bugs or glitches.
      3. No racism, religious speech or other idealism.
      4. Dont harass other players and community members.
      5. No spamming, advertising or excessive swearing/CAPS.
      6. Respect the staff - They are here for you.
      7. Do not abuse staff members, we are here to help and we try hard to keep a low ban rate.
      8. Have fun!

      Wild West Frontier specific rules:
      9. Dont use /sethome or /back in others claimed territory or to reengage in PVP.
      10. Please try to make your town a town, we dont like seeing underground bases.
      11. Have your town be "raid"able. Have entrances(doors/gates/ect) to your town/houses.
      Just so people have a "chance" of getting a jump on you, or you forgetting to close it.
      12. Dont make any lagmachines/ pointless contraptions.
      13. Destroying/blocking roads (or near 3 blocks of one) are not allowed, and is harshly punished.
      And remember: An Admins word is final!
       
    • By JragonGamer
      My modpack won't launch and crashes when I hit play.
      Here's the log: https://pastebin.com/Xg18gxSg
    • By Leafzy
      hello lately when i wanna play a modpack it crashes it happens like this i can download every modpack no problem but when i click on play it loads en at the end of loading it stops  and crashes the modpacks just wont open i tried many things but nothing worked can somebody me pls 


      log files