Jump to content

Recommended Posts

I've scoured the internet, looking for ways to make the link work for the techniclauncher-- I've tried dropbox (both copying the link after exiting the pop-up after the "share link" redirection as well as changing the www. to dl.  and appending "?dl=1" to the end) and copy.com (which doesn't seem to work either).  Now, I seem to be the only one that has this problem; these solutions seem to work for everybody except me, it seems.  I've tested the url and when it is entered in the browser, it leads directly to a download of the file.  Is it an error with the techniclauncher, a human error, or something beyond my control?  Any input would be appreciated, as this is a very frustrating subject.

Link to post
Share on other sites

I use dropbox but use a public folder. It allows me to copy URLs directly to the modpack without a download page. If you set up dropbox within the last two years or so, you won't have a public folder by default.

 

You can set up a public folder by following this guide. After that, any file you put in your public folder or in a sub folder within the folder can be directly linked by going to your public folder, right clicking the file you want, and selecting 'copy public link'. It'll stick a direct link to the file on your clipboard which you can then just paste into the path on the modpack editor page.

Edited by SinisterPixel
Link to post
Share on other sites

I use dropbox but use a public folder. It allows me to copy URLs directly to the modpack without a download page. If you set up dropbox within the last two years or so, you won't have a public folder by default.

 

You can set up a public folder by following this guide. After that, any file you put in your public folder or in a sub folder within the folder can be directly linked by going to your public folder, right clicking the file you want, and selecting 'copy public link'. It'll stick a direct link to the file on your clipboard which you can then just paste into the path on the modpack editor page.

I've tried that, and it leads to the page that states that if I want the public folder, i must upgrade to pro.  This is, at minimum, $99.  Is there some other way besides the link copying or adding ?dl=1 to the end of the link location?  All three methods have gotten me no farther, sadly...

Link to post
Share on other sites
  • 5 months later...

Hey, figured out the fix to make dropbox work thanks to this forum:

http://www.minecraftforum.net/forums/off-topic/computers-science-technology/195741-modpack-hosts-not-dropbox-or-google-drive

 

when you upload your modpack file to dropbox and attain the link by hitting share and (dont get put off by the email thing) click get link, it will copy the link to clipboard, sound familiar?

well heres the most important step

when you paste your link into the modpack file location box in technicpack, simply add this to the end of your link:

?dl=1

example:

https://www.dropbox.com/s/blahblah/Modpack.zip

becomes:

https://www.dropbox.com/s/blahblah/Modpack.zip?dl=1

amazing xD

also using something like webs.com to make free website, and upload the file like you would  a photo or something  you want on the site, then just use its direct link, works fine also.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By madscientist10
      I had tried adding 2 mods to my current modpack and made a new zip so I wouldn't mess with the working one.  It didn't work of course, so I used the old zip that was working to update the modpack back to its slighty older version.  Now that one doesn't work either, even thought I never messed with that particular zip file.  Here is the crash report:
       
      ---- Minecraft Crash Report ----
      WARNING: coremods are present:
        ForgelinPlugin (Forgelin-1.8.3.jar)
        Quark Plugin (Quark-r1.6-178.jar)
        CTMCorePlugin (CTM-MC1.12.2-1.0.1.30.jar)
        LittlePatchingLoader (LittleTiles_v1.5.0-pre199_53_mc1.12.2.jar)
        CreativePatchingLoader (CreativeCore_v1.10.9_mc1.12.2.jar)
      Contact their authors BEFORE contacting forge
      // Why did you do that?
      Time: 10/3/20 4:55 PM
      Description: Initializing game
      java.lang.NoClassDefFoundError: com/creativemd/opf/OPFrame$1
          at java.lang.Class.forName0(Native Method)
          at java.lang.Class.forName(Unknown Source)
          at net.minecraftforge.fml.common.FMLModContainer.constructMod(FMLModContainer.java:539)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
          at java.lang.reflect.Method.invoke(Unknown Source)
          at com.google.common.eventbus.Subscriber.invokeSubscriberMethod(Subscriber.java:91)
          at com.google.common.eventbus.Subscriber$SynchronizedSubscriber.invokeSubscriberMethod(Subscriber.java:150)
          at com.google.common.eventbus.Subscriber$1.run(Subscriber.java:76)
          at com.google.common.util.concurrent.MoreExecutors$DirectExecutor.execute(MoreExecutors.java:399)
          at com.google.common.eventbus.Subscriber.dispatchEvent(Subscriber.java:71)
          at com.google.common.eventbus.Dispatcher$PerThreadQueuedDispatcher.dispatch(Dispatcher.java:116)
          at com.google.common.eventbus.EventBus.post(EventBus.java:217)
          at net.minecraftforge.fml.common.LoadController.sendEventToModContainer(LoadController.java:219)
          at net.minecraftforge.fml.common.LoadController.propogateStateMessage(LoadController.java:197)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
          at java.lang.reflect.Method.invoke(Unknown Source)
          at com.google.common.eventbus.Subscriber.invokeSubscriberMethod(Subscriber.java:91)
          at com.google.common.eventbus.Subscriber$SynchronizedSubscriber.invokeSubscriberMethod(Subscriber.java:150)
          at com.google.common.eventbus.Subscriber$1.run(Subscriber.java:76)
          at com.google.common.util.concurrent.MoreExecutors$DirectExecutor.execute(MoreExecutors.java:399)
          at com.google.common.eventbus.Subscriber.dispatchEvent(Subscriber.java:71)
          at com.google.common.eventbus.Dispatcher$PerThreadQueuedDispatcher.dispatch(Dispatcher.java:116)
          at com.google.common.eventbus.EventBus.post(EventBus.java:217)
          at net.minecraftforge.fml.common.LoadController.distributeStateMessage(LoadController.java:136)
          at net.minecraftforge.fml.common.Loader.loadMods(Loader.java:595)
          at net.minecraftforge.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:232)
          at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:467)
          at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:378)
          at net.minecraft.client.main.Main.main(SourceFile:123)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
          at java.lang.reflect.Method.invoke(Unknown Source)
          at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
          at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
      Caused by: java.lang.ClassNotFoundException: com.creativemd.opf.OPFrame$1
          at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:191)
          at java.lang.ClassLoader.loadClass(Unknown Source)
          at java.lang.ClassLoader.loadClass(Unknown Source)
          ... 39 more
      Caused by: java.lang.NoClassDefFoundError: com/creativemd/littletiles/client/gui/handler/LittleGuiHandler
          at java.lang.ClassLoader.defineClass1(Native Method)
          at java.lang.ClassLoader.defineClass(Unknown Source)
          at java.security.SecureClassLoader.defineClass(Unknown Source)
          at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:182)
          ... 41 more
      Caused by: java.lang.ClassNotFoundException: com.creativemd.littletiles.client.gui.handler.LittleGuiHandler
          at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:101)
          at java.lang.ClassLoader.loadClass(Unknown Source)
          at java.lang.ClassLoader.loadClass(Unknown Source)
          ... 45 more

      A detailed walkthrough of the error, its code path and all known details is as follows:
      ---------------------------------------------------------------------------------------
      -- Head --
      Thread: Client thread
      Stacktrace:
          at java.lang.Class.forName0(Native Method)
          at java.lang.Class.forName(Unknown Source)
          at net.minecraftforge.fml.common.FMLModContainer.constructMod(FMLModContainer.java:539)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
          at java.lang.reflect.Method.invoke(Unknown Source)
          at com.google.common.eventbus.Subscriber.invokeSubscriberMethod(Subscriber.java:91)
          at com.google.common.eventbus.Subscriber$SynchronizedSubscriber.invokeSubscriberMethod(Subscriber.java:150)
          at com.google.common.eventbus.Subscriber$1.run(Subscriber.java:76)
          at com.google.common.util.concurrent.MoreExecutors$DirectExecutor.execute(MoreExecutors.java:399)
          at com.google.common.eventbus.Subscriber.dispatchEvent(Subscriber.java:71)
          at com.google.common.eventbus.Dispatcher$PerThreadQueuedDispatcher.dispatch(Dispatcher.java:116)
          at com.google.common.eventbus.EventBus.post(EventBus.java:217)
          at net.minecraftforge.fml.common.LoadController.sendEventToModContainer(LoadController.java:219)
          at net.minecraftforge.fml.common.LoadController.propogateStateMessage(LoadController.java:197)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
          at java.lang.reflect.Method.invoke(Unknown Source)
          at com.google.common.eventbus.Subscriber.invokeSubscriberMethod(Subscriber.java:91)
          at com.google.common.eventbus.Subscriber$SynchronizedSubscriber.invokeSubscriberMethod(Subscriber.java:150)
          at com.google.common.eventbus.Subscriber$1.run(Subscriber.java:76)
          at com.google.common.util.concurrent.MoreExecutors$DirectExecutor.execute(MoreExecutors.java:399)
          at com.google.common.eventbus.Subscriber.dispatchEvent(Subscriber.java:71)
          at com.google.common.eventbus.Dispatcher$PerThreadQueuedDispatcher.dispatch(Dispatcher.java:116)
          at com.google.common.eventbus.EventBus.post(EventBus.java:217)
          at net.minecraftforge.fml.common.LoadController.distributeStateMessage(LoadController.java:136)
          at net.minecraftforge.fml.common.Loader.loadMods(Loader.java:595)
          at net.minecraftforge.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:232)
          at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:467)
      -- Initialization --
      Details:
      Stacktrace:
          at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:378)
          at net.minecraft.client.main.Main.main(SourceFile:123)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
          at java.lang.reflect.Method.invoke(Unknown Source)
          at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
          at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
      -- System Details --
      Details:
          Minecraft Version: 1.12.2
          Operating System: Windows 10 (amd64) version 10.0
          Java Version: 1.8.0_261, Oracle Corporation
          Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
          Memory: 8088715248 bytes (7713 MB) / 8589934592 bytes (8192 MB) up to 8589934592 bytes (8192 MB)
          JVM Flags: 5 total; -Xms8192m -Xmx8192m -XX:+UseG1GC -XX:MaxGCPauseMillis=4 -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump
          IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
          FML: MCP 9.42 Powered by Forge 14.23.5.2847 25 mods loaded, 25 mods active
          States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
          | State | ID                | Version           | Source                                            | Signature |
          |:----- |:----------------- |:----------------- |:------------------------------------------------- |:--------- |
          | LC    | minecraft         | 1.12.2            | minecraft.jar                                     | None      |
          | LC    | mcp               | 9.42              | minecraft.jar                                     | None      |
          | LC    | FML               | 8.0.99.99         | modpack.jar                                       | None      |
          | LC    | forge             | 14.23.5.2847      | modpack.jar                                       | None      |
          | LC    | creativecoredummy | 1.0.0             | minecraft.jar                                     | None      |
          | LC    | littletilescore   | 1.0.0             | minecraft.jar                                     | None      |
          | LC    | alet              | 1.0               | A+Little+Extra+Tiles-1.0.7.jar                    | None      |
          | LC    | jei               | 4.15.0.291        | jei_1.12.2-4.15.0.291.jar                         | None      |
          | LC    | quark             | r1.6-178          | Quark-r1.6-178.jar                                | None      |
          | LC    | autoreglib        | 1.3-32            | AutoRegLib-1.3-32.jar                             | None      |
          | LC    | bibliocraft       | 2.4.5             | BiblioCraft[v2.4.5][MC1.12.2].jar                 | None      |
          | LC    | biomesoplenty     | 7.0.1.2439        | BiomesOPlenty-1.12.2-7.0.1.2439-universal.jar     | None      |
          | LC    | ctm               | MC1.12.2-1.0.1.30 | CTM-MC1.12.2-1.0.1.30.jar                         | None      |
          | LC    | chisel            | MC1.12.2-1.0.1.44 | Chisel-MC1.12.2-1.0.1.44.jar                      | None      |
          | LC    | chiselsandbits    | 14.33             | chiselsandbits-14.33.jar                          | None      |
          | LC    | cjcm              | 1.0               | cjcm-1.0.jar                                      | None      |
          | L     | opframe           | 1.4.0             | OnlinePicFrame_v1.4.33_mc1.12.2.jar               | None      |
          | L     | creativecore      | 1.10.0            | CreativeCore_v1.10.9_mc1.12.2.jar                 | None      |
          | L     | forgelin          | 1.8.3             | Forgelin-1.8.3.jar                                | None      |
          | L     | cfm               | 6.3.1             | furniture-6.3.1-1.12.2.jar                        | None      |
          | L     | littleopener      | 1.0.1             | littleopener-1.0.1.jar                            | None      |
          | L     | littletiles       | 1.5.0             | LittleTiles_v1.5.0-pre199_53_mc1.12.2.jar         | None      |
          | L     | mcmultipart       | 2.5.3             | MCMultiPart-2.5.3.jar                             | None      |
          | L     | harvestcraft      | 1.12.2zb          | Pam's+HarvestCraft+1.12.2zf.jar                   | None      |
          | L     | worldedit         | 6.1.10-SNAPSHOT   | worldedit-forge-mc1.12.2-6.1.10-SNAPSHOT-dist.jar | None      |
          Loaded coremods (and transformers):
      ForgelinPlugin (Forgelin-1.8.3.jar)
       
      Quark Plugin (Quark-r1.6-178.jar)
        vazkii.quark.base.asm.ClassTransformer
      CTMCorePlugin (CTM-MC1.12.2-1.0.1.30.jar)
        team.chisel.ctm.client.asm.CTMTransformer
      LittlePatchingLoader (LittleTiles_v1.5.0-pre199_53_mc1.12.2.jar)
        com.creativemd.littletiles.LittleTilesTransformer
      CreativePatchingLoader (CreativeCore_v1.10.9_mc1.12.2.jar)
       
          GL info: ' Vendor: 'NVIDIA Corporation' Version: '4.6.0 NVIDIA 456.55' Renderer: 'GeForce RTX 2060 SUPER/PCIe/SSE2'
          Launched Version: 1.12.2-forge1.12.2-14.23.5.2847
          LWJGL: 2.9.4
          OpenGL: GeForce RTX 2060 SUPER/PCIe/SSE2 GL version 4.6.0 NVIDIA 456.55, NVIDIA Corporation
          GL Caps: Using GL 1.3 multitexturing.
      Using GL 1.3 texture combiners.
      Using framebuffer objects because OpenGL 3.0 is supported and separate blending is supported.
      Shaders are available because OpenGL 2.1 is supported.
      VBOs are available because OpenGL 1.5 is supported.
          Using VBOs: Yes
          Is Modded: Definitely; Client brand changed to 'fml,forge'
          Type: Client (map_client.txt)
          Resource Packs:
          Current Language: English (US)
          Profiler Position: N/A (disabled)
          CPU: 8x Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz
    • By Umbreon118
      For some reason my modpack won't load mods when I start it up, it just cuts to vanilla.
       
      I am hoping that one of you wonderful people can find issues that I have missed.

      Here is my dropbox for the modpack, https://www.dropbox.com/s/rnnzusyjyp8z2w8/Pokemon.zip?dl=0 
      Before anyone says it, I have double checked by reinstalling all the mods off of curseforge to insure they are from a reliable source.

      I hope to hear solutions or suggestions soon.

      Thanks
    • By Plowmanplowbro
      First of all, i apologize if this is the wrong place, i couldnt find a help section in the search. and im in desperate need of a solution. 

      So i followed a tutorial to publish a pack to technic, it downloads everything fine but minecraft itself doesnt load with the mods. 

      here is the link: http://dl.dropbox.com/s/6mes1106tcic227/Soffcraft.zip

      please tell me what i did wrong, i have people waiting on me to finish this. 
    • By Justous
      Hi everyone,
      Despite my best efforts and reading several previous posts from this very form, my modpack keeps launching as if forge isn't installed. The mods and config folders and filled out and the modpack.jar is present in the bin folder upon install, but something just isn't happening. It seems like there must be something really obvious I'm missing...
      Here's a link to my modpack's zip: https://www.dropbox.com/s/m9pxkwagken6o02/muscraft.zip?dl=1
      Anyone have any idea what is wrong?
    • By Sakitek12!2
      So. I tried making modpack for me and my friends, but apparently, it isn't working. It starts normaly, but mod's won't load. Minecraft version is 1.12.2Links:

      Dropbox: https://www.dropbox.com/s/4y12dgfo6aifg4d/Modpack yes.zip?dl=0

      Pack https://www.technicpack.net/modpack/modpack-yes.1730492

      Thanks for any help. I tried doing what you guys said in other thread, but it didn't work for me 
       
×
×
  • Create New...