Jump to content

Recommended Posts

So I've read the whole Technic page for how to make a modpack. I've also watched two different videos explaining it. I've tried it out, and it'll download and run, but it won't open any worlds, or log on to my server... The modpack does run, because I've run it on my own totally fine. I would imagine it would have to be a problem with how the launcher installs my pack.

The problem is, I believe, how the Technic launcher installs forge. The instructions don't really specify how to get forge installed. I’m pretty confused how to add that properly, and how the technic launcher actually creates the pack.

What I've done is I've created a config folder with all my configs, a mods folder with all my mods, and a bin folder where I have the forge universal I downloaded, but the forge file is renamed modpack.jar (this is what both videos said to do).

I tried also including an empty coremods folder (empty because MC no longer has coremods in 1.6.4), but it would always crash. I took out the coremods folder, and for some reason now it loads, but it won't go into any worlds, SP or MP.

If anyone could help me out I'd really appreciate it.

Thanks!

Share this post


Link to post
Share on other sites
  • Your modpack has a staggering number of item ID conflicts. These will almost surely cause problems when trying to use any of the mods which are conflicting and cause a ton of problems for trying to set up a server.
  • Your modpack does actually start so I'm not sure exactly what you are asking for at this point. Your original post is a bit rambling.

Share this post


Link to post
Share on other sites

The game starts up, but you cannot enter a world. Why is that? How do I fix it?

 

I'm surprised you found ID conflicts, because I fixed all the block ID conflicts, and all the item ones I could. I thought there were only like 6 left.

 

I'd like to know if you or anyone else can explain to me how to include Forge in a 1.6.4 pack.

 

Thanks!

Share this post


Link to post
Share on other sites

I'd like to know if you or anyone else can explain to me how to include Forge in a 1.6.4 pack.

This is what I am confused about. You currently have Forge in your pack, correctly I might add. The modpack.jar file in the bin folder is simply the Forge universal jar file renamed to be "modpack.jar".

 

As for item ID conflicts, open your ForgeModLoader client log and search for the word "CONFLICT" (without quotes). Some may be unresolvable (Iguana Tweaks does "odd/bad" things) but most should be. Flan's often conflicts with itself which will require you to extract the weapon packs and change the IDs inside the text files from the weapon pack.

 

The pack does eventually start for me and I am able to create and enter a SSP world. Keep in mind that your pack is quite large and you need to be allocating 3G to the launcher to have any hope of running it successfully.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By PyroSweets
      My friends and I made a custom modpack with all our favorite mods in 1.12.2. I was having some issues with the modpack.jar that made it run vanilla and I fixed it, but now the modpack doesn't even show a java client or loading screen before crashing. I posted a day or two ago on reddit and was told to delete some iffy modpacks, but that only makes it run vanilla again. Any ideas why this is happening?
      Crash Log: http://dl.dropboxusercontent.com/s/wkv06mn3wna9hbv/techniclauncher_2020-05-31.log
      Modpack: http://dl.dropboxusercontent.com/s/ndyuw1g8t38xkde/POGWORK.zip
      Technic Page: https://www.technicpack.net/modpack/dillons-cult-pack.1697994
    • By xPriority
      Hello, so today i got a new laptop and installed mc launcher on it and wanted to install some modpacks. When i clicked the modpacks section there was no info about any modpack as you can see in the picture I attached, nothing was happening if I was trying to install any of the modpacks. I tried searching for other modpacks but nothing as well. I hope there is a fix to this. Thanks!

    • By amvandreel
      A few days ago I downloaded Minecraft Java Edition in order to to play with Shivaxi RlCraft, with my friends.  I have been unable to launch RlCraft for this entire time, and have tried waiting up to 20 minutes each time.  I currently have 64-bit Java downloaded and 3.5 GB allotted.  I am not sure what else I can do to make this work, and I would love to know that I didn't waste $27 on this process.  Any help would be greatly appreciated.
      Thanks!
    • By simovero
      Hi guys this is my very first post here and i wanted to ask you what was going on with the modpack i have created recently!!
      Whenver i try ti run minecraft the mods won't load and it will just be a vanilla minecraft. I have no idea of what i am supposed to do, hopefully i will get some help
      This is the link so you can check: https://www.dropbox.com/s/r4iw536knz7vb9v/redengineforgestock.zip?dl=0
       
      Sorry for my english since im not a native speaker.
×
×
  • Create New...