Jump to content

Recommended Posts

So I've read the whole Technic page for how to make a modpack. I've also watched two different videos explaining it. I've tried it out, and it'll download and run, but it won't open any worlds, or log on to my server... The modpack does run, because I've run it on my own totally fine. I would imagine it would have to be a problem with how the launcher installs my pack.

The problem is, I believe, how the Technic launcher installs forge. The instructions don't really specify how to get forge installed. I’m pretty confused how to add that properly, and how the technic launcher actually creates the pack.

What I've done is I've created a config folder with all my configs, a mods folder with all my mods, and a bin folder where I have the forge universal I downloaded, but the forge file is renamed modpack.jar (this is what both videos said to do).

I tried also including an empty coremods folder (empty because MC no longer has coremods in 1.6.4), but it would always crash. I took out the coremods folder, and for some reason now it loads, but it won't go into any worlds, SP or MP.

If anyone could help me out I'd really appreciate it.

Thanks!

Share this post


Link to post
Share on other sites
  • Your modpack has a staggering number of item ID conflicts. These will almost surely cause problems when trying to use any of the mods which are conflicting and cause a ton of problems for trying to set up a server.
  • Your modpack does actually start so I'm not sure exactly what you are asking for at this point. Your original post is a bit rambling.

Share this post


Link to post
Share on other sites

The game starts up, but you cannot enter a world. Why is that? How do I fix it?

 

I'm surprised you found ID conflicts, because I fixed all the block ID conflicts, and all the item ones I could. I thought there were only like 6 left.

 

I'd like to know if you or anyone else can explain to me how to include Forge in a 1.6.4 pack.

 

Thanks!

Share this post


Link to post
Share on other sites

I'd like to know if you or anyone else can explain to me how to include Forge in a 1.6.4 pack.

This is what I am confused about. You currently have Forge in your pack, correctly I might add. The modpack.jar file in the bin folder is simply the Forge universal jar file renamed to be "modpack.jar".

 

As for item ID conflicts, open your ForgeModLoader client log and search for the word "CONFLICT" (without quotes). Some may be unresolvable (Iguana Tweaks does "odd/bad" things) but most should be. Flan's often conflicts with itself which will require you to extract the weapon packs and change the IDs inside the text files from the weapon pack.

 

The pack does eventually start for me and I am able to create and enter a SSP world. Keep in mind that your pack is quite large and you need to be allocating 3G to the launcher to have any hope of running it successfully.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By CoolDrake
      Ok i tried to download a mod i did then i tried to play it {ps i'm on mac}  and then it said i unsupported version and i can't switch my version to 1.12 so i need help fixing it to 1.12 instead of 1.13.2
    • By terminatorztc
      So I'm not really sure what even happened all I know is that I tired to run Tekxit 3 LE Official. When it didn't run a tested multiple other packs including Attack of the B-Team, Blightfall, Tekkit, ect. None have been able to even open. The launcher flickers then almost resets like it never was launching in the first place. I tried reinstalling the pack and launcher, even a complete check on my PC. Specs have nothing to do with it I have 12gb of RAM also nothing should be conflicting with the program. I'm honestly at a loss for words as this is nothing like I've ever seen. I've tried just about everything reinstalling Java was something I tested but to no avail. I tried researching my problems hoping someone had the same issues but I only find outdated sources and after updates I dont trust their solutions. It may also be well to inform everyone that the modpack did initially work but i tired downloading another modpack which was RLCraft but that didnt open and now im here(I now only have Tekxit installed and still wont run).
       
      Edit: Almost forgot crashes when "installing minecraft assets"
    • By YESE
      When I press install on a modpack, I can't download the modpack because after I pressed install a button that says delete mod pack right beside the mod pack
    • By HAMBURBUR
      My modpack that i created is only loading vanilla and not forge and i've looked all over the internet and found nothing about it. https://www.technicpack.net/modpack/avatarage-of-the-blockbenders.1716798
×
×
  • Create New...