Jump to content

"Can't reach server?"


FedoraTime
 Share

Recommended Posts

So I made a Tekkit server for my friends and I, and it works if I connect using "localhost", but when I try to test it by connecting using my actual IP, it doesn't work.

 

I have port forwarded, and I used my IPv4 address, and I used the typical 25565 port. I went to ipchicken to get my public IP, and that's what I'm using to try and connect. When adding the server, I also include the port :25565, but it still doesn't work. There are no errors in the command prompt.

 

Any advice?

Link to comment
Share on other sites

It still won't work. I enabled DMZ and set the host to my IPv4 address. 

 

Is there an option in the properties folder that isn't allowing people to connect to it? Everything look fine. I double checked my IPv4 address to see if I input it correctly when I first port fowarded. I made sure the ports were the same in the server properties and on the port forward screen from my router settings. I can't find the problem!

Link to comment
Share on other sites

If I may interject: I have been running a small local server and never could connect to it via public IP, although friends were able to connect using just that IP. On my LAN, I had to use the local IP.

So a proper test would be not connecting yourself that way, but having a friend connect via Internet using the public IP. I guess it should be basically possible to use the public IP on a local computer, using DMZ and whatnot. But it should not be necessary, in my experience.

 

I'm not a network geek, so no guarantees that I got everything right. But my server is working.

Edited by Curunir
Link to comment
Share on other sites

Upload a screenshot from the router port forward settings and post basic network config: IP, mask, gateway, router IP. Post the TCP/IP settings of your machine also.

Cover personal data in screenshots if there are any.

 

Does your ISP provide real public IP or is this some kind of NAT?

Edited by bochen415
Link to comment
Share on other sites

Note that many routers do not do loopback [LAN2LAN via WAN (public) IP], to avoid IP spoofing attacks I guess.

 

First make sure that in server.property file server-ip= is blank (nothing at all), so it can bind to ANY IP on the server.

 

Then make sure that you can connect to the server from another computer on your LAN (local) network using the LAN IP of your server. If that fails, port forwarding is not going to work (maybe firewall on server is blocking).

 

Then assuming that you properly forwarded TCP port 25565 (I don't think UDP matters) to the LAN IP of your server:

 

Go to canyouseeme.org and see if the IP it shows for you agrees with the public IP you have from comcast and whether that site shows port 25565 open when you check it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...