Jump to content

Building A Modpack...


Landonian7000
 Share

Recommended Posts

I also have a few other questions

 

-Which mod replants seeds when right clicked on a fully grown crop?

 

-What mod allows sorting by clicking "R" or "Mouse3"?

 

-Which mod has the advanced options menu when you press "O"? (I think it might be forge but I am not sure...)

 

-What mod in Attack of the B team and Big Dig, allows more frequent ore generating?

Edited by Landonian7000
Link to comment
Share on other sites

         So I have everything that I want, I followed the instructions on the main page of the Technic Platform on how to make a Modpack. I made 4 folders: "bin" (Which includes all the Minecraft 1.6.4 class files and folders that are in the original 1.6.4 minecraft.jar) "config" (I didn't have anything in the folder because I am certainly not a coder and I am not sure what to do) "coremods" (Which I put all of the specified core mods in, I don't think forge is a core mod if I am correct) and "mods" (Where I put all of my specified mod files, all of the .zip's and .jar's).

 

          I then added them to an archive onto my desktop named "MyModpack.jar" just to see if it would run... sadly it did not... the window just says it is an invalid or corrupt file. I think I might be missing the other file from the original Version folder for 1.6.4 as in the .json file. However, I am not sure how it all works, as in where would the file be placed in the .jar, since I have never tooken a proper computer class in my life, most of my knowledge is based off of the internet. I also noticed that the small tutorial looks somewhat outdated so maybe the process has changed?

 

Any feedback is appreciated! Thank You!

Link to comment
Share on other sites

configs folder should just be a copy/paste of the modpack you have ran once already and resolved ID Conflicts, the bin folder doesnt need the vanilla files, only the universal forge jar renamed to modpack.jar. coremods folder isnt necessary anymore for 1.6.4 and all mods belong in the mods folder.

 

Then that itself is zipped up, and it is the one used to uploaded to a place and a custom modpack is made on the technic platform (main page, register/sign in, dashboard, new modpack) and thats what will be downloaded when you add the pack to the launcher, you do not run the zip itself.

Link to comment
Share on other sites

  • 4 weeks later...

I know it has been a while, but I just haven't had the time...

 

I copied a "1.6.4.jar" file and renamed it "Modpack.jar" and I run it and it just doesn't work?

 

Does the config folder appear when I actually succeed to run the Modpack.jar file?

 

And I'm just assuming the mod folder just needs to be dropped into the Modpack.jar file...

 

Is there something I'm doing wrong?

Link to comment
Share on other sites

You need a website that allows a direct link to the files.

Dropbox allows this, but it may need a few clicks to find said link. (Although I think it's just as easy as right-clicking the files and selecting an option)

 

In short, though. If you need to click a button to start the download, it's not going to work.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

    • By Omega_Volta
      I was planning on using some mods, but when I opened the modpack I intended to use, it just shut down and sent me back to the launcher screen. 
      I've tried removing the mods, uninstalling and reinstalling the modpack, updating my launcher, updating java, and restarting my computer, to no avail.
      Down below is the log in pastebin:
      https://pastebin.com/y64AeY0t
    • By M3veronMast3r
      Hello, I didn't know where to put this Thread, sorry for that.
      My Problem is that i want to create more than only 5 Modpacks. I have different Packs in different Version and i need them all and i dont want to create constantly an new account just to create a new Modpack. I dont understand why this Action is limited to 5 Modpacks. It makes no sense to me. Is there any way to create more than only 5?
      Hope you can help me. ~M3veronMast3r
    • By redluni
      Last year I created 2 modpacks on 1.12.2 following advice from this post: How to make a Minecraft modpack – Platform Help Center (zendesk.com) . Today I decided to create another one and did the same things as last time, now however when I start the game on technic platform forge does not load so it just a vanilla 1.12.2, I have checked the files and everything is there. If anyone could help me I would be pleased. This is the modpack: BProjeto 1.0 - Technic Platform (technicpack.net) .
      Thanks in advance.
    • By 4net_E
      LAUNCHER VERSION: v4.664
      OPERATING SYSTEM: macOS 10.14.6
      JAVA VERSION: Oracle 1.8.0_261 64-Bit
      ANTIVIRUS: none
      recently I tried to play some modpacks, but i couldnt start any of them. Every time I wanted to launch them, icon of the modpack showed up in taskbar, window popped up, but after approximately a second, it had crashed.
      I tried to solve this problem by myself, but I didnt manage to success. The closest Ive got to solution was in this thread :
      However, there is a solution linked on another forum thread, but that link is probably corrupted or something, as it just redirected me to the same thread all over again. Thus Im stuck and seek help. This is a log after one of the unsuccessful launch attempts: https://pastebin.com/Md4yW3yw
      For any kind of suggestions or additional information request I'd be very thankful
      Okay, fortunately under this post's recommended threads I've found another new thread which stated a similar problem: 
       
      The solution right there seems to do the job (at least temporarily), but still, I'd like to know the core of the problem, for example - why 8u251 works and 8u51 doesn't?
      Hope this helps someone someday
    • By proofshy
      So I have been trying to make my own but it does not seem to work even tough I have done everything correctly, (i checked this with people who knew more about it with me and they got stuck too)
      or maybe were just noobs   
       
      however that is not the point
       
      I am looking for a mod pack for builders
      that includes more types of trees mods
      more types of biomes mods
      more types of mobs mods
      and furniture mods
      and more item mods
      and that one mod that i saw somewhere with helpful villagers could be fun too but isn't necessary lol
       
      it doesn't have to be perfect but what is the mod pack that gets closest to this idea? 
       
      don't be a  <redacted> because i couldn't make the mod pack myself by the way, lets be real, if it already exists why make another one?
×
×
  • Create New...