Jump to content

Game freezes when I go near my base


Recommended Posts

I had a similar problem some time ago. When I was in a certain area and looking a certain direction I got massive frame rate drops for no appearant reason. I had just started that world, so I simply deleted it and started over. Haven't seen the problem since then. I didn't make a tracker post on it then because I lacked any substantial info on what was causing it.

I hope you manage to find a solution sicne deleting an established world is no fun.

Link to post
Share on other sites

I opened the console and this is what it showed me.

2014-09-17 17:18:37 [WARNING] [Minecraft-Client] Memory connection overburdened; after processing 2500 packets, we still have 51769 to go!
[b#439]  2014-09-17 17:18:37 [iNFO] [Minecraft-Server] Saving and pausing game...
[b#439]  2014-09-17 17:18:37 [iNFO] [Minecraft-Server] Saving chunks for level 'A Hole New World'/Overworld
[b#439]  2014-09-17 17:18:38 [sEVERE] [ForgeModLoader] An Entity type net.minecraft.entity.passive.EntityVillager has thrown an exception trying to write state. It will not persist. Report this to the mod author
[b#439]  net.minecraft.util.ReportedException: Saving entity NBT
[b#439]   at net.minecraft.entity.Entity.func_70109_d(Entity.java:1605)
[b#439]   at net.minecraft.entity.Entity.func_70039_c(Entity.java:1545)
[b#439]   at net.minecraft.world.chunk.storage.AnvilChunkLoader.func_75820_a(AnvilChunkLoader.java:292)
[b#439]   at net.minecraft.world.chunk.storage.AnvilChunkLoader.func_75816_a(AnvilChunkLoader.java:127)
[b#439]   at net.minecraft.world.gen.ChunkProviderServer.func_73242_b(ChunkProviderServer.java:232)
[b#439]   at net.minecraft.world.gen.ChunkProviderServer.func_73151_a(ChunkProviderServer.java:284)
[b#439]   at net.minecraft.world.WorldServer.func_73044_a(WorldServer.java:899)
[b#439]   at net.minecraft.server.MinecraftServer.func_71267_a(MinecraftServer.java:360)
[b#439]   at net.minecraft.server.integrated.IntegratedServer.func_71217_p(IntegratedServer.java:124)
[b#439]   at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:484)
[b#439]   at net.minecraft.server.ThreadMinecraftServer.run(SourceFile:583)
[b#439]  Caused by: java.lang.NullPointerException
[b#439]   at net.minecraft.village.MerchantRecipe.func_77395_g(SourceFile:107)
[b#439]   at net.minecraft.village.MerchantRecipeList.func_77202_a(SourceFile:127)
[b#439]   at net.minecraft.entity.passive.EntityVillager.func_70014_b(EntityVillager.java:241)
[b#439]   at net.minecraft.entity.Entity.func_70109_d(Entity.java:1588)
[b#439]   ... 10 more
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
  • Similar Content

    • By bigherdguy
      I’m installing the launcher for the first time and I open it with the .jar opener application and it downloads like normal but stays on the logo afterward and the launcher does not appear. What am I doing wrong? What should I do?
    • By ShrillBear
      So as the title says, i had a lot of problem with this server over the past weeks. There were many problems
      First of all, lags. Lots of them. I thought it might be because of Recurrent Komplex (because a lot of times the log said that the mod causes cascading worldgen lag).
      So i removed it. Than i also removed mystcraft because some times it also had the same messages in the log.
       
      But the server still lags and crashes.
      I often get kicked with the message fatal error, the connection was terminated or something like that.
      It also takes way long the modpack to load. (1.12.2, custom modpack with around  115 mods)
       
      My specs:
      i5-4440
      750-TI
      16 Gb DDR3 (6 Gb for server, and 6 for the launcher, ridiculous.)
       
       
       
      https://pastebin.com/5kA748PK
       
       
       
       
    • By 2003Alex2011
      I recently started a Tekkit Legends world and decided to manually add Galacticraft back into the modpack. I've been playing for around 50 hours. After returning to Earth from my space station, I noticed an insane dip in TPS. The /TPS command reveals a TPS of 0.3. I have no idea what caused this, but if anyone has any insight into whatever's going on, it would be much appreciated.
      Information:
      World Download: http://www.mediafire.com/file/3mk2wq3u5kesuyq/Tekkit.rar/file
      RAM: Java using 3.4GB of allocated 3.5GB
      If any more information is needed, I will add it here.
    • By haxx4real
      So i was playing fine until the movement starts stopping randomly like with jetpack it would stop mid flight and then back on again.I cant go walking in a straight line without stopping 3 or 4 times and it doesnt freeze just stops because everything around keeps moving when this happens. i tried many things none worked .My fps is constantly 150+ even when this spikes appen. i have no idea, if someone know how to fix pls help 
      Repluged keyboard and now its fine
    • By Quizer9O8
      Hello there,
      Since I haven't got any luck of finding a fix or someone mentioning this issue I'll place it down right here.
      A few months ago I have noticed that whenever you're launching a Minecraft modpack from the Technic Launcher Minecraft suddenly hijacks all of the available RAM which causes to freeze the entire computer for 10 - 15 minutes before I'm able to terminate the process manually in Task Manager (Windows 10). Since I have 16GB of RAM in my pc I allocated 8GB of RAM to Minecraft (which should be enough for many modpacks) in the settings shown here below but no matter what is set in the Launcher Options seems to have any effect, it straight up ignores it all together.

      I'm out of ideas and in desperate need for a solution because this issue makes every modpack I have (small or large) unplayable at this point.
×
×
  • Create New...