Jump to content
Sign in to follow this  
speedy

Bringing over standard MC map into TekkitServer

Recommended Posts

Hi all. I've just tried copying over the /world directory from my old vanilla SMP server to my new TekkitServer directory. I can get into the world but it has reverted back a couple of months, which is a bit strange.

Any ideas about what might be causing this, or what I can do to get around it?

TIA.

Share this post


Link to post
Share on other sites

Hi all. I've just tried copying over the /world directory from my old vanilla SMP server to my new TekkitServer directory. I can get into the world but it has reverted back a couple of months, which is a bit strange.

Any ideas about what might be causing this, or what I can do to get around it?

TIA.

Not a whole lot you can do. You'll need the new generation of it anyway, because I can guarantee your old map doesn't have any of the new Tekkit ores spawned in it. Use something like MCEdit to copy over your old buildings.

Share this post


Link to post
Share on other sites

Hi all. I've just tried copying over the /world directory from my old vanilla SMP server to my new TekkitServer directory. I can get into the world but it has reverted back a couple of months, which is a bit strange.

Any ideas about what might be causing this, or what I can do to get around it?

TIA.

I'm going to assume that your 'old vanilla SMP' world directory is from before 1.2.*. Please correct me if I'm wrong.

As to what is causing your world to revert back a few months, I have next to no idea. I had a very similar problem back when I was running a Bukkit server. Whilst trying to update the maps to 1.2.* the map would revert itself 2 weeks from the point at which I updated. I drudged up a baseless theory about the Anvil system and how it was possible that it was causing the reverting issue, as there was nothing else I could see that was causing it. I also found that when I would attempt to load a backup it would do the same exact thing, regardless of the age of the backup. That is what led me to believe it was Anvil that was screwing me over, as it was the only variable that was different.

I don't want to give you false information, which is why I stated my theory had been baseless. I have no idea if that was the cause or not. If it was, however, then you could be experiencing something similar with Tekkit's map generation. Seeing as Tekkit obviously has a different system of world generation (be it something as small/large as ore to tree inclusion) then it could be causing some error or other, or some kind of environment that would instigate the reversion of your map file to some time before the initial conversion. Once again this is baseless.

To address the solving of this issue: I think that the most cost effective solution would be to transfer the most important builds over to a newly generated Tekkit world via MCedit. You could theoretically transfer the entire map over (via MCedit), however depending upon your situation and how you wish to run your server this route might not be the best to take. It would deny your players (or yourself if it is just you) access to freshly generated Tekkit materials. It would also take a varying amount of time to port an entire map, based upon the map size. If the map was used a lot and many buildings were made, then it would take quite a long time to port then entire map, and it is possible it will not work unless you do it in spurts, if your computer is not capable that is.

I recommend just porting over the important things into a fresh new world with MCedit. The choice is of course yours however, and whatever choice you do take, I wish you the best of luck.

Well wishes,

Derpy

MOD EDIT: I'd say signing the post is the worst thing about this but so much about this user in particular is bad, including username, avatar, ponies, etc.

Share this post


Link to post
Share on other sites

Thanks for the replies - the world is straight from a 1.2.5 server (although the map originally dates back to sometime last year), so I thought it might be Anvil as well, but when Tekkit fired up it never did the conversion to Anvil format, which says to me that it's running the Anvil version.. just a really old version of it. Oh well, lets see how it goes.

Share this post


Link to post
Share on other sites

Well... I do know exactly what's going on here. If your world came from a 1.2.5 server, it will mean it is already converted to anvil! You can't convert anvil back to the old format BUT when the conversion from the old format to anvil happened (It's most likely that the 1.2.5 server did that), the old MCR files aren't removed. The client doesn't remove the old files, so the server doesn't as well. Tekkit only loads the old file format and you have those files still in your region map. That's the reason why you don't see your 1.2.5 content. It's loading the old files. Simple as that.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...