Jump to content
Sign in to follow this  
SamEskenazi

Help setting up a server, error on opening Launcher "Checking Launcher Version"?

Recommended Posts

Hello all,

I'm currently trying to set up a server for just myself and my girlfriend. I have the server information downloaded, and have successfully run and started the server.

However, the launcer simply will not open. It says "checking launcher version" and then crashes.

Simple googling and searching the forums tell me that it is a java issue. But... it's not! It turned out I had java6, when I should have had 7 so I installed 7 and uninstalled 6. That enabled me to run the server when I wasn't able to before.

But, the launcher still won't open. I have the right version of java, but it simply won't work. The guide under common problems here http://forums.technicpack.net/index.php/topic,4193.msg25703.html#msg25703

says to use the .jar file instead. But... it doesn't work! It says it can't open the file, even though it's an executable! It's opening with "windows shell common" which I assume is the problem, but what should I open it with, then?!

I can't find any decent guide on what to do! Surely it cannot be that every single person who plays tekkit is a seemingly mastermind at computing, able to solve any problem with ease?!

Simply put, is there a problem because I uninstalled java6? Surely not, because I'd want to make sure that java7 would be the only one to work, yes? This still happened before I deleted java 6 as well. I thought deleting it would help.

When I go into CMD, do the whole "java -version" check, it comes up with the correct, up to date version of version 7 so I am using the right one.

I am most certainly running 64 bit windows, as well. I don't know what I could have done. I just downloaded the launcher onto my girlfriend's laptop and it worked, so what's wrong with mine? Why is it not noticing java, if that's the problem?

Any help would be appreciated, thank you!

Sam

Share this post


Link to post
Share on other sites

Re: Help setting up a server, all guides are inadequete help!

There's two problems this might be(Haven't worked this out from the text - don't worry, I have fixes for both)

If it's the Technic Launcher that's giving you trouble, you want to download the .jar or the .exe(Whichever one you're not using)

If it's the server, you need to add Java to the path. If you don't know how to, google it :)

Share this post


Link to post
Share on other sites

Re: Help setting up a server, all guides are inadequete help!

There's two problems this might be(Haven't worked this out from the text - don't worry, I have fixes for both)

If it's the Technic Launcher that's giving you trouble, you want to download the .jar or the .exe(Whichever one you're not using)

If it's the server, you need to add Java to the path. If you don't know how to, google it :)

I have downloaded both versions of the launcher, and neither work. The .exe file comes up with "Checking Launcher Version" and then just doesn't open.

The .jar file simply will not open. It says it cannot open, and nothing happens.

As I said in the post, the server is running fine; I haven't been able to join it, obviously however, as I don't have the launcher! But, it is enabled and such.

What do you mean "add java to path" do you mean this: http://forums.technicpack.net/index.php/topic,2805.0.html If so, I did that and nothing really changed, as the server installs just fine!

Sam

Share this post


Link to post
Share on other sites

Okay, just deleted the damn thing and re-downloaded the launcher .exe

I also disabled by AV just in case, so all protection down. I run it, and it runsa loading bar that goes to 100%, but the bar is still only half full! Then, it doesn't do anything and seemindly crashes. On loading it up again, does the same "Checking Launcher Version" again

Does anyone have any idea what's going on? :(

Share this post


Link to post
Share on other sites

Alright, I attempted to open the .jar file using the Java web start launcher, but it says it is unable to open the file! Why is that?

I get this on the "Details" section of the aplication error for Java:

MissingFieldException[ The following required field is missing from the launch file: <jnlp>]

at com.sun.javaws.jnl.XMLFormat.parse(Unknown Source)

at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)

at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)

at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)

at com.sun.javaws.Main.launchApp(Unknown Source)

at com.sun.javaws.Main.continueInSecureThread(Unknown Source)

at com.sun.javaws.Main$1.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

Where is this <jnlp> meant to be, and where should I add it? Oh god, I am very much confused.

Share this post


Link to post
Share on other sites

I have re-installed Java from the main page of the site, seemingly a different version? I don't know, but it's the correct one (version 7) but I am still getting the same "Checking Launcher Version" problem.

Had a brief problem wherein Java gave me 32 bit one my default, meaning it came up that it couldn't find java dreictory, so I installed the correct one.

Still having this problem, and nothing should be causing it! I just want to damn well play Tekkit :(

Share this post


Link to post
Share on other sites

You need both java 6 and 7. I recommend you delete the .techniclauncher folder and reinstall everything from the .exe once you've got both Java 6 and 7 on your computer again. Also, make sure that the java versions you download are for your OS. If you have Windows 7 64bit, then download the windows 7 64 bit copies of Java. Make sure that they are the right versions for your OS or you WILL run into problems.

Share this post


Link to post
Share on other sites

You need both java 6 and 7. I recommend you delete the .techniclauncher folder and reinstall everything from the .exe once you've got both Java 6 and 7 on your computer again. Also, make sure that the java versions you download are for your OS. If you have Windows 7 64bit, then download the windows 7 64 bit copies of Java. Make sure that they are the right versions for your OS or you WILL run into problems.

Alright, I've done so. I've removed all Java, and deleted the .techniclauncher folder and everything. Then, I've reinstalled both versions of Java, and it still does not work...

They're both for my version of windows (64 bit) and it has the exact same problem.

Any more suggestions?

Share this post


Link to post
Share on other sites

Right click the jar file, go to 'Open With' and chose 'Java 7' or whatever has 'Java 7' within it.

I have done so; however, Java simply says "Unable to open application".

And, now it appears that there's a new version of Tekkit?! Oh god... Guess I have to do the server again!

What mods aren't in Tekkit 3 that were in 2?

Sam

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...