Jump to content
KakerMix

Technic Platform V2 and Technic Launcher V3

Recommended Posts

Well guys if you want to translate the standard approach is to fork the github repo, make the translation to UIText.properties and submit a pull request.

Share this post


Link to post
Share on other sites

Well guys if you want to translate the standard approach is to fork the github repo, make the translation to UIText.properties and submit a pull request.

How we can do this ?

Share this post


Link to post
Share on other sites

You need to know github usage perfectly to start this.

Does Launcher Will support Special Symbols Like ó ł ż ą ę ń ś ?????

Share this post


Link to post
Share on other sites

Liking it so far, I have a few minor questions and concerns:

 

Each pack now has a little tag that says "Solder enabled" if it uses solder, does this mean that solder is going to recieve an update soon or is it just a new interface change?

 

Everything feels really unresponsive.  On the V2 launcher, clicking things would instantly or close to instantly.  On this launcher, there can be a 1-5 second delay clicking anything.  It makes the whole thing feel very clunky.

Edited by miniboxer

Share this post


Link to post
Share on other sites

Liking it so far, I have a few minor questions and concerns:

 

Each pack now has a little tag that says "Solder enabled" if it uses solder, does this mean that solder is going to recieve an update soon or is it just a new interface change?

 

Everything feel really unresponsive.  On the V2 launcher, clicking things would instantly or close to instantly.  On this launcher, there can be a 1-5 second delay clicking anything.  It makes the whole thing feel very clunky.

I've been testing the new launcher and it works fine on my system. 

Share this post


Link to post
Share on other sites

Has this been tested very extensively on Linux? The UI seems rather broken on my computer.

This was with the stable Ubuntu OpenJDK 7, I'll try it again once I've installed the latest Oracle Java 8 which I've been meaning to get.

Share this post


Link to post
Share on other sites

Liking it so far, I have a few minor questions and concerns:

 

Each pack now has a little tag that says "Solder enabled" if it uses solder, does this mean that solder is going to recieve an update soon or is it just a new interface change?

 

Yes. Solder is under development. 

 

Here is a demonstration of what I mean:

'>

I have clicked the button when I move my mouse away, the delay when it changes is not due to the gif, that is what I am talking about.

The strange colored dots, however, is due to the gif.  Simple color compression.

EDIT: Apparently the colored dots didn't show when I uploaded to gfycat.  I forgot to mention that the weird green lines in the corner are the FPS overlay from shadowplay.  They don't like it when a program doesn't update at a regular interval and kind of freak out.

 

Has this been tested very extensively on Linux? The UI seems rather broken on my computer.

This was with the stable Ubuntu OpenJDK 7, I'll try it again once I've installed the latest Oracle Java 8 which I've been meaning to get.

 

Please join #platformbeta on SynIRC for bug reports/issues. We have been working on testing on Mac and Linux.

Share this post


Link to post
Share on other sites

The best thing to do would be add Technic SSP back into the new launcher! That would be awesome! If you guys could do that then you're awesome as well!

Edited by Stuf7

Share this post


Link to post
Share on other sites

For people wanting to do translations,

 

(If you know how to use Git/Github) Go here and fork the repo: https://github.com/TechnicPack/LauncherV3 and submit a Pull Request with your added translation

 

Example PR: https://github.com/TechnicPack/LauncherV3/pull/10

 

(If not) Please PM me here on the forums. I will provide you with a blank translation file to translate. You will still be credited. 

 

Gen

Share this post


Link to post
Share on other sites

I like the new launcher! It was very laggy running the "stable" version but updating to the beta seems to have fixed that, so I'm guessing you found and patched the issue there, good job :) Is there any possibility of getting your technic launcher (in my case Hexxit) server featured in the launcher? There could be some kind of way to buy a position or simply a good ol' votifier system for the most popular servers. I feel like this would be a win win for both the technic and the server community.

Share this post


Link to post
Share on other sites

I am getting a JVM error whenever I try to launch Build 132 of the new Launcher.

 

EF9UXkv.png

 

I am using Java 8, Update 25.

 

I tried re-downloading it, downloading other builds, downloading the Windows executable (that doesn't do anything when I double-click it), and I even tried downloading it using other browsers.

Share this post


Link to post
Share on other sites

I like the new launcher! It was very laggy running the "stable" version but updating to the beta seems to have fixed that, so I'm guessing you found and patched the issue there, good job :) Is there any possibility of getting your technic launcher (in my case Hexxit) server featured in the launcher? There could be some kind of way to buy a position or simply a good ol' votifier system for the most popular servers. I feel like this would be a win win for both the technic and the server community.

 

Buying featured spots is still under debate. However our new sorting algorithm for modpacks now show trending modpacksas well as most popular, newest, and most updated.

 

I am getting a JVM error whenever I try to launch Build 132 of the new Launcher.

 

EF9UXkv.png

 

I am using Java 8, Update 25.

 

I tried re-downloading it, downloading other builds, downloading the Windows executable (that doesn't do anything when I double-click it), and I even tried downloading it using other browsers.

 

Please right-click, save-as. The file should be 35MB in size. Any smaller and the file did not download properly. Also you downloaded the jar file. (.jar) which is primarily for linux. There is an .exe file.

 

Here is the direct link: http://jenkins.technicpack.net:8080/job/LauncherV3/lastStableBuild/artifact/target/launcher-4.0-132.exe

Share this post


Link to post
Share on other sites

Liking it so far, I have a few minor questions and concerns:

 

Each pack now has a little tag that says "Solder enabled" if it uses solder, does this mean that solder is going to recieve an update soon or is it just a new interface change?

 

Everything feels really unresponsive.  On the V2 launcher, clicking things would instantly or close to instantly.  On this launcher, there can be a 1-5 second delay clicking anything.  It makes the whole thing feel very clunky.

I'm also experiencing similar delays, although I'm pretty sure it didn't occur in previous builds. Some new features such as optionals like @disconsented mentioned too at some point would be really useful as well.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Upikia123
      I really need some help please, it's making like 2 days I'm trying to figure out what's wrong with technic launcher, because everytime I click on play to launch a modpack, it's just closing the technic launcher sreen, load a littlebit and then it just pop-up the technic launcher screen again, I know that Java is not the problem because I tried the 8u25, the 8 251 and the 8 191 version and they all did the same error again and again. I was thinking that my graphic card driver was the problem, but I just updated it to the last version and it did the same. I also did every Windows Update and it did the same again... I would be glad to find a solution.. 
      Here are the last crash report (log) I had:crash-2020-04-19_20.41.04-client.txt
    • By Mikewood
      I was used to play modpacks on the technic launcher. But today i can't start the modpack.
      When i click on the play button, it closes the window like the modpack is normally loading. But after maybe 10 seconds it open the technic launcher window again.  Here is my crash report. I don't know why is it not working. Can anyone help or know the possible fixes ? 
       
      crash-2020-04-17_13.07.04-client.txt
    • By LonkaGaming
      Your world is save in %appdata% .technic>modpacks<select your modpack<saves
    • By FullMetalFerkel
      When I run the TechnicLauncher.exe the first time I can install it and every thing is fine. But when I try to run the TechnicLauncher.exe after the installation it won't open. It doesn't even pop up an error dialog. When I look into the latest log file it show following error:
          > java.lang.NoClassDefFoundError: com/sun/awt/AWTUtilities.
      I googled for a few weeks now and didn't find a solution. Sadly I didn't even found somebody with the same problem.
      I currently have a java JRE 8u211 installed. previously I had some java 10 JDK but thought that would be the problem and deleted it. Since I'm not developing java on this machine I simply installed the 8u211 JRE and hoped this would fix my problem.
      Since AWTUtilities is a standard java class I didn't expect technic launcher to have any issue with it, as long as the launcher can find my java installation. But as far as I know, my environment variables are correctly setup and java should be installed correctly.
      I add the technic launcher error log, and some screenshots about my java installation.
      I hope you guys can help me, and I hope I didn't miss one of the forum rules. Thanks in advance



      techniclauncher_2019-05-31.log
    • By Quizer9O8
      Hello there,
      Since I haven't got any luck of finding a fix or someone mentioning this issue I'll place it down right here.
      A few months ago I have noticed that whenever you're launching a Minecraft modpack from the Technic Launcher Minecraft suddenly hijacks all of the available RAM which causes to freeze the entire computer for 10 - 15 minutes before I'm able to terminate the process manually in Task Manager (Windows 10). Since I have 16GB of RAM in my pc I allocated 8GB of RAM to Minecraft (which should be enough for many modpacks) in the settings shown here below but no matter what is set in the Launcher Options seems to have any effect, it straight up ignores it all together.

      I'm out of ideas and in desperate need for a solution because this issue makes every modpack I have (small or large) unplayable at this point.
×
×
  • Create New...