KakerMix

Technic Platform V2 and Technic Launcher V3

Recommended Posts

I've been having problems getting one of my Solder-enabled packs to link properly to the Platform beta. Of my three Solder packs, only one of them is failing to properly link (and of course it's the one I NEED to be linked properly right now...).

 

Despite having Solder configured and linked on my profile, and the pack in question claiming to have a successful link on the Edit Modpack page, the main modpack page still says that the modpack isn't properly configured (and needs a link to a zip or Solder configuration). I've tried unlinking and relinking Solder (both on live and beta platform). I wanted to try to generate a new API key for beta and relink, but there's no button to generate a new key at the moment. I'd rather not delete and re-create the pack on the platform to keep my users from having to reinstall.

 

When I try to run the pack from the launcher using the version installed by the live launcher, the launcher tries to update the pack (which is already up to date) but fails to download ("Invalid URL: "). If I delete the installed pack and try to add it in the new launcher, it fails to download the pack entirely.

I need you to link your pack on the beta platform to help you with this. I do know that there was a problem with API key generation on the beta platform- it has been corrected in dev but not pushed live to the beta site yet.

Share this post


Link to post
Share on other sites

I need you to link your pack on the beta platform to help you with this. I do know that there was a problem with API key generation on the beta platform- it has been corrected in dev but not pushed live to the beta site yet.

 

Apologies, here's the pack: http://beta.technicpack.net/modpack/pixelmint-fresh.468793

 

Edit: In addition, here are the packs that ARE properly linked to solder:

 

http://beta.technicpack.net/modpack/ultamint-2.329022

 

http://beta.technicpack.net/modpack/pixelmint.402822

Edited by DeviPotato

Share this post


Link to post
Share on other sites

Will the newest java version work with this? My launcher currently will not lauch mods ever since i have upgraded java.

Just download java 7 and install instead of java 8.

 

 

About Technic beta

There is some things on the beta site that I can't seem to figure out.

 

  1. One of my packs is noticed to be linkable with solder but linking it still gives the message that I need to configure the modpacks download or link it to solder. It is linked to solder in the setup of the modpack but not when browsing it.

     

  2. Since the modpack above doesn't seem to work I thought I'd just remove it from my mods list. That's when the second problem occured.. How do I remove my modpack?? Can't find it removable anywhere.
Edited by sketaful

Share this post


Link to post
Share on other sites

I expect the launcher has no problem with Java 8. The current one doesn't either.

The modpacks, however, are dependent on Forge which does not play well with Java 8, and will remain that way until the packs get updated with a version of Forge which has that problem fixed.

Edited by Melfice

Share this post


Link to post
Share on other sites

A lot of the issues you guys were having is related to the way the beta site was implemented.

 

We are beginning our update process and you will be able to login to the main site shortly

Share this post


Link to post
Share on other sites

I expect the launcher has no problem with Java 8. The current one doesn't either.

The modpacks, however, are dependent on Forge which does not play well with Java 8, and will remain that way until the packs get updated with a version of Forge which has that problem fixed.

i am not sure if the bug was in forge or java8 took out one of the fuctions forge used in 7 and earlyer if thats the case its javas falt lol

Share this post


Link to post
Share on other sites

I finaly was able to create an account and got an activaion link. But when i use it, i only come to the login page. if i try to login it says i must activate my account. -.-

Share this post


Link to post
Share on other sites

well my problem is on tekkit only i have no sounds what so ever

and yes the valume menu is set for music off and sound ot full

what should i do

Edited by challenje

Share this post


Link to post
Share on other sites

It seems that this is still not common knowledge:

i am not sure if the bug was in forge or java8 took out one of the fuctions forge used in 7 and earlyer if thats the case its javas falt lol

 

Forge had a bug. It didn't break anything because it was masked by another bug in Java. Then Java 8 update 20 came around and fixed the Java bug that had been masking the Forge bug. Thus, the unfixed Forge version(s) cannot run with Java 8 update 20 or newer. It will run with earlier Java 8 versions (not recommended because of missing security fixes), or Java 7.

 

There has been a Forge hotfix for quite a while now to patch the old version (just drop in the mods directory of affected packs). Tekkit and other modpacks suffering from the issue will run fine on Java 8 update 20 or newer when it is applied. The hotfix should have been brought at least to Tekkit beta asap, but has not. I am summarizing this to raise awareness, and reinforce my point that Tekkit needs that patch.

 

Oracle is pushing Java 8 now, and has even announced that Java 7 downloads will be discontinued in half a year. Of course it will still be available somewhere, but "just use Java 7" is not a good solution any more.

Share this post


Link to post
Share on other sites

Hi, Curunir,

You were right, we dropped the ball with the Java 8 updates. We've updated our packs to support it, and I've been buzzing modpack developers about java 8 support as their packs are reported in the Platform. At some point in the next month I'm going to set a deadline for pack authors to add Java 8 support to be considered a "working" pack, but that is going to be at least a month off, I don't want to force too many changes on them at once.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By NebelC0meback
      Hello people of the Technic community, I've had this problem for around 3 weeks now, and after countless hours of research i couldn't get it to work.
      I've got the following problem:
      I've been using Ubuntu (PoPOS) for around 2 months now, and i got really familiar with it. I got minecraft from the repositories no problem whatsoever. But as i wanted to play with mods, My old friend Technic Launcher came to my mind again, so i tried to install it and play some modpacks.
      Problem:
      I've installed the correct java version (OpenJDK 8 ) and put the techniclauncher.jar as an executable. Now when i run the launcher, the installation screen pops up, everything normal. Now when i install it as a portable or just normally, it creates the directory and the installer dissapears. Everything ok until now: When i try to launch Technic again, it just crashes. The java process is running, but starts dissapearing. So i tried again with oracle Java 11. Same problem. It just crashes. When i launch it over Terminal, it gives me this:
       
      [email protected]:/home/muenzlpsaveyourinternet# java -jar '/home/directory/TechnicLauncher.jar' '/home/directory/TechnicLauncher.jar'
      Settings for exe: /home/directory/TechnicLauncher.jar
      Portable settings dir: /home/directory/technic
      Setting up logging
      And nothing else happens, the terminal doesnt continue launching, same with launching without terminal.Nothing opens , just the process i can see in my system manager
      I tried and tried, i uninstalled the runtimes, 8 and 11, tried and tried but nothing worked. I found no answer, now after 2 weeks of trying, I decided to post this here to get some answers from nice people who like to help in the community.
      If you like to help me, just post solutions or suggestions in the section down, please stay simple with ubuntu stuff since i am really new to linux and just getting started. Thanks for any response.
      (replaced my install directory with directory because its pretty much useless for help and might confuse people)
       
    • By LonkaGaming
      Your world is save in %appdata% .technic>modpacks<select your modpack<saves
    • By FullMetalFerkel
      When I run the TechnicLauncher.exe the first time I can install it and every thing is fine. But when I try to run the TechnicLauncher.exe after the installation it won't open. It doesn't even pop up an error dialog. When I look into the latest log file it show following error:
          > java.lang.NoClassDefFoundError: com/sun/awt/AWTUtilities.
      I googled for a few weeks now and didn't find a solution. Sadly I didn't even found somebody with the same problem.
      I currently have a java JRE 8u211 installed. previously I had some java 10 JDK but thought that would be the problem and deleted it. Since I'm not developing java on this machine I simply installed the 8u211 JRE and hoped this would fix my problem.
      Since AWTUtilities is a standard java class I didn't expect technic launcher to have any issue with it, as long as the launcher can find my java installation. But as far as I know, my environment variables are correctly setup and java should be installed correctly.
      I add the technic launcher error log, and some screenshots about my java installation.
      I hope you guys can help me, and I hope I didn't miss one of the forum rules. Thanks in advance



      techniclauncher_2019-05-31.log
    • By Quizer9O8
      Hello there,
      Since I haven't got any luck of finding a fix or someone mentioning this issue I'll place it down right here.
      A few months ago I have noticed that whenever you're launching a Minecraft modpack from the Technic Launcher Minecraft suddenly hijacks all of the available RAM which causes to freeze the entire computer for 10 - 15 minutes before I'm able to terminate the process manually in Task Manager (Windows 10). Since I have 16GB of RAM in my pc I allocated 8GB of RAM to Minecraft (which should be enough for many modpacks) in the settings shown here below but no matter what is set in the Launcher Options seems to have any effect, it straight up ignores it all together.

      I'm out of ideas and in desperate need for a solution because this issue makes every modpack I have (small or large) unplayable at this point.
    • By Monepoke33
      hello everyone,
      As a modpack owner, I've tried to integrate a github asset link from a release to the modpack direct link option. But it doesn't works. The platform doesn't want to accept my link from an asset linked to the release (except for the "source code" zip link). Has anyone an idea? 
      Thank you very much