Archived

This topic is now archived and is closed to further replies.

  • 0
miskek

Disabling Optifine

Question

Is there anyway to disable Optifine in Technic 6? It causes memory leak on my pc. Thanks in advance.

Share this post


Link to post
Share on other sites

10 answers to this question

Yes actually. The first thing you will need to do is find where technic installed itself. For windows it is AppData\Roaming\.techniclauncher Once there go into the technicssp file, then into the Config file (End result should look like this AppData\Roaming\.techniclauncher\technicssp\config) and then right click any of the .cfg files there. Set them to always open with notepad. Now go to the launcher and hit the mods select button, there should be a list of mods there that you can turn on or off at your leisure.

Share this post


Link to post
Share on other sites

Yes actually. The first thing you will need to do is find where technic installed itself. For windows it is AppData\Roaming\.techniclauncher Once there go into the technicssp file, then into the Config file (End result should look like this AppData\Roaming\.techniclauncher\technicssp\config) and then right click any of the .cfg files there. Set them to always open with notepad. Now go to the launcher and hit the mods select button, there should be a list of mods there that you can turn on or off at your leisure.

Unfortunately optifine isn't listed there.

Share this post


Link to post
Share on other sites

Humm, you're right. I don't see it in the mods folder either. Maybe you could try installing optifine over a vanilla .minecraft and seeing what classes it change? If you remove or revert those changes then it should disable optifine. Seems like you get the hard one. (I was thinking MAtmos Sorry.) Other then that I don't know. Sorry.

Share this post


Link to post
Share on other sites

I tried, but i failed to achieve anything. When i got rid of optifine, new problem occured, something called grassfix won't work without optifine, and i can't find how to disable this grassfix.

Share this post


Link to post
Share on other sites

Click on "mod select" and try disabling the grassfix=true to false. Unsure if this will work but worth trying.

Share this post


Link to post
Share on other sites

- edit -

I think i have found a solution to remove optifine and the better grass fix

I will test it today and post the changes if it works

- end edit -

I am having the same problem, the error i get after removing the optifine class files and changing the setting to false (or removing the option entirely) is:

Minecraft: Minecraft 1.1

OS: Windows XP (x86) version 5.1

Java: 1.7.0_01, Oracle Corporation

VM: Java HotSpot Client VM (mixed mode), Oracle Corporation

LWJGL: 2.4.2

OpenGL: Quadro NVS 160M/PCI/SSE2 version 3.3.0, NVIDIA Corporation

java.lang.NoSuchFieldError: cfgGrassFix

at ModLoader.init(ModLoader.java:838)

at ModLoader.AddAllRenderers(ModLoader.java:189)

at afq.<init>(afq.java:80)

at afq.<clinit>(afq.java:9)

at net.minecraft.client.Minecraft.a(Minecraft.java:316)

at net.minecraft.client.Minecraft.run(Minecraft.java:624)

at java.lang.Thread.run(Unknown Source)

--- END ERROR REPORT 6dd27f5f ----------

Share this post


Link to post
Share on other sites

If you look at bettergrass download you see that it modifies the base minecraft.jar than means part of the mod in the launcher is in the modpack.jar file.. you need to remove it from there to get it out as well..

On a side note one of the intended features to be added to the launcher later is the ability to enable disable the optional mods like before. It will just take time to code up

Share this post


Link to post
Share on other sites

I thought that Optifine helped stop that from happening. I am having memory leaks happen, but that has almost always happened to me on my newer computer. (Newer as in 6 years old compared to almost 10 years old.) Eventually the problem just stops.

Share this post


Link to post
Share on other sites

I got it working last night without optifine, but it was complicated. To make sure everything worked I had to remove optifine from the modpack jar file then reinstall all of the technic mods that are installed in the jar; about 6or7. Works just great now.

I love the new launcher but hope they add the option to remove optifine eventually

Share this post


Link to post
Share on other sites