ungato

Members
  • Content Count

    1
  • Joined

  • Last visited

  1. I was looking into exactly why this happens, digging deep into the source code of Launch4J which the technic launcher uses, and I found that Java 9 uses a different registry key than Java 8 did, which makes Launch4J think you don't have java. This is fixed in a new version of Launch4J, but the technic launcher does not use this version. To work around this, follow these steps: Open Registry Editor. (Windows key + R, type "regedit" then enter). Go here: HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\ Right click JRE and click Export. Save the file somewhere. Find the file, right click it, and click Edit. Notepad should appear. Press Ctrl-H for replace, and replace "JRE" with "Java Runtime Environment". Make sure match case is on. Your file should look like the file below, with some version numbers changed, with it being okay if the MSI section is missing. If it does look like below, press ctrl-S to save and continue to the next step. Double click the file, and click yes to both prompts. Open the technic launcher. Tada! What my file looked like: Windows Registry Editor Version 5.00 [HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment] "CurrentVersion"="9.0.4" "BrowserJavaVersion"="12.0.4.0" [HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\9.0.4] "JavaHome"="C:\\Program Files\\Java\\jre-9.0.4" "RuntimeLib"="C:\\Program Files\\Java\\jre-9.0.4\\bin\\server\\jvm.dll" [HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\9.0.4\MSI] "INSTALLDIR"="C:\\Program Files\\Java\\jre-9.0.4\\" "JU"="" "OEMUPDATE"="" "FROMVERSION"="NA" "PRODUCTVERSION"="9.0.4.0" "EULA"="" "JAVAUPDATE"="1" "AUTOUPDATECHECK"="1" "AUTOUPDATEDELAY"="" "FullVersion"="9.0.4+11" Hope this helps!