BCkid

Members
  • Content Count

    11
  • Joined

  • Last visited

About BCkid

  • Rank
    Member
  • Birthday 08/23/1999
  1. *** You will probly need to due to some of the new mods adding in a new world gen.
  2. Probble not because of some of the new mods it adds, It wil l ned a new map
  3. yea, if you want the old or classic version (If you love it too much or something) you can still have it. But lite is updated to 1.4.6 With updated mods & new mods
  4. The mods are updated, and new mods
  5. Tekkit lite is 1.4.6 !!!! hurayyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy
  6. Only a few things to say... Awesome and tutorials?
  7. i could host a server, but im not 16, message me