Jump to content

Help: Setting up a server

Recommended Posts

I'm trying to set up a server and I'm having an issue. I've set up a normal Minecraft server so all connection issues are fine. I just can't seem launch a Tekkit server. I've followed the tutorial on this page exactly: http://forums.technicpack.net/threads/how-to-set-up-a-tekkit-server-step-by-step-guide-win-7-images.2299/

However, whenever, I try to launch it, I still get what I assume to be a Java error:

C:\Users\Vishal\Downloads\Tekkit_Server_3.0.4>java -Xmx3G -Xms2G -jar Tekkit.jar


182 recipes

27 achievements

22:43:16 [iNFO] Starting minecraft server version 1.2.5

22:43:17 [iNFO] Forge Mod Loader version @MAJOR@.@MINOR@.@REV@.@BUILD@ for Minec

raft @MCVERSION@ loading

22:43:17 [iNFO] Loading mods from C:\Users\Vishal\Downloads\Tekkit_Server_3.0.4\


22:43:17 [sEVERE] java.lang.UnsupportedClassVersionError: net/minecraft/server/m

od_NetherOres : Unsupported major.minor version 51.0

22:43:17 [sEVERE] at java.lang.ClassLoader.defineClass1(Native Method)

22:43:17 [sEVERE] at java.lang.ClassLoader.defineClassCond(Unknown Source)

22:43:17 [sEVERE] at java.lang.ClassLoader.defineClass(Unknown Source)

22:43:17 [sEVERE] at java.security.SecureClassLoader.defineClass(Unknown S


22:43:17 [sEVERE] at java.net.URLClassLoader.defineClass(Unknown Source)

22:43:17 [sEVERE] at java.net.URLClassLoader.access$000(Unknown Source)

22:43:17 [sEVERE] at java.net.URLClassLoader$1.run(Unknown Source)

22:43:17 [sEVERE] at java.security.AccessController.doPrivileged(Native Me


22:43:17 [sEVERE] at java.net.URLClassLoader.findClass(Unknown Source)

22:43:17 [sEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)

22:43:17 [sEVERE] at sun.misc.Launcher$AppClassLoader.loadClass(Unknown So


22:43:17 [sEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)

22:43:17 [sEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)

22:43:17 [sEVERE] at java.lang.Class.forName0(Native Method)

22:43:17 [sEVERE] at java.lang.Class.forName(Unknown Source)

22:43:17 [sEVERE] at cpw.mods.fml.common.Loader.loadModClass(Loader.java:4


22:43:17 [sEVERE] at cpw.mods.fml.common.Loader.attemptFileLoad(Loader.jav


22:43:17 [sEVERE] at cpw.mods.fml.common.Loader.load(Loader.java:375)

22:43:17 [sEVERE] at cpw.mods.fml.common.Loader.loadMods(Loader.java:527)

22:43:17 [sEVERE] at cpw.mods.fml.server.FMLBukkitHandler.onPreLoad(FMLBuk


22:43:17 [sEVERE] at net.minecraft.server.MinecraftServer.init(MinecraftSe


22:43:17 [sEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftSer


22:43:17 [sEVERE] at net.minecraft.server.ThreadServerApplication.run(Sour


22:43:17 [sEVERE] Unexpected exception

java.lang.UnsupportedClassVersionError: net/minecraft/server/mod_NetherOres : Un

supported major.minor version 51.0

at java.lang.ClassLoader.defineClass1(Native Method)

at java.lang.ClassLoader.defineClassCond(Unknown Source)

at java.lang.ClassLoader.defineClass(Unknown Source)

at java.security.SecureClassLoader.defineClass(Unknown Source)

at java.net.URLClassLoader.defineClass(Unknown Source)

at java.net.URLClassLoader.access$000(Unknown Source)

at java.net.URLClassLoader$1.run(Unknown Source)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at java.lang.Class.forName0(Native Method)

at java.lang.Class.forName(Unknown Source)

at cpw.mods.fml.common.Loader.loadModClass(Loader.java:440)

at cpw.mods.fml.common.Loader.attemptFileLoad(Loader.java:497)

at cpw.mods.fml.common.Loader.load(Loader.java:375)

at cpw.mods.fml.common.Loader.loadMods(Loader.java:527)

at cpw.mods.fml.server.FMLBukkitHandler.onPreLoad(FMLBukkitHandler.java:


at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:118)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:426)

at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)

If anyone could recognize what is going on and help solve the problem, It would be much appreciated.

Link to comment
Share on other sites

command prompt


01:50:03 [iNFO] Stopping server

01:50:03 [sEVERE] java.lang.IndexOutOfBoundsException: Index: 0, Size: 0

01:50:03 [sEVERE] at java.util.ArrayList.RangeCheck(Unknown Source)

01:50:03 [sEVERE] at java.util.ArrayList.get(Unknown Source)

01:50:03 [sEVERE] at net.minecraft.server.MinecraftServer.stop(MinecraftSe


01:50:03 [sEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftSer


01:50:03 [sEVERE] at net.minecraft.server.ThreadServerApplication.run(Sour


01:50:03 [iNFO] Stopping server


Link to comment
Share on other sites

I meant at the system command prompt, not the server command prompt. Also, there's a space between the word java and the dash.

My next advice is likely to be the same anyway: You probably actually have multiple Java versions installed. Uninstall *all* versions of Java on your computer, then install the latest version, which is version 7 update 5 or 1.7 update 5 (same thing)

Link to comment
Share on other sites

Glad it worked for you :)

For future readers who stumble across this post:

How do I know if i have uninstalled every version?

Just keep uninstalling versions of Java until there aren't any versions left in the Programs and Features window to uninstall

Link to comment
Share on other sites

Alright, so I followed what you said and it worked like a charm. The server set up perfectly but now, The technic launcher isn't working because my java is the wrong version. Should I uninstall the java version I just installed and try to install a slightly older version or should I do something else?

Link to comment
Share on other sites

Alright! Finally got it to work. Thank you so much. If it weren't for you, I would probably still be tearing my hair out trying to figure it out. I hope this thread will help anyone else who has this problem.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...