Jump to content

Adding mod ModernWarfare v1.0.4 (forge version) to Tekkit?


Recommended Posts

Hello I was wondering if anyone could help me with some errors I have been getting while trying to add ModernWarfare v1.0.4 to the Tekkit client and to a server. As of this post, I have not even tried adding the mod to the server. I started with the client in the .techniclauncher folder. I placed the mod in the mods folder under the tekkit mod folder, and tried to run the game. I get this crash error when trying to launch the game:

Mods loaded: 39

ModLoader 1.2.5

mod_CodeChickenCore 0.5.2

mod_MinecraftForge 3.1.3.107

mod_NotEnoughItems 1.2.2

mod_ReiMinimap v3.0_04 [1.2.5]

mod_BuildCraftCore 2.2.14

mod_BuildCraftBuilders 2.2.14

mod_BuildCraftEnergy 2.2.14

mod_BuildCraftFactory 2.2.14

mod_BuildCraftTransport 2.2.14

mod_AdditionalPipes 2.1.3 (Minecraft 1.2.5, Buildcraft 2.2.14, Forge 3.0.1.75)

mod_ComputerCraft 1.33

mod_CCTurtle 1.33

mod_CraftingTableIII (Beta1.8, MC1.2.5)

mod_EE 1.4.5.1

mod_EnderStorage 1.1.1

mod_IC2NuclearControl v1.1.6

mod_ImmibisCore 48.2.1

mod_IC2 v1.95

mod_PowerConverters 1.2.5R1.3.4

mod_IC2AdvancedMachines v4.0

mod_InvTweaks 1.41b (1.2.4)

mod_MAtmos_forModLoader r12 for 1.1.x

mod_IC2_ChargingBench 1.95b

mod_CompactSolars 2.2

mod_IronChest 3.3

mod_Railcraft 5.2.4

mod_RedPowerControl 2.0pr5b2

mod_RedPowerCore 2.0pr5b2

mod_NetherOres 1.2.5R1.2.2

mod_RedPowerLighting 2.0pr5b2

mod_RedPowerLogic 2.0pr5b2

mod_RedPowerMachine 2.0pr5b2

mod_RedPowerWiring 2.0pr5b2

mod_RedPowerWorld 2.0pr5b2

mod_TubeStuff 48.2.1

mod_WirelessRedstoneCore 1.2.1

mod_WirelessRedstoneRedPower 1.2.1.1

mod_WirelessRedstoneAddons 1.2.1

Minecraft has crashed!

----------------------

Minecraft has stopped running because it encountered a problem.

--- BEGIN ERROR REPORT 8ad75b87 --------

Generated 7/22/12 5:10 PM

Minecraft: Minecraft 1.2.5

OS: Windows 7 (amd64) version 6.1

Java: 1.7.0_03, Oracle Corporation

VM: Java HotSpot 64-Bit Server VM (mixed mode), Oracle Corporation

LWJGL: 2.4.2

OpenGL: GeForce GT 445M/PCI/SSE2 version 4.0.0, NVIDIA Corporation

java.lang.RuntimeException: RedPowerCore: BlockID 133 occupied by uberkat.war.BlockGrapplingHook, autoAssign is disabled.

at forge.MinecraftForge.killMinecraft(MinecraftForge.java:483)

at eloraam.core.Config.getBlockID(Config.java:114)

at RedPowerControl.initialize(RedPowerControl.java:22)

at mod_RedPowerControl.initialize(mod_RedPowerControl.java:38)

at mod_RedPowerControl.modsLoaded(mod_RedPowerControl.java:19)

at ModLoader.init(ModLoader.java:899)

at ModLoader.addAllRenderers(ModLoader.java:189)

at ahu.<init>(RenderManager.java:86)

at ahu.<clinit>(RenderManager.java:14)

at net.minecraft.client.Minecraft.a(Minecraft.java:394)

at net.minecraft.client.Minecraft.run(Minecraft.java:732)

at java.lang.Thread.run(Unknown Source)

--- END ERROR REPORT 56cadf78 ----------

So once I get here I see that the line java.lang.RuntimeException: RedPowerCore: BlockID 133 occupied by uberkat.war.BlockGrapplingHook... I realized that the new ModernWarfare mod was conflicting with Redpower. So I went to the redpower.cfg file under the redpower folder to reassign the block id. I tried reassigning the block id and after getting parse errors and id out of range errors I tried using redpower's autoassign to fix the block id conflict, but I also got this parse error there:

--- BEGIN ERROR REPORT 8ad75b87 --------

Generated 7/22/12 5:05 PM

Minecraft: Minecraft 1.2.5

OS: Windows 7 (amd64) version 6.1

Java: 1.7.0_03, Oracle Corporation

VM: Java HotSpot 64-Bit Server VM (mixed mode), Oracle Corporation

LWJGL: 2.4.2

OpenGL: GeForce GT 445M/PCI/SSE2 version 4.0.0, NVIDIA Corporation

java.lang.IllegalArgumentException: Parse error

at eloraam.core.TagFile.readtag(TagFile.java:249)

at eloraam.core.TagFile.readtag(TagFile.java:261)

at eloraam.core.TagFile.readtag(TagFile.java:261)

at eloraam.core.TagFile.readStream(TagFile.java:309)

at eloraam.core.TagFile.readFile(TagFile.java:288)

at eloraam.core.Config.loadConfig(Config.java:29)

at RedPowerCore.initialize(RedPowerCore.java:92)

at WirelessRedstoneRedPower.initialize(WirelessRedstoneRedPower.java:37)

at mod_WirelessRedstoneRedPower.load(mod_WirelessRedstoneRedPower.java:11)

at ModLoader.init(ModLoader.java:891)

at ModLoader.addAllRenderers(ModLoader.java:189)

at ahu.<init>(RenderManager.java:86)

at ahu.<clinit>(RenderManager.java:14)

at net.minecraft.client.Minecraft.a(Minecraft.java:394)

at net.minecraft.client.Minecraft.run(Minecraft.java:732)

at java.lang.Thread.run(Unknown Source)

--- END ERROR REPORT d16918c ----------

Not sure how to reassign the block id without getting a parse error. The install for this did not take any time at all, very small mod file. Is anyone willing to try and fix this for me or help offer solutions? I spent a lot of timing on different forums, including this forum, the buildcraft forum (since buildcraft also has id conflict problems with redpower), and the actual redpower forum. No luck, I tried all of their suggestions, including deleting the .cfg file to get a fresh one. No help there, didn't fix the problem. Any suggestions? Thanks.

EDIT- forgot to mention that I chose the forge version of the ModernWarfare v1.0.4 because I read that the Modloader version would not work on Tekkit. Can anyone clarify this problem for me at all? Thanks again.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...