Jump to content

Tekkit Server not working on Linux


Recommended Posts

Hi guys,

I have been playing IC2 and buildcraft now for a long time and i did always mod server myself. im quite happy i found tekkit, but currently its kind of annoying me.

So if i run a tekkit server on my PC it works perfectly fine. But when i upload all files to my root server and bash the launch.sh it gives me following error:

2012-07-31 09:13:35 [iNFO] Starting minecraft server version 1.2.5

.......

2012-07-31 09:16:58 [iNFO] [iC2] Config loaded from /home/mc2/./config/IC2.cfg

2012-07-31 09:16:58 [sEVERE] java.lang.IllegalArgumentException: Slot 241 is already occupied by [email protected] when adding [email protected]

2012-07-31 09:16:58 [sEVERE]at net.minecraft.server.Block.<init>(Block.java:181)

2012-07-31 09:16:58 [sEVERE]at net.minecraft.server.BlockFlower.<init>(SourceFile:11)

2012-07-31 09:16:58 [sEVERE]at net.minecraft.server.BlockFlower.<init>(SourceFile:19)

2012-07-31 09:16:58 [sEVERE]at net.minecraft.server.BlockSapling.<init>(BlockSapling.java:18)

2012-07-31 09:16:58 [sEVERE]at ic2.common.BlockRubSapling.<init>(BlockRubSapling.java:14)

2012-07-31 09:16:58 [sEVERE]at net.minecraft.server.mod_IC2.load(mod_IC2.java:289)

2012-07-31 09:16:58 [sEVERE]at cpw.mods.fml.common.modloader.ModLoaderModContainer.init(ModLoaderModContainer.java:351)

2012-07-31 09:16:58 [sEVERE]at cpw.mods.fml.common.Loader.modInit(Loader.java:263)

2012-07-31 09:16:58 [sEVERE]at cpw.mods.fml.common.Loader.initializeMods(Loader.java:618)

2012-07-31 09:16:58 [sEVERE]at cpw.mods.fml.server.FMLBukkitHandler.onLoadComplete(FMLBukkitHandler.java:142)

2012-07-31 09:16:58 [sEVERE]at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:176)

2012-07-31 09:16:58 [sEVERE]at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:438)

2012-07-31 09:16:58 [sEVERE]at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)

2012-07-31 09:16:58 [sEVERE] Unexpected exception

java.lang.IllegalArgumentException: Slot 241 is already occupied by [email protected] when adding [email protected]

at net.minecraft.server.Block.<init>(Block.java:181)

at net.minecraft.server.BlockFlower.<init>(SourceFile:11)

at net.minecraft.server.BlockFlower.<init>(SourceFile:19)

at net.minecraft.server.BlockSapling.<init>(BlockSapling.java:18)

at ic2.common.BlockRubSapling.<init>(BlockRubSapling.java:14)

at net.minecraft.server.mod_IC2.load(mod_IC2.java:289)

at cpw.mods.fml.common.modloader.ModLoaderModContainer.init(ModLoaderModContainer.java:351)

at cpw.mods.fml.common.Loader.modInit(Loader.java:263)

at cpw.mods.fml.common.Loader.initializeMods(Loader.java:618)

at cpw.mods.fml.server.FMLBukkitHandler.onLoadComplete(FMLBukkitHandler.java:142)

at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:176)

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:438)

at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)

2012-07-31 09:17:47 [sEVERE] null

java.io.IOException: Input/output error

at java.io.FileInputStream.readBytes(Native Method)

at java.io.FileInputStream.read(FileInputStream.java:242)

at java.io.BufferedInputStream.fill(BufferedInputStream.java:235)

at java.io.BufferedInputStream.read(BufferedInputStream.java:254)

at java.io.FilterInputStream.read(FilterInputStream.java:83)

at jline.console.ConsoleReader$1.read(ConsoleReader.java:167)

at jline.internal.InputStreamReader.read(InputStreamReader.java:267)

at jline.internal.InputStreamReader.read(InputStreamReader.java:204)

at jline.console.ConsoleReader.readCharacter(ConsoleReader.java:995)

at jline.console.ConsoleReader.readLine(ConsoleReader.java:1167)

at net.minecraft.server.ThreadCommandReader.run(ThreadCommandReader.java:31)

(end of server.log)

Okay it is clearly visible that slot 241 (blockrubsapling) is occupied by the enderstoragechest. so I changed the enderstorage.cfg and gave her the id 178. Now upon restarting the server it gives me the exact same error and as I look up the enderstorage.cfg, the server changed the enderchests id again to 241.

Thank you for your time

Link to comment
Share on other sites

Same problem, I assume those cfg files are generated on first run from the mod zip files hence not being able to manually change the values for either 'blockRubSapling=241' or 'block.id=241'.

However ... :) I copied my config file folder from my previous working server into the new folder and poof! as if by magic. I suggest you try the same :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...